Contribute
Register

USB Mass Storage not working on Catalina Z390 OpenCore Build (jmPeripheralDeviceType00 error)

Joined
Apr 28, 2020
Messages
2
Motherboard
Gigabyte Z390-UD
CPU
i5-9600K
Graphics
RX 5500 XT
Hi,
I am running 10.15.4 on OC 0.58 on a GigaByte Z390UD, I have Catalina 10.15.4 installed. The build is running great but I have been trying to fix this issue for weeks to no avail.

All of my USB ports work at full speed for most of my devices, however USB mass storage devices don't work. They show up in IOReg and system report but not in finder or disk utility. Interestingly, my QNAP TR004 USB RAID enclosure works fine. This behaviour is the same on every port. When I boot into the MacOS installer from a USB, the devices are recognized fine using disk utility there.

When I boot into MacOS with one of these "unsupported" devices plugged in, I get barraged with the following message over and over again before it boots: jmPeripheralDeviceType00[<ptr>]: GetChipFlashStatus command failed - Unsupported Device !

I've attached my EFI, as well as a log from my most recent boot. I've also attached a picture of my IOReg Explorer showing entries for a device that works and one that doesn't, it seems the working device has an entry for jmPeripheralDeviceType00 with children, but the entry for the device that doesn't work has no children. I'm not sure what this means.

My original build consisted of an ASUS Prime Z370PII, which I replaced because of this issue. I though it was hardware related but the issue persisted when I switched to the Z390 and updated OC.

I am fairly confident that I have a proper USB Map working (I've tried hackintool as well as USBMap Tool by corpnewt), so I don't think it's causing the issue. I've also tried XHCIUnsupported.kext which did nothing.

Does anyone know what might be causing this issue? My hack is so close to being perfect and I've been hung up on this problem for weeks.
 
Last edited:
Top