Contribute
Register

USB HDD not detected by macOS from cold boot

Status
Not open for further replies.
Joined
Sep 22, 2010
Messages
170
Motherboard
ASUS PRIME Z390-A
CPU
i7-9700K
Graphics
Vega 64
Hi everyone,

I have a USB Flash and USB HDD plugged into my machine when I power up but macOS only sees the flash drive, not the hdd. I have to unplug and replug my HDD each time.

Any idea how to get the USB HDD to be seen by macOS after booting? It's my Time Machine drive and it's a small nuisance to unplug/replug each time I boot.

Mobo = ASUS Prime Z270-P
USB HDD = WD My Passport 0730

Thanks!
 
Joined
Sep 9, 2010
Messages
456
Motherboard
Asrock Z490m pro-4
CPU
i9-10850K
Graphics
Vega 64 (flashed Vega 56)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
If you go into Disk Utility after cold boot, does the drive show up, but the volume unmounted (greyed out), or does the drive not show up at all until unplugged?
 
Joined
Sep 22, 2010
Messages
170
Motherboard
ASUS PRIME Z390-A
CPU
i7-9700K
Graphics
Vega 64
Hi, no, doesn't show in Disk Utility. I have a second, newer HDD - WD My Passport 0827 that does load properly from cold boot. Wondering if it's the drive and not the computer? Also wondering the 0827 is ExFAT and 0730 is Extended (Journaled). Wondering if that could have something to do with it too?
 
Joined
Sep 22, 2010
Messages
170
Motherboard
ASUS PRIME Z390-A
CPU
i7-9700K
Graphics
Vega 64
ok....pretty sure it's the drive. perhaps the 0730 is too old. I tried formatting to ExFAT and it still won't recognize on boot. The 0827 loads every time. Guess it's time to buy a new USD HDD.
 
Status
Not open for further replies.
Top