Contribute
Register

USB drives Not Properly Ejected on wake from sleep. [Yet another solution but this one is free!]

Joined
Nov 28, 2016
Messages
7
Motherboard
Gigabyte GA-Z170X-Gaming 5
CPU
Intel Core i7 6700K
Graphics
MSI GTX 970 4GD5T OCV1
Mac
iMac
Mobile Phone
Android
I am sorry that the script by @shilohh does not work for my Sierra 10.12.3 Hackintosh. The message "Disk not ejected properly" still pops up for my plugged-in USB thumb drive after I installed the script and experimented with sleep and wake. What should I do to trace the issue? Thanks a lot.

My build has the following main components:

Mobo: Gigabyte GA-Z170X-Gaming 5
CPU: Intel Core i7 6700K
GPU: MSI GTX 970 4GD5T OCV1
RAM: Crucial Ballistix Tactical DDR4-3000 8G*4
SSD: Crucial MX300 750GB
WiFi: BCM94360CD PCI-E/AC68 card
Bluetooth USB dongle: PCi (Planex) BT-MicroEDR2x
 

shilohh

Moderator
Joined
Jan 2, 2012
Messages
1,769
Motherboard
Asus Rampage IV Black Edition
CPU
4930K @ 4.4GHz
Graphics
PNY GTX 980 + EVGA Titan X
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
I am sorry that the script by @shilohh does not work for my Sierra 10.12.3 Hackintosh. The message "Disk not ejected properly" still pops up for my plugged-in USB thumb drive after I installed the script and experimented with sleep and wake. What should I do to trace the issue? Thanks a lot.

My build has the following main components:

Mobo: Gigabyte GA-Z170X-Gaming 5
CPU: Intel Core i7 6700K
GPU: MSI GTX 970 4GD5T OCV1
RAM: Crucial Ballistix Tactical DDR4-3000 8G*4
SSD: Crucial MX300 750GB
WiFi: BCM94360CD PCI-E/AC68 card
Bluetooth USB dongle: PCi (Planex) BT-MicroEDR2x
I haven't messed with this one in a long time. I don't need it with my X79 machines in 10.12. I'd guess that the script needs to be installed to a new location in Sierra. Just guessing though.
 
Joined
Sep 1, 2016
Messages
303
Motherboard
GA-Z170N Gaming 5
CPU
i7-6700K
Graphics
RX 580
The script is still working great for me 90% of the time on the Gigabyte system, but every now and again it will inexplicably revert to a self-wake, bad eject cycle. Again, is there any log at which I can look and/or post after this happens to diagnose this random occurrence?
 
Joined
Feb 26, 2011
Messages
42
Motherboard
GA-Z170X-UD3
CPU
i7 6700K @4.5GHz
Graphics
NVIDIA GeForce 1080 GTX Zotac Extreme
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android
i had this problem on my z170x-ud3 10.12.5, then i found the culprit!

When i disable xmp profile in bios, usb sleep wake is fine without any improper eject message!

When i enable xmp profile1 again in bios, symptoms come again! Usb not properly ejected after wake.

So do you have thoughts on this?
 
Joined
Oct 3, 2010
Messages
2
Motherboard
Snow
CPU
Core 2 Duo
Graphics
ATI
Mac
Classic Mac
Mobile Phone
Thanks a lot!
working here with Z77X UD5H and AMD Radeon R9 370X 4 GB on High Sierra 10.13.3
 
Top