Contribute
Register

Solved > USB Audio Interface Artifacts and Dropouts

Joined
Nov 13, 2010
Messages
57
Motherboard
Asus X299 Prime Deluxe II
CPU
i9-10980XE
Graphics
Radeon VII
Mac
  1. MacBook Pro
Classic Mac
  1. 128K
  2. 512K
  3. Apple
  4. Classic
  5. iBook
  6. Performa
  7. Power Mac
  8. PowerBook
  9. SE
Mobile Phone
  1. iOS
I started having audio dropouts and static on my USB Alesis Multimix after upgrading from 11 to 11.1. I've had this mixer since 10.13 and it's always just worked, so this was a new behavior.

It seemed to be tied to the GPU usage (Radeon VIIs) and coreaudiod would crash after a few minutes. After a few days of messing around, simply moving the mixer to it's own USB 2.0 port on the motherboard solved everything.
 
Joined
Nov 10, 2016
Messages
7
Motherboard
Asus Prime Z390-A
CPU
i9 9900k
Graphics
Sapphire Radeon Vega 64
Mac
  1. iMac
  2. MacBook Pro
The journey continues...
I reverted back to Catalina and the issue went away.

I have repurposed an old drive as a test install and installed a fresh version of Big Sur 11.1. The stuttering was still there.

I changed the SMBIOS just now to MacPro 7,1 and the audio works great. However I am now getting a memory error and my Bluetooth has stopped working.

just got to find solutions to those issues now, but it’s progress on the audio, so I am happy.
 
Joined
Sep 9, 2010
Messages
390
Motherboard
Asrock Z490m pro-4
CPU
i9 10850K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
The journey continues...
I reverted back to Catalina and the issue went away.

I have repurposed an old drive as a test install and installed a fresh version of Big Sur 11.1. The stuttering was still there.

I changed the SMBIOS just now to MacPro 7,1 and the audio works great. However I am now getting a memory error and my Bluetooth has stopped working.

just got to find solutions to those issues now, but it’s progress on the audio, so I am happy.
how weird. My issue started with Catalina. How much RAM do you have? I ask because back when I was wrestling with this problem, It seems like the issue would be most prevalent when my RAM usage went up. I upgraded from 16 to 32GB and it dramatically helped. It seems illogical but if you're eyeing an upgrade already, it could be worth a try.
 
Joined
Jul 4, 2012
Messages
372
Motherboard
Gigabyte Aorus Z390 Ultra
CPU
i5-9600K
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
The journey continues...
I reverted back to Catalina and the issue went away.

I have repurposed an old drive as a test install and installed a fresh version of Big Sur 11.1. The stuttering was still there.

I changed the SMBIOS just now to MacPro 7,1 and the audio works great. However I am now getting a memory error and my Bluetooth has stopped working.

just got to find solutions to those issues now, but it’s progress on the audio, so I am happy.

I know it's not sexy, but Mac mini is closer than Mac Pro.
 
Joined
Nov 10, 2016
Messages
7
Motherboard
Asus Prime Z390-A
CPU
i9 9900k
Graphics
Sapphire Radeon Vega 64
Mac
  1. iMac
  2. MacBook Pro
how weird. My issue started with Catalina. How much RAM do you have? I ask because back when I was wrestling with this problem, It seems like the issue would be most prevalent when my RAM usage went up. I upgraded from 16 to 32GB and it dramatically helped. It seems illogical but if you're eyeing an upgrade already, it could be worth a try.
I have 64GB installed. Thanks for your suggestion. I did remove a few sticks to see if that helped on Big Sur, but to no avail.
 
Joined
Nov 10, 2016
Messages
7
Motherboard
Asus Prime Z390-A
CPU
i9 9900k
Graphics
Sapphire Radeon Vega 64
Mac
  1. iMac
  2. MacBook Pro
I know it's not sexy, but Mac mini is closer than Mac Pro.
Would that have any effect on hardware acceleration etc? Also hoping to upgrade to a 6800xt once they are compatible, will that effect that?

I will give Mac mini a try though, and see how it works.

Thanks
 
Top