USB 3.0 devices are not working after updating to High Sierra using APFS+

Discussion in 'Hardware Troubleshooting' started by luvlastcall, Oct 4, 2017.

  1. luvlastcall

    luvlastcall

    Joined:
    Jul 27, 2012
    Messages:
    34
    Mobo:
    GA-Z97X-UD3H BK
    CPU:
    I5 4690K Processor
    Graphics:
    Intel Iris 6100
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Oct 4, 2017 at 4:48 PM #1
    luvlastcall

    luvlastcall

    Joined:
    Jul 27, 2012
    Messages:
    34
    Mobo:
    GA-Z97X-UD3H BK
    CPU:
    I5 4690K Processor
    Graphics:
    Intel Iris 6100
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Hello

    I would like some one to help me with the USB 3.0 issues.

    Thanks
     
  2. neoxlefou

    neoxlefou

    Joined:
    Dec 13, 2015
    Messages:
    18
    Mobo:
    Asus Z97-A
    CPU:
    i7-4790K
    Graphics:
    Asus GTX1080 Turbo 8Go
    Mac:
    MacBook Air, MacBook Pro
    Mobile Phone:
    Android
    Oct 31, 2017 at 6:32 PM #2
    neoxlefou

    neoxlefou

    Joined:
    Dec 13, 2015
    Messages:
    18
    Mobo:
    Asus Z97-A
    CPU:
    i7-4790K
    Graphics:
    Asus GTX1080 Turbo 8Go
    Mac:
    MacBook Air, MacBook Pro
    Mobile Phone:
    Android
    Nearly same setup here (Z97-a, core i7)
    I did not checked with sierra, but on high sierra my usb3 are working fine in usb2 mode (with keyboard, mouse, usb2 drive, and even with usb3 drive plug through usb2 wire)
    i'm still looking at solution.

    according to some post it may be related on "3rd party USB3" being present or not in a setup with/without 3rd party chipset
     
  3. emanuelediba

    emanuelediba

    Joined:
    Aug 7, 2015
    Messages:
    12
    Mobo:
    MSI Z97 Gaming 3
    CPU:
    i5 4690K
    Graphics:
    GTX 1060
    Mobile Phone:
    iOS
    Nov 3, 2017 at 6:01 PM #3
    emanuelediba

    emanuelediba

    Joined:
    Aug 7, 2015
    Messages:
    12
    Mobo:
    MSI Z97 Gaming 3
    CPU:
    i5 4690K
    Graphics:
    GTX 1060
    Mobile Phone:
    iOS
    Hi, I also have a similar setup (Z97, i5), and normally to fix I used to install "7/8/9 Series USB Support" through multibeast, but now I have updated to High Sierra, and multibeast for high Sierra isn't out yet. I found out that we need to install FakePCIID.kext and FakePCIID_XHCIMux.kext. I found them on this site: https://bitbucket.org/RehabMan/os-x-fake-pci-id/downloads/ I think this is the creators site, but my main question is if they work with High Sierra.
     
  4. BreBo

    BreBo Moderator

    Joined:
    Oct 17, 2011
    Messages:
    5,611
    Mobo:
    Gigabyte GA-Z87X-OC
    CPU:
    Intel Core i7-4770K
    Graphics:
    Asus Strix GTX 970
    Nov 3, 2017 at 8:21 PM #4
    BreBo

    BreBo Moderator

    Joined:
    Oct 17, 2011
    Messages:
    5,611
    Mobo:
    Gigabyte GA-Z87X-OC
    CPU:
    Intel Core i7-4770K
    Graphics:
    Asus Strix GTX 970
    Yes they work in macOS High Sierra.
     

Share This Page