Contribute
Register

Upgrading to ML 10.8.4 from SL 10.6.8 fails on Sony VGN-AW11Z

Joined
Jun 18, 2013
Messages
46
Motherboard
Sony VGN-AW11Z / Motherboard Intel PM45
CPU
Intel Mobile Core 2 Duo T9400
Graphics
GeForce 9600M GT 512 MB
Mac
Classic Mac
Mobile Phone
There is an AppleYukon2.kext in /S/L/E/IONetworkingFamily.kext/Contents/PlugIns. You might be able to use it..

Yes I've already seen that kext there, though I don't get your point about "I might be able to use it"... As far as I see there's no way for me as a system user to instruct which kext should be used for my ethernet as ALL these kext things get loaded at the boot time and the ones recognizing the device they can support, will make it possible to interact with that given device whatsoever, e.g. a Bluetooth device as one clicks on System Preferences ==> Bluetooth etc. right?!

To be fair the problem is that under System Preferences ==> Network I DO see my Ethernet on the left column as well as my Firewire BUT although the ethernet cable is connected it says that it is unplugged (and with no surprise using Safari I can't get into the Web). What also doesn't work as well is my WI-FI which is another story (works perfectly under Windows 7) but in contrast to Ethernet the Wi-Fi doesn't even get enlisted on the left column of Network devices.

Would need to know the PCI ids of your card. Perhaps DSDT and IOreg dump

I've attached these two in the hope these are the ones you've asked for...

Thanks again!
 

Attachments

  • DSDT.aml
    23.4 KB · Views: 73
  • Sony-VGN-AW11Z’s Mac Pro.zip
    350.4 KB · Views: 44

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Yes I've already seen that kext there, though I don't get your point about "I might be able to use it"... As far as I see there's no way for me as a system user to instruct which kext should be used for my ethernet as ALL these kext things get loaded at the boot time and the ones recognizing the device they can support, will make it possible to interact with that given device whatsoever, e.g. a Bluetooth device as one clicks on System Preferences ==> Bluetooth etc. right?!

To be fair the problem is that under System Preferences ==> Network I DO see my Ethernet on the left column as well as my Firewire BUT although the ethernet cable is connected it says that it is unplugged (and with no surprise using Safari I can't get into the Web). What also doesn't work as well is my WI-FI which is another story (works perfectly under Windows 7) but in contrast to Ethernet the Wi-Fi doesn't even get enlisted on the left column of Network devices.



I've attached these two in the hope these are the ones you've asked for...

Thanks again!

What I mean by "use it" is check the device ids to see if they match. Your device id is 11ab:4363 (you can see it in ioreg PCI0/RP01/PXSX). And looking at the Info.plist in AppleYukon2.kext/Contents/Info.plist... it is a match (Yukon-88E8055). So... that driver should be loading. But if you look in IOreg you will see there is no driver attached to that device. So perhaps it is finding something it doesn't like startup. You should probably check your kernel.log for any clues.

What kind of WiFi do you have? You can check with DPCIManager or 'lspci -nn' on Linux. If you don't have one that is supported by OS X, then it is best to just replace it (assuming your BIOS has no whitelist).
 
Joined
Jun 18, 2013
Messages
46
Motherboard
Sony VGN-AW11Z / Motherboard Intel PM45
CPU
Intel Mobile Core 2 Duo T9400
Graphics
GeForce 9600M GT 512 MB
Mac
Classic Mac
Mobile Phone
What kind of WiFi do you have? You can check with DPCIManager or 'lspci -nn' on Linux. If you don't have one that is supported by OS X, then it is best to just replace it (assuming your BIOS has no whitelist).

I could live without Ethernet completely if my WiFi would work. I've got "Intel WiFi Link 5100 AGN" which I assume is not supported at all (no kext being available).

So which USB-WiFi connector label would you recommend me to buy being supported by ML 10.8.4? A really good and fast one...

Thanks
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I could live without Ethernet completely if my WiFi would work. I've got "Intel WiFi Link 5100 AGN" which I assume is not supported at all (no kext being available).

Correct. There is no support available for Intel WiFi in OS X. Replace it with a compatible card if possible. Does your laptop implement a BIOS whitelist for WIFI cards?

So which USB-WiFi connector label would you recommend me to buy being supported by ML 10.8.4? A really good and fast one...

I don't have a recommendation as I don't use one. I would try first to replace the internal WiFi...
 
Joined
Jun 18, 2013
Messages
46
Motherboard
Sony VGN-AW11Z / Motherboard Intel PM45
CPU
Intel Mobile Core 2 Duo T9400
Graphics
GeForce 9600M GT 512 MB
Mac
Classic Mac
Mobile Phone
Replace it with a compatible card if possible. Does your laptop implement a BIOS whitelist for WIFI cards

Is there a list of compatible (natively supported) WiFi cards available for ML so that I could buy one of them? And how can I find out if my laptop implements BIOS whitelist for WIFI cards?!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Is there a list of compatible (natively supported) WiFi cards available for ML so that I could buy one of them?

This post (and its links) might help: http://www.tonymacx86.com/hp-probook/97099-wi-fi-bluetooth-cards-laptops-mac-os-os-x.html

And how can I find out if my laptop implements BIOS whitelist for WIFI cards?!

Google... perhaps.

Otherwise, if you have a spare card laying around (perhaps out of another laptop you own), you could try it. Also you could see if you can download the service manual for your laptop, since sometimes details like that are documented there.
 
Joined
Jun 18, 2013
Messages
46
Motherboard
Sony VGN-AW11Z / Motherboard Intel PM45
CPU
Intel Mobile Core 2 Duo T9400
Graphics
GeForce 9600M GT 512 MB
Mac
Classic Mac
Mobile Phone
Hi

I bought a TP-Link TL-WN823N adaptor and installed the matching driver according to this post and it works.

Once again thanks for all your help!
 
Top