Contribute
Register

Upgrading an older build to El Capitan - mostly successful

Status
Not open for further replies.
Joined
Jul 5, 2012
Messages
26
Motherboard
Gigabyte Designare Z390-F6
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Classic
  2. Xserve
Mobile Phone
  1. iOS
Hi.. Five years ago I built essentially Tagny Daggarts Build: i7-3770K - GA-Z77X-UD5H with 32gb Ram and a XFX 6870. The 6870 drives 3 - 30" monitors at 2560x1600 for a Photoshop heavy installation. It finally was old enough (10.8) that the client asked me to upgrade.. I chose 10.11 to install as it seems to have the most successes.

I followed all the guides here posted here, and used Multibeast:

Quick Start > UEFI Boot Mode
Drivers > Audio > Realtek ALCxxx > ALC898
Drivers > Disk > 3rd Party SATA
Drivers > Disk > 3rd Party eSATA
Drivers > Disk > Intel Generic AHCI SATA
Drivers > Misc > FakeSMC v6.18-313-g671f31c.1707
Drivers > Misc > FakeSMC Plugins v6.18-313-g671f31c.1707
Drivers > Misc > FakeSMC HWMonitor Application v6.18-313-g671f31c.1707
Drivers > Network > Atheros > AtherosE2200Ethernet v2.2.0d0
Drivers > USB > 3rd Party USB 3.0
Drivers > USB > 7/8/9 Series USB Support
Bootloaders > Clover v2.3k r3423 UEFI Boot Mode
Customize > System Definitions > iMac > iMac 12,2

I have tried 3,1 and 13,2

More or less everything works, but I have one issue, that is out of my league. I am hoping someone here can give me direction, or just tell me what I have done wrong.

I have 2 SSD's on Intel 0/1 SATA ports on the MB, they both mount and work properly, 0(Boot), 1(cache files) . I have a 3rd internal drive on Intel SATA port 2 that also mounts (Time Machine). I have 3 external Raid 5 Arrays connected to Marvell Ports 6,7 & 8. They will auto mount anytime after I have originally booted with no problem. The problem is the 4th Raid Array that is connected to Intel SATA Port 3. It will only mount if I reboot the machine once I have turned the Raid on.. I have tried all the Raids on the Intel ports and none of them will mount on power on unless I restart the box. The 4th Raid will auto mount on a Marvel port.. so it is a port issue not a Raid Box issue. All of the Raid units are various versions of OWC Raid Boxes.

https://eshop.macsales.com/shop/hard-drives/RAID/Desktop/

I did not have this problem on 10.8, all drives would auto mount. I assume it is a Kext mismatch or conflict of them or I am missing something, But I am at a loss of what to try next.

What Works:

All Three 30" monitors @2560x1600 Two Apple Cinema displays and a Dell Ultrasharp.
USB2/USB3 (Wacom tablet, USB Hard Drives, CF/SD Card reader, Bluetooth Dongle) works, Ethernet works
Audio works for system things sounds, have not tested deeper.
Sleep seems to work, but I need to further test, as I have had too many permutations in play, Machine powers off correctly.
Last MacBench was in the 14,000 range.. So I am happy with performance..
Don't use iMessage, so have not. all not test for this.

AN ODD PROBLEM I SOLVED.. When I brought the system online the first time.. it sputtered and died.. With so many things connected directly to the MB I thought we had fried the Corsair 650 PS or the MB.. We got a new PS, and still no life.. the onboard power switch on the Mobo.. would blink briefly.. but not turn on.. Searching the net gave me a clue.. I replaced the MB CMOS battery: CR2032 and even though the old one tested good at 3V, the new battery brought the machine to life..

Thanks in Advance
 
Status
Not open for further replies.
Top