Contribute
Register

Upgraded GPU, updated to Catalina; sleep now causes crash

Status
Not open for further replies.
Joined
Sep 19, 2018
Messages
18
Motherboard
ASUSTeK Z170-A
CPU
i5-6600K
Graphics
RX 5700 XT
Hey all, I got an RX 5700 XT as an upgrade from my old 1060. I was on High Sierra because of the 1060, so once I got the RX, I updated my kexts, updated macOS, then swapped the cards. Bluetooth wasn't working initially, so I edited the SMBIOS and then added the two new bluetooth patch kexts.

Everything is working now except one thing: sleeping. Whenever my computer tries to go to sleep, it just restarts/crashes.

No idea what's up. I think it may be something left over from when I had an NVIDIA card, but I'm not sure where to look within these debug files. Hopefully, someone can help. I have attached the zip of them below.
 

Attachments

  • debug_18960.zip
    3.3 MB · Views: 30
Joined
Sep 19, 2018
Messages
18
Motherboard
ASUSTeK Z170-A
CPU
i5-6600K
Graphics
RX 5700 XT
Any help is appreciated. Here's a bug report from right after it crashed: https://pastebin.com/mhAJJufh

One thing I did notice is that my computer will not sleep normally (due to inactivity). I have, in Energy Saver settings, things set to 1 minute, 2 minutes etc, but my PC will crash after maybe 5 minutes of inactivity, never going to sleep.

I've also noticed that if I run "pmset -g assertions" it says external media devices is preventing sleep. Here's exactly what it says: https://pastebin.com/T7ss0Yfi

With that, I've noticed that if I have a USB plugged in to one of the front ports on the computer, it won't sleep at all - it just wakes right back up with wifi and bluetooth disabled. However, if I have nothing, it sleeps exactly as it should. The display sleeps, then the entire PC sleeps after maybe 45 seconds.
 
Joined
Jun 26, 2018
Messages
297
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900k
Graphics
RX 5700 XT
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
I had almost the same problem. In my case it turned out I had 2 memory fixes in my UEFI directory. I looked at yours and see you have files in drivers64UEFI, drivers64 (should be unused) and drivers/UEFI. Not sure, but you should probably move all to /UEFI and see if you can remove some. I do see your listing AptioMemoryFix-64.efi and AptioMemoryFix.efi, so they might be conflicting......

hope that helps for a start.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,514
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Any help is appreciated. Here's a bug report from right after it crashed: https://pastebin.com/mhAJJufh

One thing I did notice is that my computer will not sleep normally (due to inactivity). I have, in Energy Saver settings, things set to 1 minute, 2 minutes etc, but my PC will crash after maybe 5 minutes of inactivity, never going to sleep.

I've also noticed that if I run "pmset -g assertions" it says external media devices is preventing sleep. Here's exactly what it says: https://pastebin.com/T7ss0Yfi

With that, I've noticed that if I have a USB plugged in to one of the front ports on the computer, it won't sleep at all - it just wakes right back up with wifi and bluetooth disabled. However, if I have nothing, it sleeps exactly as it should. The display sleeps, then the entire PC sleeps after maybe 45 seconds.

Please try with this EFI.

Copy your serial, board serial, and UUID to the config.plist.
 

Attachments

  • EFI.zip
    2.8 MB · Views: 48
Joined
Sep 19, 2018
Messages
18
Motherboard
ASUSTeK Z170-A
CPU
i5-6600K
Graphics
RX 5700 XT
Please try with this EFI.

Copy your serial, board serial, and UUID to the config.plist.
Giving this a try now. I'm having the problem (have had this problem since Catalina) where my computer seems to not listen to energy saver settings. It's set at 1 minute, but if I leave and 1 minute passes, nothing changes. Screen still on, computer still going.

Going to leave my computer for about 10 minutes and see if that gets it to either crash or hopefully your EFI fixed it all up for me.

edit: As far as everything else goes under your supplied EFI, my computer is no worse off, everything elsewhere still works - bluetooth wifi, manual sleep.

I had almost the same problem. In my case it turned out I had 2 memory fixes in my UEFI directory. I looked at yours and see you have files in drivers64UEFI, drivers64 (should be unused) and drivers/UEFI. Not sure, but you should probably move all to /UEFI and see if you can remove some. I do see your listing AptioMemoryFix-64.efi and AptioMemoryFix.efi, so they might be conflicting......

hope that helps for a start.

Thanks for this! It looks like chef's EFI fixed this up, so *crosses fingers*
 
Joined
Sep 19, 2018
Messages
18
Motherboard
ASUSTeK Z170-A
CPU
i5-6600K
Graphics
RX 5700 XT
Still not sleeping. Here is what I get from
Code:
pmset -g assertions


Code:
My-iMac:~ [name]$ pmset -g assertions


2020-01-07 17:29:35 -0500


Assertion status system-wide:


   BackgroundTask                 0


   ApplePushServiceTask           0


   UserIsActive                   1


   PreventUserIdleDisplaySleep    0


   PreventSystemSleep             0


   ExternalMedia                  1


   InternalPreventDisplaySleep    1


   PreventUserIdleSystemSleep     1


   NetworkClientActive            0


Listed by owning process:


   pid 458(sharingd): [0x00000ad000018734] 00:02:52 PreventUserIdleSystemSleep named: "Handoff"


   pid 121(hidd): [0x0000060300098527] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle serviceID:1000004b0 name:AppleUserHIDEventSe product:USB-HID Keyboard eventType:3"


    Timeout will fire in 180 secs Action=TimeoutActionRelease


   pid 74(powerd): [0x0000000600088005] 00:49:14 ExternalMedia named: "com.apple.powermanagement.externalmediamounted"


   pid 74(powerd): [0x00000aea00108003] 00:01:37 InternalPreventDisplaySleep named: "com.apple.powermanagement.delayDisplayOff"


    Timeout will fire in 83 secs Action=TimeoutActionTurnOff


Kernel Assertions: 0x4=USB


   id=500  level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.14400000 owner=Mayflash Wiimote PC Adapter


   id=501  level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.14300000 owner=USB-HID Keyboard


   id=502  level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.14500000 owner=4-Port USB 2.0 Hub


   id=505  level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.14541000 owner=Wireless Controller


   id=507  level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.00400000 owner=USB Advanced Audio Device


Idle sleep preventers: IODisplayWrangler

edit. It finally did something - not what I wanted but maybe a step in the right direction?

Instead of outright crashing and rebooting, it simply froze and forced me to reboot the computer. Booting back up gave me a similar kernel panic log.

Code:
panic(cpu 2 caller 0xffffff8006e6520a): Kernel trap at 0xffffff7f8ab33adf, type 14=page fault, registers:
CR0: 0x0000000080010033, CR2: 0x0000000000000040, CR3: 0x0000000194d0515e, CR4: 0x00000000003626e0
RAX: 0xffffff80eb302260, RBX: 0x0000000000000000, RCX: 0x0000000000000000, RDX: 0xffffff80eb302260
RSP: 0xffffff9145703870, RBP: 0xffffff91457038b0, RSI: 0xffffff802b33de00, RDI: 0x0000000000000000
R8:  0x0000000000000000, R9:  0x0000000000000000, R10: 0xffffff7f8aa63104, R11: 0xffffff802c137e0c
R12: 0xffffff800781cae8, R13: 0xffffff802b33de00, R14: 0xffffff802b33d000, R15: 0x0000000000000000
RFL: 0x0000000000010282, RIP: 0xffffff7f8ab33adf, CS:  0x0000000000000008, SS:  0x0000000000000010
Fault CR2: 0x0000000000000040, Error code: 0x0000000000000000, Fault CPU: 0x2, PL: 0, VF: 0

Backtrace (CPU 2), Frame : Return Address
0xffffff91457032d0 : 0xffffff8006d3bb1b 
0xffffff9145703320 : 0xffffff8006e733e5 
0xffffff9145703360 : 0xffffff8006e64e5e 
0xffffff91457033b0 : 0xffffff8006ce2a40 
0xffffff91457033d0 : 0xffffff8006d3b207 
0xffffff91457034d0 : 0xffffff8006d3b5eb 
0xffffff9145703520 : 0xffffff80074d24f9 
0xffffff9145703590 : 0xffffff8006e6520a 
0xffffff9145703710 : 0xffffff8006e64f08 
0xffffff9145703760 : 0xffffff8006ce2a40 
0xffffff9145703780 : 0xffffff7f8ab33adf 
0xffffff91457038b0 : 0xffffff7f8ab446d0 
0xffffff91457039d0 : 0xffffff7f8aa6602e 
0xffffff9145703a10 : 0xffffff7f8aa66561 
0xffffff9145703a40 : 0xffffff7f8aa63adb 
0xffffff9145703ac0 : 0xffffff8007468ea0 
0xffffff9145703b10 : 0xffffff8007467121 
0xffffff9145703b60 : 0xffffff8007470083 
0xffffff9145703ca0 : 0xffffff8006e22c22 
0xffffff9145703db0 : 0xffffff8006d41998 
0xffffff9145703e10 : 0xffffff8006d18625 
0xffffff9145703e70 : 0xffffff8006d2f0d5 
0xffffff9145703f00 : 0xffffff8006e4b485 
0xffffff9145703fa0 : 0xffffff8006ce3226 
      Kernel Extensions in backtrace:
         com.apple.iokit.IOAcceleratorFamily2(438.2.8)[9176E894-E24A-36BA-AFDA-0DB11F3F512A]@0xffffff7f8aa5d000->0xffffff7f8ab1ffff
            dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[2FAEE793-59BC-3ADF-A5E2-3BC8760AFE0B]@0xffffff7f87784000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[1286D5E5-A6A1-3C44-A244-04C068903DB2]@0xffffff7f878f7000
            dependency: com.apple.iokit.IOSurface(269.6)[640503DC-6033-3EF6-85F4-F48282EF48DD]@0xffffff7f88a53000
            dependency: com.apple.iokit.IOGraphicsFamily(569.3)[7B5CA52B-0BD1-34AB-BFC9-7D5C3A0DBE7C]@0xffffff7f89f9b000
            dependency: com.apple.iokit.IOReportFamily(47)[E3C37E96-3AFA-301F-B89C-719FB3D4DA53]@0xffffff7f87827000
         com.apple.kext.AMDRadeonX6000(3.0.4)[7C946094-8767-3E64-9AB8-CE0D460F9A02]@0xffffff7f8ab20000->0xffffff7f8ad24fff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[1286D5E5-A6A1-3C44-A244-04C068903DB2]@0xffffff7f878f7000
            dependency: com.apple.iokit.IOSurface(269.6)[640503DC-6033-3EF6-85F4-F48282EF48DD]@0xffffff7f88a53000
            dependency: com.apple.iokit.IOGraphicsFamily(569.3)[7B5CA52B-0BD1-34AB-BFC9-7D5C3A0DBE7C]@0xffffff7f89f9b000
            dependency: com.apple.iokit.IOAcceleratorFamily2(438.2.8)[9176E894-E24A-36BA-AFDA-0DB11F3F512A]@0xffffff7f8aa5d000

BSD process name corresponding to current thread: VTDecoderXPCServ
Boot args: agdpmod=pikera debug=0x100 kext-dev-mode=1 

Mac OS version:
19C57

Kernel version:
Darwin Kernel Version 19.2.0: Sat Nov  9 03:47:04 PST 2019; root:xnu-6153.61.1~20/RELEASE_X86_64
Kernel UUID: C3E7E405-C692-356B-88D3-C30041FD1E72
Kernel slide:     0x0000000006a00000
Kernel text base: 0xffffff8006c00000
__HIB  text base: 0xffffff8006b00000
System model name: iMacPro1,1 (Mac-7BA5B2D9E42DDD94)
System shutdown begun: NO
Panic diags file available: YES (0x0)

System uptime in nanoseconds: 3560919861460
last loaded kext at 460135672946: >usb.IOUSBHostHIDDevice    1.2 (addr 0xffffff7f8a2d5000, size 45056)
last unloaded kext at 198306213418: >!A!ILpssGspi    3.0.60 (addr 0xffffff7f887b6000, size 45056)
loaded kexts:
com.malwarebytes.mbam.rtprotection    3.4.29
com.squirrels.driver.AirParrotSpeakers    1.8
com.bitgapp.eqMac2Driver    2.0
com.waves.driver.soundgrid    9.7.99
com.squirrels.airparrot.framebuffer    5
com.paragon-software.filesystems.ntfs    41.5.15
com.paragon-software.kext.VDMounter    1370.2
com.radiosilenceapp.nke.filter    2.2
com.insanelymac.!IMausiEthernet    2.5.0d0
as.vit9696.!AALC    1.4.5
org.tw.CodecCommander    2.7.1
as.vit9696.WhateverGreen    1.3.6
as.vit9696.Lilu    1.4.1
org.netkas.driver.FakeSMC    1800
com.rehabman.driver.USBInjectAll    0.7.4
|IO!BUSBDFU    7.0.2f4
@fileutil    20.036.15
@filesystems.autofs    3.0
@kext.AMDRadeonX6000    3.0.4
>!AUpstreamUserClient    3.6.8
@kext.AMDRadeonServiceManager    3.0.4
>!AMCCSControl    1.13
>!AGraphicsDevicePolicy    4.5.21
@AGDCPluginDisplayMetrics    4.5.21
@filesystems.ntfs    3.14.3
>!AHV    1
|IOUserEthernet    1.0.1
|IO!BSerialManager    7.0.2f4
>AGPM    111.4.1
>!APlatformEnabler    2.7.0d0
>X86PlatformShim    1.0.0
>pmtelemetry    1
@Dont_Steal_Mac_OS_X    7.0.0
>!AHDA    283.15
>AudioAUUC    1.70
|Broadcom!B20703USBTransport    7.0.2f4
>!A!IMCEReporter    115
>!A!IPCHPMC    2.0.1
>!AGFXHDA    100.1.422
>eficheck    1
>!A16X50ACPI    3.2
>AirPort.BrcmNIC    1400.1.1
>!A!ISlowAdaptiveClocking    4.0.0
@filesystems.apfs    1412.61.1
|SCSITaskUserClient    422.0.2
>!U!SCoexistentDriver    489.60.3
>!AVirtIO    1.0
@filesystems.hfs.kext    522.0.9
@!AFSCompression.!AFSCompressionTypeDataless    1.0.0d1
@BootCache    40
@!AFSCompression.!AFSCompressionTypeZlib    1.0.0
>!AAHCIPort    341.0.2
@private.KextAudit    1.0
>!ARTC    2.0
>!AACPIButtons    6.1
>!AHPET    1.8
>!ASMBIOS    2.1
>!AAPIC    1.7
$!AImage4    1
@nke.applicationfirewall    303
$TMSafetyNet    8
@!ASystemPolicy    2.0.0
|EndpointSecurity    1
>usb.IOUSBHostHIDDevice    1.2
>usb.cdc    5.0.0
@kext.triggers    1.0
@kext.AMDRadeonX6000HWLibs    1.0
|IOAccelerator!F2    438.2.8
@kext.AMDRadeonX6000HWServices    3.0.4
>!ASMBus!C    1.0.18d1
|IOSMBus!F    1.1
>!AGraphicsControl    4.5.21
|IOAVB!F    800.17
>!ASSE    1.0
>DspFuncLib    283.15
@kext.OSvKernDSPLib    529
@kext.AMDRadeonX6000Framebuffer    3.0.4
@!AGPUWrangler    4.5.21
|Broadcom!BHost!CUSBTransport    7.0.2f4
|IO!BHost!CUSBTransport    7.0.2f4
|IO!BHost!CTransport    7.0.2f4
|IO!B!F    7.0.2f4
|IO!BPacketLogger    7.0.2f4
>!AHDA!C    283.15
|IOHDA!F    283.15
|IONDRVSupport    569.3
@kext.AMDSupport    3.0.4
@!AGraphicsDeviceControl    4.5.21
|IOGraphics!F    569.3
>X86PlatformPlugin    1.0.0
>IOPlatformPlugin!F    6.0.0d8
>!A16X50Serial    3.2
|IO80211!F    1200.12.2b1
>mDNSOffloadUserClient    1.0.1b8
>corecapture    1.0.4
>!UAudio    320.49
|IOSlowAdaptiveClocking!F    1.0.0
@plugin.IOgPTPPlugin    800.14
|IOEthernetAVB!C    1.1.0
|IOSkywalk!F    1
|IOAHCIBlock!S    316.40.3
|IOUSBMass!SClass    4.0.4
>usb.!UHub    1.2
>usb.networking    5.0.0
>usb.!UHostCompositeDevice    1.2
|IOSerial!F    11
|IOSurface    269.6
@filesystems.hfs.encodings.kext    1
>usb.!UHostPacketFilter    1.0
|IOUSB!F    900.4.2
>usb.!UXHCIPCI    1.2
>usb.!UXHCI    1.2
|IOAHCI!F    290.0.1
>!AEFINVRAM    2.1
>!AEFIRuntime    2.1
|IOHID!F    2.0.0
$quarantine    4
$sandbox    300.0
@kext.!AMatch    1.0.0d1
|IOAudio!F    300.2
@vecLib.kext    1.2.0
>DiskImages    493.0.0
>!AFDEKeyStore    28.30
>!AEffaceable!S    1.0
>!AKeyStore    2
>!UTDM    489.60.3
|IOSCSIBlockCommandsDevice    422.0.2
>!ACredentialManager    1.0
>KernelRelayHost    1
>!ASEPManager    1.0.1
>IOSlaveProcessor    1
|IOTimeSync!F    800.14
|IONetworking!F    3.4
|IOUSBMass!SDriver    157.40.7
|IOSCSIArchitectureModel!F    422.0.2
|IO!S!F    2.1
|IOUSBHost!F    1.2
>!UHostMergeProperties    1.2
>usb.!UCommon    1.0
>!ABusPower!C    1.0
|CoreAnalytics!F    1
>!AMobileFileIntegrity    1.0.5
@kext.CoreTrust    1
|IOReport!F    47
>!AACPIPlatform    6.1
>!ASMC    3.1.9
>watchdog    1
|IOPCI!F    2.9
|IOACPI!F    1.4
@kec.pthread    1
@kec.Libm    1
@kec.corecrypto    1.0
 
Last edited:

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,514
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I'm having the problem (have had this problem since Catalina) where my computer seems to not listen to energy saver settings.

Please go to /Library/Preferences/ and delete the com.apple.PowerManagement.*.plist files. There should be three of them. Reboot and see if your energy saver settings stick.



Code:
panic(cpu 2 caller 0xffffff8006e6520a): Kernel trap at 0xffffff7f8ab33adf, type 14=page fault, registers:
CR0: 0x0000000080010033, CR2: 0x0000000000000040, CR3: 0x0000000194d0515e, CR4: 0x00000000003626e0
RAX: 0xffffff80eb302260, RBX: 0x0000000000000000, RCX: 0x0000000000000000, RDX: 0xffffff80eb302260
RSP: 0xffffff9145703870, RBP: 0xffffff91457038b0, RSI: 0xffffff802b33de00, RDI: 0x0000000000000000
R8:  0x0000000000000000, R9:  0x0000000000000000, R10: 0xffffff7f8aa63104, R11: 0xffffff802c137e0c
R12: 0xffffff800781cae8, R13: 0xffffff802b33de00, R14: 0xffffff802b33d000, R15: 0x0000000000000000
RFL: 0x0000000000010282, RIP: 0xffffff7f8ab33adf, CS:  0x0000000000000008, SS:  0x0000000000000010
Fault CR2: 0x0000000000000040, Error code: 0x0000000000000000, Fault CPU: 0x2, PL: 0, VF: 0

Backtrace (CPU 2), Frame : Return Address
0xffffff91457032d0 : 0xffffff8006d3bb1b
0xffffff9145703320 : 0xffffff8006e733e5
0xffffff9145703360 : 0xffffff8006e64e5e
0xffffff91457033b0 : 0xffffff8006ce2a40
0xffffff91457033d0 : 0xffffff8006d3b207
0xffffff91457034d0 : 0xffffff8006d3b5eb
0xffffff9145703520 : 0xffffff80074d24f9
0xffffff9145703590 : 0xffffff8006e6520a
0xffffff9145703710 : 0xffffff8006e64f08
0xffffff9145703760 : 0xffffff8006ce2a40
0xffffff9145703780 : 0xffffff7f8ab33adf
0xffffff91457038b0 : 0xffffff7f8ab446d0
0xffffff91457039d0 : 0xffffff7f8aa6602e
0xffffff9145703a10 : 0xffffff7f8aa66561
0xffffff9145703a40 : 0xffffff7f8aa63adb
0xffffff9145703ac0 : 0xffffff8007468ea0
0xffffff9145703b10 : 0xffffff8007467121
0xffffff9145703b60 : 0xffffff8007470083
0xffffff9145703ca0 : 0xffffff8006e22c22
0xffffff9145703db0 : 0xffffff8006d41998
0xffffff9145703e10 : 0xffffff8006d18625
0xffffff9145703e70 : 0xffffff8006d2f0d5
0xffffff9145703f00 : 0xffffff8006e4b485
0xffffff9145703fa0 : 0xffffff8006ce3226
      Kernel Extensions in backtrace:
         com.apple.iokit.IOAcceleratorFamily2(438.2.8)[9176E894-E24A-36BA-AFDA-0DB11F3F512A]@0xffffff7f8aa5d000->0xffffff7f8ab1ffff
            dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[2FAEE793-59BC-3ADF-A5E2-3BC8760AFE0B]@0xffffff7f87784000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[1286D5E5-A6A1-3C44-A244-04C068903DB2]@0xffffff7f878f7000
            dependency: com.apple.iokit.IOSurface(269.6)[640503DC-6033-3EF6-85F4-F48282EF48DD]@0xffffff7f88a53000
            dependency: com.apple.iokit.IOGraphicsFamily(569.3)[7B5CA52B-0BD1-34AB-BFC9-7D5C3A0DBE7C]@0xffffff7f89f9b000
            dependency: com.apple.iokit.IOReportFamily(47)[E3C37E96-3AFA-301F-B89C-719FB3D4DA53]@0xffffff7f87827000
         com.apple.kext.AMDRadeonX6000(3.0.4)[7C946094-8767-3E64-9AB8-CE0D460F9A02]@0xffffff7f8ab20000->0xffffff7f8ad24fff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[1286D5E5-A6A1-3C44-A244-04C068903DB2]@0xffffff7f878f7000
            dependency: com.apple.iokit.IOSurface(269.6)[640503DC-6033-3EF6-85F4-F48282EF48DD]@0xffffff7f88a53000
            dependency: com.apple.iokit.IOGraphicsFamily(569.3)[7B5CA52B-0BD1-34AB-BFC9-7D5C3A0DBE7C]@0xffffff7f89f9b000
            dependency: com.apple.iokit.IOAcceleratorFamily2(438.2.8)[9176E894-E24A-36BA-AFDA-0DB11F3F512A]@0xffffff7f8aa5d000

BSD process name corresponding to current thread: VTDecoderXPCServ
Boot args: agdpmod=pikera debug=0x100 kext-dev-mode=1

Mac OS version:
19C57

Kernel version:
Darwin Kernel Version 19.2.0: Sat Nov  9 03:47:04 PST 2019; root:xnu-6153.61.1~20/RELEASE_X86_64
Kernel UUID: C3E7E405-C692-356B-88D3-C30041FD1E72
Kernel slide:     0x0000000006a00000
Kernel text base: 0xffffff8006c00000
__HIB  text base: 0xffffff8006b00000
System model name: iMacPro1,1 (Mac-7BA5B2D9E42DDD94)
System shutdown begun: NO
Panic diags file available: YES (0x0)

System uptime in nanoseconds: 3560919861460
last loaded kext at 460135672946: >usb.IOUSBHostHIDDevice    1.2 (addr 0xffffff7f8a2d5000, size 45056)
last unloaded kext at 198306213418: >!A!ILpssGspi    3.0.60 (addr 0xffffff7f887b6000, size 45056)
loaded kexts:
com.malwarebytes.mbam.rtprotection    3.4.29
com.squirrels.driver.AirParrotSpeakers    1.8
com.bitgapp.eqMac2Driver    2.0
com.waves.driver.soundgrid    9.7.99
com.squirrels.airparrot.framebuffer    5
com.paragon-software.filesystems.ntfs    41.5.15
com.paragon-software.kext.VDMounter    1370.2
com.radiosilenceapp.nke.filter    2.2
com.insanelymac.!IMausiEthernet    2.5.0d0
as.vit9696.!AALC    1.4.5
org.tw.CodecCommander    2.7.1
as.vit9696.WhateverGreen    1.3.6
as.vit9696.Lilu    1.4.1
org.netkas.driver.FakeSMC    1800
com.rehabman.driver.USBInjectAll    0.7.4
|IO!BUSBDFU    7.0.2f4
@fileutil    20.036.15
@filesystems.autofs    3.0
@kext.AMDRadeonX6000    3.0.4
>!AUpstreamUserClient    3.6.8
@kext.AMDRadeonServiceManager    3.0.4
>!AMCCSControl    1.13
>!AGraphicsDevicePolicy    4.5.21
@AGDCPluginDisplayMetrics    4.5.21
@filesystems.ntfs    3.14.3
>!AHV    1
|IOUserEthernet    1.0.1
|IO!BSerialManager    7.0.2f4
>AGPM    111.4.1
>!APlatformEnabler    2.7.0d0
>X86PlatformShim    1.0.0
>pmtelemetry    1
@Dont_Steal_Mac_OS_X    7.0.0
>!AHDA    283.15
>AudioAUUC    1.70
|Broadcom!B20703USBTransport    7.0.2f4
>!A!IMCEReporter    115
>!A!IPCHPMC    2.0.1
>!AGFXHDA    100.1.422
>eficheck    1
>!A16X50ACPI    3.2
>AirPort.BrcmNIC    1400.1.1
>!A!ISlowAdaptiveClocking    4.0.0
@filesystems.apfs    1412.61.1
|SCSITaskUserClient    422.0.2
>!U!SCoexistentDriver    489.60.3
>!AVirtIO    1.0
@filesystems.hfs.kext    522.0.9
@!AFSCompression.!AFSCompressionTypeDataless    1.0.0d1
@BootCache    40
@!AFSCompression.!AFSCompressionTypeZlib    1.0.0
>!AAHCIPort    341.0.2
@private.KextAudit    1.0
>!ARTC    2.0
>!AACPIButtons    6.1
>!AHPET    1.8
>!ASMBIOS    2.1
>!AAPIC    1.7
$!AImage4    1
@nke.applicationfirewall    303
$TMSafetyNet    8
@!ASystemPolicy    2.0.0
|EndpointSecurity    1
>usb.IOUSBHostHIDDevice    1.2
>usb.cdc    5.0.0
@kext.triggers    1.0
@kext.AMDRadeonX6000HWLibs    1.0
|IOAccelerator!F2    438.2.8
@kext.AMDRadeonX6000HWServices    3.0.4
>!ASMBus!C    1.0.18d1
|IOSMBus!F    1.1
>!AGraphicsControl    4.5.21
|IOAVB!F    800.17
>!ASSE    1.0
>DspFuncLib    283.15
@kext.OSvKernDSPLib    529
@kext.AMDRadeonX6000Framebuffer    3.0.4
@!AGPUWrangler    4.5.21
|Broadcom!BHost!CUSBTransport    7.0.2f4
|IO!BHost!CUSBTransport    7.0.2f4
|IO!BHost!CTransport    7.0.2f4
|IO!B!F    7.0.2f4
|IO!BPacketLogger    7.0.2f4
>!AHDA!C    283.15
|IOHDA!F    283.15
|IONDRVSupport    569.3
@kext.AMDSupport    3.0.4
@!AGraphicsDeviceControl    4.5.21
|IOGraphics!F    569.3
>X86PlatformPlugin    1.0.0
>IOPlatformPlugin!F    6.0.0d8
>!A16X50Serial    3.2
|IO80211!F    1200.12.2b1
>mDNSOffloadUserClient    1.0.1b8
>corecapture    1.0.4
>!UAudio    320.49
|IOSlowAdaptiveClocking!F    1.0.0
@plugin.IOgPTPPlugin    800.14
|IOEthernetAVB!C    1.1.0
|IOSkywalk!F    1
|IOAHCIBlock!S    316.40.3
|IOUSBMass!SClass    4.0.4
>usb.!UHub    1.2
>usb.networking    5.0.0
>usb.!UHostCompositeDevice    1.2
|IOSerial!F    11
|IOSurface    269.6
@filesystems.hfs.encodings.kext    1
>usb.!UHostPacketFilter    1.0
|IOUSB!F    900.4.2
>usb.!UXHCIPCI    1.2
>usb.!UXHCI    1.2
|IOAHCI!F    290.0.1
>!AEFINVRAM    2.1
>!AEFIRuntime    2.1
|IOHID!F    2.0.0
$quarantine    4
$sandbox    300.0
@kext.!AMatch    1.0.0d1
|IOAudio!F    300.2
@vecLib.kext    1.2.0
>DiskImages    493.0.0
>!AFDEKeyStore    28.30
>!AEffaceable!S    1.0
>!AKeyStore    2
>!UTDM    489.60.3
|IOSCSIBlockCommandsDevice    422.0.2
>!ACredentialManager    1.0
>KernelRelayHost    1
>!ASEPManager    1.0.1
>IOSlaveProcessor    1
|IOTimeSync!F    800.14
|IONetworking!F    3.4
|IOUSBMass!SDriver    157.40.7
|IOSCSIArchitectureModel!F    422.0.2
|IO!S!F    2.1
|IOUSBHost!F    1.2
>!UHostMergeProperties    1.2
>usb.!UCommon    1.0
>!ABusPower!C    1.0
|CoreAnalytics!F    1
>!AMobileFileIntegrity    1.0.5
@kext.CoreTrust    1
|IOReport!F    47
>!AACPIPlatform    6.1
>!ASMC    3.1.9
>watchdog    1
|IOPCI!F    2.9
|IOACPI!F    1.4
@kec.pthread    1
@kec.Libm    1
@kec.corecrypto    1.0

This panic is related to your 5700 XT. Do you have IGPU disabled in BIOS? Does the 5700 XT run stably in Windows?
 
Joined
Sep 19, 2018
Messages
18
Motherboard
ASUSTeK Z170-A
CPU
i5-6600K
Graphics
RX 5700 XT
Please go to /Library/Preferences/ and delete the com.apple.PowerManagement.*.plist files. There should be three of them. Reboot and see if your energy saver settings stick.


Tried this a bunch over the past two days - never seems to work. As far as I know, it's never slept when it's supposed to on Catalina.


This panic is related to your 5700 XT. Do you have IGPU disabled in BIOS? Does the 5700 XT run stably in Windows?

Yup, works fine and perfect on Windows.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,514
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Tried this a bunch over the past two days - never seems to work. As far as I know, it's never slept when it's supposed to on Catalina.




Yup, works fine and perfect on Windows.


I don't know why your preferences don't stick. Have you tried to create a new account, log in to that new account, and see if it sleeps?


I don't have a 5700 XT and all the reports I've read from users regarding it are very conflicting so I really don't know what would be the cause of the panic. All I can advise is that make sure you are on at least Catalina 10.15.2 and if you use iMacPro1,1 system definition, disable the IGPU in BIOS.
 
Joined
Sep 19, 2018
Messages
18
Motherboard
ASUSTeK Z170-A
CPU
i5-6600K
Graphics
RX 5700 XT
I don't know why your preferences don't stick. Have you tried to create a new account, log in to that new account, and see if it sleeps?

Huh - pretty wild. On a new user, everything works as it should. 1 minute, display goes to sleep, once it's asleep for 1 more minute, the computer goes to sleep. Doesn't crash or reboot either.

I feel like this is progress.
 
Status
Not open for further replies.
Top