Contribute
Register

[Updated] wildwillow's Haswell Build: GA-Z87X-OC - i7-4770K - HD4600+GT 640

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,562
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
wildwillow's Haswell Build: GA-Z87X-OC - i7-4770K - HD4600+GT 640

Congrats, looks surprisingly good in white :)

Any luck with iTunes purchased content and trailers ?

It seems as if we are in the same situation as Ivy Bridge Hacks.

great build sir! im diggin the nzxt case!

Thank you. It truly is a great case. The best I have owned and offers a lot for a very reasonable price.
 
Joined
Jul 3, 2013
Messages
83
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
2 X Gigabyte GTX 4GB 760s
Mac
  1. MacBook
Classic Mac
Mobile Phone
  1. iOS
wildwillow's Haswell Build: GA-Z87X-OC - i7-4770K - HD4600+GT 640

I am using a different AppleHDA that will be released in the next version of MultiBeast. I have no ownership or permission of this kext and respect that testing is underway for everyones benefit. Good news is that it is working perfectly.

Glad you have got it working in the meantime:thumbup:

Thanks that's great news. Been driving myself crazy trying to find a fix on this board, but if new multibeast has the fix it can wait.
 
Joined
Sep 20, 2013
Messages
5
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
wildwillow's Haswell Build: GA-Z87X-OC - i7-4770K - HD4600+GT 640

Hi, congrats for your config! Very useful for me as I want to built a quite similar config.
I have 1 question for the Intel 4600: you get dual monitors working using that & a GTX card: are you using the hdmi output only of the integrated device or you can use the DVI output? In your mutlibeast config, it seems that the max resolution is 1920x1080 max? I wanted to get a WQHD monitor working with this config..
Thank you for your help
 
Joined
Feb 21, 2013
Messages
232
Motherboard
Gigabyte GA-B85M-D3H
CPU
E3-1241v3
Graphics
GT 740
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
wildwillow's Haswell Build: GA-Z87X-OC - i7-4770K - HD4600+GT 640

Then my question is did you make any other steep to make your sound work ?

Edit: i fix my sound whit this :
http://www.osx86.net/files/file/54-alc892-nodsdt-ml1085/

Sea_man,

Thank you so much for posting this link!! :clap: With a GA-B85M-D3H I could get sound, but only through USB speakers. The two files resolved this issue completely, and not just on 10.8.5 if you get my drift. :D

Tom
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,562
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
wildwillow's Haswell Build: GA-Z87X-OC - i7-4770K - HD4600+GT 640

Hi, congrats for your config! Very useful for me as I want to built a quite similar config.
I have 1 question for the Intel 4600: you get dual monitors working using that & a GTX card: are you using the hdmi output only of the integrated device or you can use the DVI output? In your mutlibeast config, it seems that the max resolution is 1920x1080 max? I wanted to get a WQHD monitor working with this config..
Thank you for your help

Hi Tymeo and thanks. The maximum resolution for HDMI is 1920x1080. But this is maximum resolution for my monitors until I upgrade them and I am using HDMI from the integrated graphics. There is an option for you to use the DVI or DP and edit the Org.Chameleon.Boot Plist for the resolution you require. Don't hesitate if you have anymore questions. It is a great configuration especially for the stability of a Customac, by far my favourite to date.
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,562
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
wildwillow's Haswell Build: GA-Z87X-OC - i7-4770K - HD4600+GT 640

Sea_man,

Thank you so much for posting this link!! :clap: With a GA-B85M-D3H I could get sound, but only through USB speakers. The two files resolved this issue completely, and not just on 10.8.5 if you get my drift. :D

Tom

There will be a new release of MultiBeast pretty soon also to implement audio on all Haswell builds.
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,562
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
wildwillow's Haswell Build: GA-Z87X-OC - i7-4770K - HD4600+GT 640

Thanks that's great news. Been driving myself crazy trying to find a fix on this board, but if new multibeast has the fix it can wait.

Time to get your audio working MultiBeast 5.5 Update:thumbup:
 
Joined
Jun 10, 2011
Messages
28
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
wildwillow's Haswell Build: GA-Z87X-OC - i7-4770K - HD4600+GT 640

Hi wildwillow

I've the same MB and same CPU but I can't get what's wrong with fakesmc plugins, HWMonitor from Multibeast 5.5.0 shows only HDD temp and lifetime, dmesg says the following:

Code:
sudo dmesg | grep SMC
         org.netkas.driver.FakeSMC(820.0)[E88DCBC2-F742-36C0-AA90-BE2C62DB995B]@0xffffff7f81046000->0xffffff7f8105bfff
FakeSMCDevice: 13 preconfigured keys added
SMC: successfully initialized
SMC::smcInitHelper ERROR: MMIO regMap == NULL - fall back to old SMC mode
ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out

Code:
sudo dmesg | grep CPU
AppleACPICPU: ProcessorId=1 LocalApicId=0 Enabled
AppleACPICPU: ProcessorId=2 LocalApicId=2 Enabled
AppleACPICPU: ProcessorId=3 LocalApicId=4 Enabled
AppleACPICPU: ProcessorId=4 LocalApicId=6 Enabled
AppleACPICPU: ProcessorId=5 LocalApicId=1 Enabled
AppleACPICPU: ProcessorId=6 LocalApicId=3 Enabled
AppleACPICPU: ProcessorId=7 LocalApicId=5 Enabled
AppleACPICPU: ProcessorId=8 LocalApicId=7 Enabled
ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out
WARNING: IOPlatformPluginUtil : getCPUIDInfo: this is an unknown CPU model 0x3c

Just a clean install of 10.8.5. using UniBeast and MultiBeast only.
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,562
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
wildwillow's Haswell Build: GA-Z87X-OC - i7-4770K - HD4600+GT 640

Hi wildwillow

I've the same MB and same CPU but I can't get what's wrong with fakesmc plugins, HWMonitor from Multibeast 5.5.0 shows only HDD temp and lifetime, dmesg says the following:

Code:
sudo dmesg | grep SMC
         org.netkas.driver.FakeSMC(820.0)[E88DCBC2-F742-36C0-AA90-BE2C62DB995B]@0xffffff7f81046000->0xffffff7f8105bfff
FakeSMCDevice: 13 preconfigured keys added
SMC: successfully initialized
SMC::smcInitHelper ERROR: MMIO regMap == NULL - fall back to old SMC mode
ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out

Code:
sudo dmesg | grep CPU
AppleACPICPU: ProcessorId=1 LocalApicId=0 Enabled
AppleACPICPU: ProcessorId=2 LocalApicId=2 Enabled
AppleACPICPU: ProcessorId=3 LocalApicId=4 Enabled
AppleACPICPU: ProcessorId=4 LocalApicId=6 Enabled
AppleACPICPU: ProcessorId=5 LocalApicId=1 Enabled
AppleACPICPU: ProcessorId=6 LocalApicId=3 Enabled
AppleACPICPU: ProcessorId=7 LocalApicId=5 Enabled
AppleACPICPU: ProcessorId=8 LocalApicId=7 Enabled
ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out
WARNING: IOPlatformPluginUtil : getCPUIDInfo: this is an unknown CPU model 0x3c

Just a clean install of 10.8.5. using UniBeast and MultiBeast only.

This may be because Haswell is not fully supported fully as of yet (Reason i say this you can count on 1 finger the amount of Macs released with haswell). If you built the system and you know you that the cooling is sufficient for your build I would just wait until it is fully supported, In the meantime you can use another OS to monitor hardware only if you're having problems. I myself never use HWMonitor due to the fact of not adding unnecessary kext to my OS X installation. It's amazing what you can monitor from the BOIS. Hope this helps.
 
Joined
Sep 20, 2013
Messages
5
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
wildwillow's Haswell Build: GA-Z87X-OC - i7-4770K - HD4600+GT 640

Hi Tymeo and thanks. The maximum resolution for HDMI is 1920x1080. But this is maximum resolution for my monitors until I upgrade them and I am using HDMI from the integrated graphics. There is an option for you to use the DVI or DP and edit the Org.Chameleon.Boot Plist for the resolution you require. Don't hesitate if you have anymore questions. It is a great configuration especially for the stability of a Customac, by far my favourite to date.

Thank you for the answer! I tried to find out where to find tips on how-to set the org.Chameleon.Boot (I didn't have yet started my hackintosh), but no luck . Can you explain how to modify the DVI or DP and edit the Org.Chameleon.Boot Plist and what kind of values you put in in order to get a WQHD monitor to work on DVI with the integrated graphics? Or if you have the link to the tutorial? I looked at Multibeast pdf, but no luck...
 
Top