Contribute
Register

[Updated] wildwillow's Haswell Build: GA-Z87X-OC - i7-4770K - HD4600+GT 640

Joined
Aug 25, 2011
Messages
37
Motherboard
Lenovo Thinkcenter M93p Intel Q87 Express Chipset
CPU
Intell® Core™ i5-4590T Processo
Graphics
igpu
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. iOS
Hi, Anyone have NVMe external icon patch for Catalina. I used Clover and OpenCore. Both still need patch.
 
Joined
Aug 25, 2011
Messages
37
Motherboard
Lenovo Thinkcenter M93p Intel Q87 Express Chipset
CPU
Intell® Core™ i5-4590T Processo
Graphics
igpu
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. iOS
I don't perceive any significant differences in boot speed between Mojave and Catalina.
Not sure what you mean by stops in between.

When installing:

Run Catalina install in a Mojave boot - install into a fresh new APFS drive - Reboot.
Select OSX install in Clover - reboot.
Select Catalina partition in Clover - reboot.
Select Catalina partition in Clover - system boots into Catalina.
Hi! What NVMe patch are you using in Catalina?
 
Joined
Dec 10, 2013
Messages
84
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
HD4600
Mac
Classic Mac
Mobile Phone
I am not sure I am using one.
SSD 960 EVO seems to work fine as is?
 
Joined
Aug 25, 2011
Messages
37
Motherboard
Lenovo Thinkcenter M93p Intel Q87 Express Chipset
CPU
Intell® Core™ i5-4590T Processo
Graphics
igpu
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. iOS
I am not sure I am using one.
SSD 960 EVO seems to work fine as is?
Yes. It works but it works as external disk not built in {Disk Utility},
 
Joined
Dec 10, 2013
Messages
84
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
HD4600
Mac
Classic Mac
Mobile Phone
The 960 EVO shows as internal on my Mojave setup, and I don't remember addressing this issue in my Clover setup.


The Catalina-Data partition shows under "Locations" in Mojave finder sidebar,
and I can't remove it from there.
 
Joined
Oct 21, 2019
Messages
2
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
HD4600+GT 640
Hello friends,

I am an old user of this forum. I am thinking of updating my hackintosh (10.9.4) to Mojave or Catalina. Is there a small tutorial or from which post number.

Thank you.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,656
Motherboard
Asus ProArt Z490 Creator
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Hello friends,

I am an old user of this forum. I am thinking of updating my hackintosh (10.9.4) to Mojave or Catalina. Is there a small tutorial or from which post number.

Thank you.
I recommend you upgrade to Mojave. Catalina is .0 version that is still full of bugs, and it's going to restructure your drive. Additioinally, Catalina won't run 32bit apps. I always wait until at least the .3 update of macOS to make sure Apple gets the major bugs corrected.

BTW, get the GO64 freeware utility to identify all your 32bit applications so you can update them or get rid of them and find new ones that 64bit applications. See this article about more information on using GO54 and the 32bit application issue.


Finally, Mojave has mature UniBeast and MultiBeast. Use the tonymacx86 guide:

 
Joined
Oct 21, 2019
Messages
2
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
HD4600+GT 640
I recommend you upgrade to Mojave. Catalina is .0 version that is still full of bugs, and it's going to restructure your drive. Additioinally, Catalina won't run 32bit apps. I always wait until at least the .3 update of macOS to make sure Apple gets the major bugs corrected.

BTW, get the GO64 freeware utility to identify all your 32bit applications so you can update them or get rid of them and find new ones that 64bit applications. See this article about more information on using GO54 and the 32bit application issue.


Finally, Mojave has mature UniBeast and MultiBeast. Use the tonymacx86 guide:

Thanks Stork.
 
Joined
Apr 18, 2020
Messages
3
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / GT 640
Mac
  1. Mac Pro
Hey Everyone,
I'm still using the original build, and updated to Mojave. Used the appropriate kext file to to get my wifi card to work. Audio seems to be working. However my graphics doesn't seem to be working.

I tried playing a game and received a popup "Could not initialize graphics device"
If on youtube the Play button/Full screen option flicker as if I was tabbing between them.
The Video Card does not appear in Graphics/Display. Please let me know if you have any ideas as I'm pretty inexperienced at all this despite running mavericks perfectly for 5 years haha.
 

Attachments

  • IMG_0329.jpg
    IMG_0329.jpg
    1.5 MB · Views: 88
Joined
Dec 10, 2013
Messages
84
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
HD4600
Mac
Classic Mac
Mobile Phone
Updated to Big Sur 11.0.1
Open Core 6.4

New to OC, used pre-compiled Haswell AMLs. Sleep does not work.
Just mapped USB ports and made a custom USBmapping.kext - that now works well.

Its an old build ... but with 32GB RAM and NVME patch for the BIOS - It works quite nice.
 
Top