Contribute
Register

[Updated] wildwillow's Haswell Build: GA-Z87X-OC - i7-4770K - HD4600+GT 640

Joined
Sep 18, 2013
Messages
44
Motherboard
Motherboard Gigabyte GA-Z87X-OC
CPU
i7-4770
Graphics
GTX 970 + HD 4600
Mac
MacBook Air, Mac Pro
Mobile Phone
Android
Finally found the time to update my build to High Sierra 13.3.6 (Nvidia drivers are not available yet for Mojave).
Everything works perfectly as was on my Yosemite build that is already in place on a different SSD.

Not tested:
  • iMessage
  • Facetime
  • USB 3.1 support
Thanks to Wildwillow for the original Yosemite build that I used the last 5 years
and to Coldcross and BreBO for their posts that helped me to do the new build.
 
Joined
Dec 10, 2013
Messages
81
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
HD4600
Mac
Classic Mac
Mobile Phone
Updated to 10.14.1 via software update. No problem.
Updated apfs.kext in clover.

Still can't play videos in Safari. I tried a workaround described for high Sierra, but that does not work for me.

I would also like to thank Wildwillow and others on this forum for the great support.
What a solid hackintosh build!
 
Joined
Aug 25, 2011
Messages
30
Motherboard
Gigabyte Z87X-OC
CPU
i7-4770K
Graphics
GTX 950
Mac
MacBook Air, MacBook Pro, Mac mini
Mobile Phone
iOS
Finally found the time to update my build to High Sierra 13.3.6 (Nvidia drivers are not available yet for Mojave).
Everything works perfectly as was on my Yosemite build that is already in place on a different SSD.

Not tested:
  • iMessage
  • Facetime
  • USB 3.1 support
Thanks to Wildwillow for the original Yosemite build that I used the last 5 years
and to Coldcross and BreBO for their posts that helped me to do the new build.
Updated to 10.14.1 via software update. No problem.
Updated apfs.kext in clover.

Still can't play videos in Safari. I tried a workaround described for high Sierra, but that does not work for me.

I would also like to thank Wildwillow and others on this forum for the great support.
What a solid hackintosh build!
Will you be able to provide your (Gigabyte GA-Z87X-OC) SSDT-UIAC.aml
 
Joined
Dec 10, 2013
Messages
81
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
HD4600
Mac
Classic Mac
Mobile Phone
I don't think I have that file, as I installed the system as High Sierra used Multibeast and then updated to Mohave.
 
Joined
Sep 18, 2013
Messages
44
Motherboard
Motherboard Gigabyte GA-Z87X-OC
CPU
i7-4770
Graphics
GTX 970 + HD 4600
Mac
MacBook Air, Mac Pro
Mobile Phone
Android
I replaced the wifi card and the Bluetooth dongle with BCM943602CS 2,4 & 5g 3 Antenne 1300 Mbps BT4.1 WiFi.

It took 3 weeks to arrive from China to Germany and works without any drivers on Mohave.
Mouse and keyboard work in BIOS.
Hi ColdCross finally the wifi card is arrived. The Wifi is ok but bluetooth no, I don't see the card in the usb list...
I've tried on 10.13.4 and on 10.14.0 OSX installation (I have two SSD on the same machine).

I've connected the usb cable from the card to the motherboard (tried all usb ports).

Any idea on what could be the problem for the bluetooth?
I enclose some pictures.
Thank you so much.
 

Attachments

Joined
Dec 10, 2013
Messages
81
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
HD4600
Mac
Classic Mac
Mobile Phone
Sorry to hear about this.
I made sure the cables are in the correct direction.

I had initial issues with Bluetooth, because I was using the old dongle as well at the same time.
I had no USB keyboard or mouse, so I tried to delete the device from the system, remove the dongle and then wait for the system to ask for a Bluetooth mouse and hoped for the best.

Obviously not the best solution, but if you are still using the dongle, maybe switch to a USB mouse first, remove the Bluetooth devices and then remove the dongle. Upon reboot the system should ask for a bluetooth device - or you can do it in the system preferences.

IMG_0321.jpeg IMG_0323.jpeg IMG_0324.jpeg Screenshot 2018-11-07 at 19.38.05.png
 
Joined
Sep 18, 2013
Messages
44
Motherboard
Motherboard Gigabyte GA-Z87X-OC
CPU
i7-4770
Graphics
GTX 970 + HD 4600
Mac
MacBook Air, Mac Pro
Mobile Phone
Android
Will you be able to provide your (Gigabyte GA-Z87X-OC) SSDT-UIAC.aml
Why you need an SSDT-UIAC.aml ?
Your USB ports aren't working well?
Anyway download from github the RehabMan SSDT-UIAC-ALL.dsl file
and follow RehabMan's procedures to create a custom SSDT-UIAC
 
Joined
Aug 25, 2011
Messages
30
Motherboard
Gigabyte Z87X-OC
CPU
i7-4770K
Graphics
GTX 950
Mac
MacBook Air, MacBook Pro, Mac mini
Mobile Phone
iOS
Why you need an SSDT-UIAC.aml ?
Your USB ports aren't working well?
Anyway download from github the RehabMan SSDT-UIAC-ALL.dsl file
and follow RehabMan's procedures to create a custom SSDT-UIAC
USB Ports stop working after update to 10.14.1, so I tried so many times to create ssdt, and some USB 2 devices start showing up under USB 3 devices, and USB 2 stops working. I will try again on my day off.
 
Joined
Sep 18, 2013
Messages
44
Motherboard
Motherboard Gigabyte GA-Z87X-OC
CPU
i7-4770
Graphics
GTX 970 + HD 4600
Mac
MacBook Air, Mac Pro
Mobile Phone
Android
USB Ports stop working after update to 10.14.1, so I tried so many times to create ssdt, and some USB 2 devices start showing up under USB 3 devices, and USB 2 stops working. I will try again on my day off.
Ok, as soon as I can I will try to make it for you if I succeed. :)
 
Joined
Dec 10, 2013
Messages
81
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
HD4600
Mac
Classic Mac
Mobile Phone
Has anyone figured out how to deal with the freeze of the system when watching video in safari on sites like verge,
or when playing a video in the App Store?
 

Top