Contribute
Register

[Updated] Stork's Thunderbolt Build: i5-3570K | GA-Z77X-UP5-TH | GTX 760

RuleBreaker01

Banned
Joined
May 31, 2018
Messages
1,133
I am using the MultiBeast for Sierra default SMBIOS, iMac14,2. Works well.

I'll update to 10.12.5 later today and report back here with an update post; I'll also update Post #1.
Sleep/wake speedsteps works? Means native Powermanagement ok?
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,397
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Updated to 10.12.5 without any problems. Here is my procedure.

:ch: If you're using a M.2 NVMe SSD like I am, then download RehabMan's latest patch-nvme script. Don't run it until after you update!

:ch: Backup your current installation using Carbon Copy Cloner or SuperDuper.

:ch: Download the Mac App Store Software Update or Combo Update and run it to update to 10.12.5 - the updater will reboot upon completion;

:ch: Upon rebooting, if you have a Maxwell or Pascal Nivida graphics card, the Nvidia driver will prompt you to update to the latest driver and reboot when its completed it's installation;

:ch: The Audio driver has been overwritten by the update, so run the latest version of MultiBeast selecting only:

Drivers > Audio > Realtek > ALC898
Build > Install > Reboot​

You may have to do this more than one time. It took me twice before it stuck.​

:ch: (Optional for M.2 NVMe SSD owners) Update your HackrNVMeFamily kext with RehabMan's patch-nvme.

Welcome to Sierra 10.12.5! :thumbup:

Audio is working fine.
 
Last edited:
Joined
Jul 16, 2010
Messages
380
Motherboard
OP-LP3 Laptop
CPU
i7-8750H
Graphics
UHD630 (1920 x 1080)
Mac
Mac Pro
Mobile Phone
iOS
:ch: Drivers > Misc > USB Increase Max Port Limit
Is this only for 9 and 100/200 series because I don't see this for 7 series in Multibeast v9.1. Is the modified Bios suppose to fix things that Gigabyte never attended to?

Thanks again for yet another masterful guide of yours and thank you for sharing it with us!!
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,397
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
:ch: Drivers > Misc > USB Increase Max Port Limit
Is this only for 9 and 100/200 series because I don't see this for 7 series in Multibeast v9.1. Is the modified Bios suppose to fix things that Gigabyte never attended to?

Thanks again for yet another masterful guide of yours and thank you for sharing it with us!!
Re: USB port increase. Good catch! This is from MultiBeast v9.0.1
From Page 6 MultiBeast v9.0.1 Features document said:
Increase Max Port Limit
Enables USB 2.0 and 3.0 support on 9/100 Series motherboards. Adds Raise Port Limit Patch to Volumes/EFI/EFI/CLOVER/config.plist and installs USBInjectAll.kext to /Library/Extensions.
and I really need to update Post #1 Installation information. In the v9.1.0 MultiBeast Features document the "Increase Max Port Limit" was renamed to "Increase Max Port Limit 9 Series, 100 Series" and states the same actions as above.
From Page 6 MultiBeast v9.1.0 Features document said:
Increase Max Port Limit 9 Series, 100 Series
Enables USB 2.0 and 3.0 support on 9/100 Series motherboards. Adds Raise Port Limit Patch to Volumes/EFI/EFI/CLOVER/config.plist and installs USBInjectAll.kext to /Library/Extensions.
I would use this option until you can build an SSDT-USB.aml per RehabMan's [Guide] Creating a Custom SSDT for USBInjectAll.kext.


Re: Modified BIOS. This modified F12 BIOS only had the mod to see NVMe SSDs. F12 was the last "official" BIOS released by Gigabyte for the Z77X-UP5 TH motherboard. If you are not going to use an NVMe SSD with your system, then look at the "F12j mod 9" on Gigabyte's unofficial BIOS web site and search for "UP5TH". A list of changes is shown.
 
Joined
Nov 27, 2012
Messages
11
Motherboard
ASUS STRIX Z390 I Gaming
CPU
i7-8700K
Graphics
R580
Mac
iMac, MacBook Air, MacBook Pro, Mac mini, Mac Pro
Mobile Phone
Android, iOS
Updated to 10.12.5 without any problems. Here is my procedure.

:ch: If you're using a M.2 NVMe SSD like I am, then download RehabMan's latest patch-nvme script. Don't run it until after you update!

:ch: Backup your current installation using Carbon Copy Cloner or SuperDuper.

:ch: Download the Mac App Store Software Update or Combo Update and run it to update to 10.12.5 - the updater will reboot upon completion;

:ch: Upon rebooting, if you have a Maxwell or Pascal Nivida graphics card, the Nvidia driver will prompt you to update to the latest driver and reboot when its completed it's installation;

:ch: The Audio driver has been overwritten by the update, so run the latest version of MultiBeast selecting only:

Drivers > Audio > Realtek > ALC898
Build > Install > Reboot​
You may have to do this more than one time. It took me twice before it stuck.​

:ch: (Optional for M.2 NVMe SSD owners) Update your HackrNVMeFamily kext with RehabMan's patch-nvme.

Welcome to Sierra 10.12.5! :thumbup:

Audio is working fine.
Hello Stork,

Have
Gigabyte Z77x-UP5 TH
4 x 8 GB Crucia;l Vengance 1600 MHz RAM
EVGA GTX 670
Samsung 840 500 GB SSD
and ran it for years with OSX 10.10.5 and various updates to 10.11.xx - Upgrade to Sierra failed.

I then did the firmware upgrade to version F12 and wanted to instll fresh to Sierra along with a better graphics card- Gigabyte GTX 1060 Windforce OC6. I am getting the kernel panics everytime I complete the Multibeast installation after first reboot. The progress bar makes it about a third through and the last thing I see is kernel panic. I tried with nvidia drv disabled, with webdrivers loaded... can's seem to get past this.

Found a post re incompatibiltiy with FAKESMC GPU kext amd followed the steps to deleting the FaceSMC GPU kext as suggested.
Also manually copied the kexts for library/extensions into EFI partition ...

Have followed all the steps as outlined with BIOS configuration, and Unibeast prep to OSX installation. I am getting all the way to installing the Multibeast configurations and then I cannot get back into the installation, even trying to use safe mode, or load without kext... essentially have to start over.

Tested hardware in other systems and with other OSes just fine. must be a setting or procedure. Whats my best shot at getting this mobo working with Sierra?


Help and Advise greatly appreciated.

Max
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,397
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Updated to Sierra 10.12.6 through the M.A.S update without a problem. All works good.
 
Joined
May 7, 2012
Messages
7
Motherboard
Gigabyte Aorus Pro WiFi
CPU
i9-9900k
Graphics
GT 640
Mac
iMac
Mobile Phone
Android
Hi All

Got a nicely working system with help from all you guy and the awesome developers! Got one lingering issue though which I think started when I upgraded to Sierra. Sleep Wake no longer works. Monitor doesn't come back up and USB ports seem to be off (although the USB2 must be working to allow the wake from keyboard i guess?).

This is a dual boot system and if i force restart from the case, clover loads fine and i can select os etc but if i boot into windows no keyboard or mouse. Have to power down for 10 secs then it all comes back.

System is UP5TH with 3770k, 16GB RAM & GT 640. OS 10.12.6. BIOS settings as per first page of post. Tried different darkwake settings but doesn't seem to make any difference.

Thanks in advance for any help!
 
Joined
Oct 9, 2017
Messages
38
Motherboard
ASUS RAMPAGE V EXTREME
CPU
i7-5820K
Graphics
GTX 1060
May I ask if it is possible to use a discrete GPU and at the same time have the iGPU enabled too for Intel Quick Sync?
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,397
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
I have no knowledge of X99 motherboards. Since this thread is dedicated to my build components, I recommend you post your question in the Graphics forum section.
 
Top