Contribute
Register

[Updated] Stork's Thunderbolt Build: i5-3570K | GA-Z77X-UP5-TH | GTX 760

Joined
Sep 30, 2011
Messages
40
Motherboard
Z390 Designare
CPU
i7 9700K
Graphics
UHD 630
Mac
MacBook Pro, Mac Pro
Classic Mac
Classic, iMac, LC, PowerBook, Quadra
Mobile Phone
iOS
What to do now? Nothing, unless you want to experiment by removing FakePCIID_XHCIMux.kext (and rebuilding kextcaches) to see what difference that makes.
Interesting. I did remove this ktext which I think I had installed with Multibeast. Just like you said now those USB3 ports are back under the XHC in IOReg. I'm still getting good speeds with my 60MB/sec CF card over USB3.

Also Hackintool now recognized 2 of the 6 USB ports in back, but only with my USB2 card reader.

It's funny how this differs from Stork's guide. I guess there are a few differences in hardware, but would that have an effect? Like you say, it could be the latest apple update changed something. At least the USB ports are working. and hopefully my fenvi t919 card that's on the way will work with airdrop / handoff, and i can get sleep / wake to work.

I'm going to do a fresh install with the latest Mojave installer and see. Will report back.

Thank you!
 
Last edited:
Joined
Feb 21, 2011
Messages
1,213
Motherboard
GA-Z77X-UP5-TH
CPU
i7-3770K
Graphics
RX480
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
I've a problem, after a while, my GC is memory full...
Fans are working a lot, many times...
I don't understand what's going wrong with this card...
Can you help me ?

View attachment 440331
Could you explain further please? I don't see the issue at this time. Thank you.
 
Joined
Feb 21, 2011
Messages
1,213
Motherboard
GA-Z77X-UP5-TH
CPU
i7-3770K
Graphics
RX480
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Hello to Stork and everyone else following this thread. I am still having issues getting both my iGPU and dGPUs to work on my Z77X-UP5-TH board. This is the reason for me buying and building this machine. I was able to get Hardware Acceleration on my 5,1 Mac Pro but would still like to use my Hackintosh over that PC. Anyone have any ideas or clues as to how they got HD4000 working with a dGPU on their computer? Thank you in advanced.
 
Joined
Oct 23, 2010
Messages
845
Motherboard
GA-Z77X-UP5-TH
CPU
i7-3770K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
Android, iOS,
Hello to Stork and everyone else following this thread. I am still having issues getting both my iGPU and dGPUs to work on my Z77X-UP5-TH board. This is the reason for me buying and building this machine. I was able to get Hardware Acceleration on my 5,1 Mac Pro but would still like to use my Hackintosh over that PC. Anyone have any ideas or clues as to how they got HD4000 working with a dGPU on their computer? Thank you in advanced.
It depends on what you plan on doing with your system. Graphics acceleration (i.e. GUI) is easy to achieve but if you plan on using your system for encoding video (in H.264 or HEVC format) then it is different matter.
Mac OS Mojave and Catalina now supports basic GUI acceleration with AMD 5xx dGPU's.

I use my system for video encoding. For that purpose, I DISABLE the HD4000 IGPU in BIOS and use SMBIOS iMacPro1,1 model ID for my i7-3770k and Z77x-UP5-TH. Latest Catalina 10.15.2 recently BROKE H/W encoding done by AMD 5xx dGPU.

Post your Clover EFI folder (without the Themes folders) and a copy of your IOREG file (generated by IORegistryExplorer App R2.1) and maybe we can help you.
 
Joined
Feb 21, 2011
Messages
1,213
Motherboard
GA-Z77X-UP5-TH
CPU
i7-3770K
Graphics
RX480
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
It depends on what you plan on doing with your system. Graphics acceleration (i.e. GUI) is easy to achieve but if you plan on using your system for encoding video (in H.264 or HEVC format) then it is different matter.
Mac OS Mojave and Catalina now supports basic GUI acceleration with AMD 5xx dGPU's.

I use my system for video encoding. For that purpose, I DISABLE the HD4000 IGPU in BIOS and use SMBIOS iMacPro1,1 model ID for my i7-3770k and Z77x-UP5-TH. Latest Catalina 10.15.2 recently BROKE H/W encoding done by AMD 5xx dGPU.

Post your Clover EFI folder (without the Themes folders) and a copy of your IOREG file (generated by IORegistryExplorer App R2.1) and maybe we can help you.
Fair enough. I will fire this rig up and post this info.
Also the points you are making are why I am shocked. I did something similar on my 5,1 Mac Pro, and my editing experience went thru the roof. Thank you in advanced.
 
Joined
Apr 6, 2013
Messages
42
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
GTX 760
Mobile Phone
iOS
Stork, Thank you for all the work you have done for us. I have just wiped and installed per post 1 and have some questions and a comment.

First. A few steps from the bottom
Hackintool will place three files on your Desktop: SSDT-UIAC.aml and USBPorts.kext. You only need to use either the SSDT or the kext
The third file not mentioned is SSDT-EC.aml. Should I place both of the .aml files in the CLOVER/ACPI/patched/ folder or just one? which one?

Secondly, post 1 states near the end
Use IORegister to confirm your successful limit to 15 or under USB assignments
What do I look for in IORegister? Its not clear.

And a comment. I was unsuccessful at first and I think it was because the UniBeast USB thumb drive should be formatted as GUID and not MBR. If this is required its not mentioned in the post anywhere that I noticed and Disk utility hides the GUID / MBR choice by default. The GUID format option might also be need to format the Mojave Disk. After formatting GUID my install succeeded.

Thank you for this build which I have been using since Mavericks.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,187
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
...
The third file not mentioned is SSDT-EC.aml. Should I place both of the .aml files in the CLOVER/ACPI/patched/ folder or just one? which one?
Definitely the SSDT-UIAC.aml I mention should go in the ...CLOVER/ACPI/patched/ folder. However, I don't think I used the SSDT-EC.aml or I would have posted so...I'm not at Thunderball's location so I can't check for sure.

Secondly, Post 1 states near the end
Use IORegister to confirm your successful limit to 15 or under USB assignments
What do I look for in IORegister? Its not clear.
I assumed you are familar with the IORegister's output. (There's a thread on IORegister, but I can't find it now.) Hackintool will confirm your USB count number, too. Just remember USB 2 counts for one USB port while USB 3 count for 2 USB ports.

And a comment. I was unsuccessful at first and I think it was because the UniBeast USB thumb drive should be formatted as GUID and not MBR. If this is required its not mentioned in the post anywhere that I noticed and Disk utility hides the GUID / MBR choice by default. The GUID format option might also be need to format the Mojave Disk. After formatting GUID my install succeeded.
...
If you select Mac OS Extended (Journaled) format as the UniBeast guide shows, Disk Utility automatically format the drive GUID.
 
Last edited:
Joined
Feb 21, 2011
Messages
1,213
Motherboard
GA-Z77X-UP5-TH
CPU
i7-3770K
Graphics
RX480
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Definitely the SSDT-UIAC.aml I mention should go in the ...CLOVER/ACPI/patched/ folder. However, I don't think I used the SSDT-EC.aml or I would have posted so...I'm not at Thunderball's location so I can't check for sure.


I assumed you are familar with the IORegister's output. (There's a thread on IORegister, but I can't find it now.) Hackintool will confirm your USB count number, too. Just remember USB 2 counts for one USB port while USB 3 count for 2 USB ports.

If you select Mac OS Extended (Journaled) format as the UniBeast guide shows, Disk Utility automatically format the drive GUID.
Jezzz. Stork, I just realized you have 6 builds from all of the ages of Intel CPUs. Definitely a dedicated person to the Hackintosh community.
 
Top