Contribute
Register

[Updated] Stork's Thunderbolt Build: i5-3570K | GA-Z77X-UP5-TH | GTX 760

Joined
Feb 12, 2013
Messages
82
Motherboard
GA-Z77X-UD5H rev1.1
CPU
i7-3770K
Graphics
RX 580
Mac
MacBook Pro, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
I just found this: https://www.tonymacx86.com/threads/rx580-not-detected-after-catalina-update.282194/#post-2006913

It seems @glofter1 has got the same issue on 3 machines:
DPCI Manager v1.5 and v1.8 don't see the GPU in the first screenshot where the FB info should be displayed. @glofter1 is on 10.14.6 (18G95).

Is there another way to see the FB info?
I removed ATI Inject-no change.
I changed SMBIOS to 13,2 and lost my BT card functionality, but otherwise all is ok there.

DPCI manager still can't display the Framebuffer brand of my Sapphire Pulse RX580.
I noticed the card came with a slip of paper showing a switch with 2 different positions: gaming and computing. I looked for the switch and couldn't easily see it (card is installed).

Then just for fun using my 2012 MBP which happens to be on 10.14.6 (18G95), I ran DPCIManger 1.8 and it properly ID'd my GPU on my real Mac Laptop. No idea why it's not working on my Hackintosh. But now I know it's not DPCI's fault.
Screen Shot 2019-10-08 at 12.45.18 AM.jpg
 
Joined
Feb 21, 2011
Messages
1,199
Motherboard
GA-Z77X-UP5-TH
CPU
i7-3770K
Graphics
RX560
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Yes, if you are updating to 10.14.6 from 10.14.5 and had used the MultiBeast v10.4's Remove Port Limit option.
Hey, Stork. I finally took the plunge to 10.14.6 and WoW :headbang::clap::angel::eek::p(that's enough smileys). My performance improvement with the new Metal API is amazing. The computer runs so much better with the two RX560 GPUs. I hope this stays the same as we move into Catalina in the near future.
Now, to the questions. What do you for see as potential hazards with Catalina on our hardware? I am as always willing to wait. But, there's that desire to move forward.
And, I still can't get HD4000 to work correctly on this build. Have you been able to use the iGPU with a dGPU or even the iGPU alone? :banghead::crazy:

Thank you again for all your help. :!:
 
Joined
Jul 20, 2013
Messages
144
Motherboard
GA-Z77X-UPH TH
CPU
I7-3770K OC 4.5
Graphics
R9 280
Mac
Mac mini
Mobile Phone
Android, iOS
Hey, Stork. I finally took the plunge to 10.14.6 and WoW :headbang::clap::angel::eek::p(that's enough smileys). My performance improvement with the new Metal API is amazing. The computer runs so much better with the two RX560 GPUs. I hope this stays the same as we move into Catalina in the near future.
Now, to the questions. What do you for see as potential hazards with Catalina on our hardware? I am as always willing to wait. But, there's that desire to move forward.
And, I still can't get HD4000 to work correctly on this build. Have you been able to use the iGPU with a dGPU or even the iGPU alone? :banghead::crazy:

Thank you again for all your help. :!:
Preempting Stork's usual reply of he wouldn't be using any new OS until it reaches X.X.3 version for a main system as that's when most of the bugs are worked out.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,031
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
...
And, I still can't get HD4000 to work correctly on this build. Have you been able to use the iGPU with a dGPU or even the iGPU alone? :banghead::crazy:
...
I gave up using the on-board graphics (HD 4000) a long time ago. It was too much hassle to get working back then. Thus, my continued use of a good graphics card.

Damn! @Westsurf, you took the wind out of my sails. :D
 
Joined
Feb 21, 2011
Messages
1,199
Motherboard
GA-Z77X-UP5-TH
CPU
i7-3770K
Graphics
RX560
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
I gave up using the on-board graphics (HD 4000) a long time ago. It was too much hassle to get working back then. Thus, my continued use of a good graphics card.

Damn! @Westsurf, you took the wind out of my sails. :D
Okay, I'll move on then. With the new full METAL API in 10.14.6 I don't really need it. The HD4000 was great for H.264 playback and thus the desire.
As for 10.15, I figured you'd stick to old faithful and tell us to wait till 10.15.3/4 ;).
 
Joined
Jul 10, 2011
Messages
41
Motherboard
Z77x-UP5-TH
CPU
i7-3770K
Graphics
RX 580
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
I removed ATI Inject-no change.
I changed SMBIOS to 13,2 and lost my BT card functionality, but otherwise all is OK there.

DPCI manager still can't display the Framebuffer brand of my Sapphire Pulse RX580.
I noticed the card came with a slip of paper showing a switch with 2 different positions: gaming and computing. I looked for the switch and couldn't easily see it (card is installed).

Then, just for fun using my 2012 MBP which happens to be on 10.14.6 (18G95), I ran DPCIManger 1.8 and it properly ID'd my GPU on my real Mac Laptop. No idea why it's not working on my Hackintosh. But now I know it's not DPCI's fault.
View attachment 429114
Exactly the same problem here...
 
Joined
Feb 12, 2013
Messages
82
Motherboard
GA-Z77X-UD5H rev1.1
CPU
i7-3770K
Graphics
RX 580
Mac
MacBook Pro, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Thank you!!! Do you use ATI injection?
@parkingmo Glad I could help someone, lol!

I am not in front of the machine at the moment. I followed @Stork's method mentioned in Post #1109 which is a link to here: https://www.tonymacx86.com/threads/storks-myhero-ii-build-asus-rog-maximus-z370-hero-x-i7-8700k-amd-rx-580.245074/#580

He does inject ATI, and there is more. Check the link out and you should have your RX 580 issues solved, too. Just use Hackintool to verify instead, if DPCI manager can't show you the RX 580 info.
 
Last edited:
Top