Contribute
Register

*UPDATED*[Guide] Gigabyte Z170 HD3P 10.11.6

Joined
May 1, 2012
Messages
6
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i5-9600K
Graphics
GTX 960
Mobile Phone
iOS
Hi littlegreen,

You've done a lot of progress with the HD3P!!!
I followed every word of your guide, but no luck reaching the installer.
I'm getting "Still Waiting For Root Device".

The question is, should I modify in any way my usb flash drive in order to boot?
You think that maybe posting DSDT from your installation would help to bypass this issue? (I have the same build as you).
Any other suggestion would be also nice :)

Things used to be more simple with my old P35 build :p

Thank you
 
Joined
Jul 12, 2015
Messages
8
Mac
Classic Mac
Mobile Phone
hey littlegreen,

ich have the same system as you.
I have de-installed my graphic card and now I come in to the installer.
now my mouse and keyboard stopped working

you know how I can fix it?
 
Joined
May 1, 2012
Messages
6
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i5-9600K
Graphics
GTX 960
Mobile Phone
iOS
Hi littlegreen,

You've done a lot of progress with the HD3P!!!
I followed every word of your guide, but no luck reaching the installer.
I'm getting "Still Waiting For Root Device".

The question is, should I modify in any way my usb flash drive in order to boot?
You think that maybe posting DSDT from your installation would help to bypass this issue? (I have the same build as you).
Any other suggestion would be also nice :)

Things used to be more simple with my old P35 build :p

Thank you

Never mind, I've build a VM (no real MAC in house) and made some changes on the usb using your kext suggestion, also custom ssdt and finally managed to complete the installation.
 
Joined
May 1, 2012
Messages
6
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i5-9600K
Graphics
GTX 960
Mobile Phone
iOS
hey littlegreen,

ich have the same system as you.
I have de-installed my graphic card and now I come in to the installer.
now my mouse and keyboard stopped working

you know how I can fix it?
For starters use only USB2 ports. Then install USBInjectAll.kext for usb 3.0 support
 
Joined
Jul 12, 2015
Messages
8
Mac
Classic Mac
Mobile Phone
For starters use only USB2 ports. Then install USBInjectAll.kext for usb 3.0 support
i did that, but it dosent work :(
My Mouse and Keyboard had a USB port.
It give a "USBInjectAll.kext" file for USB 2.0?

Update: My El Catian System works! :clap::headbang::)




but I get the ethernet not to run.
I have the RealtekRTL8111.kext into the 10.11 folder, but it don't works :(
 
Joined
May 1, 2012
Messages
6
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i5-9600K
Graphics
GTX 960
Mobile Phone
iOS
i did that, but it dosent work :(
My Mouse and Keyboard had a USB port.
It give a "USBInjectAll.kext" file for USB 2.0?

Update: My El Catian System works! :clap::headbang::)




but I get the ethernet not to run.
I have the RealtekRTL8111.kext into the 10.11 folder, but it don't works :(
Glad to hear :)
I'm also having issues with the ethernet adapter.
Let us know if make any progress on that.
 
Joined
Jan 8, 2016
Messages
1
Motherboard
Gigabyte Z170 HD3P
CPU
i7 6700
Mac
MacBook Pro, Mac mini
Classic Mac
Mobile Phone
Android
Hello! Congratulations to the guide, i'm new in the world of hackintosh. These days I would try to carry out one on my new computer. I was wondering if there is news about the problems related to the ethernet card.
I also wanted to ask you, the integrated graphics card HD530 is working?


Thanks
 
Joined
Feb 2, 2013
Messages
313
Motherboard
HP 14-CE0501NA
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
iOS, Other
Hi littlegreen,

You've done a lot of progress with the HD3P!!!
I followed every word of your guide, but no luck reaching the installer.
I'm getting "Still Waiting For Root Device".

The question is, should I modify in any way my usb flash drive in order to boot?
You think that maybe posting DSDT from your installation would help to bypass this issue? (I have the same build as you).
Any other suggestion would be also nice :)

Things used to be more simple with my old P35 build :p

Thank you
I am VERY sorry for the late response - I was traveling offline for a while :)

Many people have said using a different USB port works for the error you are having. I would suggest try either USB2 and 3 and see if you get lucky. I had an issue with USB 3.0 ports working prior to the BIOS update I did. For example - keyboard and mouse wouldn't work. Same goes for USB2.0 flash drive in a USB3.0 port.

Also - make sure you have dart=0 in clover options when the bootloader shows up on the screen.

Another thing you can try (that worked for me initially) is to unplug your PCI-E graphics card and install with the integrated Intel GPU instead.
 
Joined
Feb 2, 2013
Messages
313
Motherboard
HP 14-CE0501NA
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
iOS, Other
Glad to hear :)
I'm also having issues with the ethernet adapter.
Let us know if make any progress on that.
I have attached the Ehternet kext that I am using and works fine for me - both on 10/100 mbps connection and on 1 Gbps. Works upon wake-up after the computer sleeps.

It is also attached to the OP now :)

View attachment RealtekRTL8111.kext.zip
 
Joined
Feb 2, 2013
Messages
313
Motherboard
HP 14-CE0501NA
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
iOS, Other
Hello! Congratulations to the guide, i'm new in the world of hackintosh. These days I would try to carry out one on my new computer. I was wondering if there is news about the problems related to the ethernet card.
I also wanted to ask you, the integrated graphics card HD530 is working?


Thanks
AFAIK the Intel 530 is working on some level but it's quirky and not fully supported. The last thing I read about it was you need to choose between good-looking sluggish system and quick moving system with A LOT of graphical glitches. 10.11.3 came out a few days ago - I haven't read about it but I am pretty sure people around the forum will already have information regarding integrated graphics.
 
Top