Contribute
Register

Updated from Mojave to Catalina 10.15.1 > Got Black Screen

Status
Not open for further replies.
Joined
Oct 24, 2015
Messages
16
Motherboard
Gigabyte GA-Z97M-D3H
CPU
i7-4790K
Graphics
GT 740
Mac
  1. Mac mini
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Updated WEG, Lilu, AppleALC, no luck upgrading from Mojave. Graphics hangs (black screen). Tried a few things without luck (disable IGPU, agdpmod=pikera, remove GPU card). This is an old machine, so maybe I need to go through and clean up old kext.
 
Joined
May 7, 2019
Messages
2
Motherboard
Asus P6T
CPU
i7-950
Graphics
RX 570
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Updated WEG, Lilu, AppleALC, no luck upgrading from Mojave. Graphics hangs (black screen). Tried a few things without luck (disable IGPU, agdpmod=pikera, remove GPU card). This is an old machine, so maybe I need to go through and clean up old kext.
I am having the same issue, also on older hardware. I can only get to the desktop by booting in safe mode. Do you know of a way to uninstall 10.15.1 without a full reinstall? Thanks,
 
Joined
Jan 9, 2017
Messages
1
Motherboard
ASUS Z97-C
CPU
i5-4460
Graphics
RX 460
Mobile Phone
  1. iOS
I got the same problem here and on haswell as well. I've tried booting with safe mode or verbose mode, but with no lucks, both of them failed. I can only see black screen after clover page, with no error messages. I've tried booting with another clover USB, apple logo showed up but after 75% loaded, the screen goes black again.
I've updated lilu, AppleALC and WEG before I have the system updated, and I've tried removing WEG, unfortunately, nothing works.
Checked all needed modules are inside drivers64UEFI.
Just wanna have it booted up and get back those settings of the applications arghhhhh
 
Joined
Oct 24, 2015
Messages
16
Motherboard
Gigabyte GA-Z97M-D3H
CPU
i7-4790K
Graphics
GT 740
Mac
  1. Mac mini
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I am having the same issue, also on older hardware. I can only get to the desktop by booting in safe mode. Do you know of a way to uninstall 10.15.1 without a full reinstall? Thanks,

I used a backup to get back to Mojave. I don't think there is any simple way to restore without a backup, except for a reinstall.
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,570
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
I used a backup to get back to Mojave. I don't think there is any simple way to restore without a backup, except for a reinstall.

Have you tried ACPI patch ECO to EC using the latest clover configurator?
 
Joined
Oct 24, 2015
Messages
16
Motherboard
Gigabyte GA-Z97M-D3H
CPU
i7-4790K
Graphics
GT 740
Mac
  1. Mac mini
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Decided to get back to this. Switched to OpenCore and all new kext. Fresh install. Worked perfectly.

Changed machine type to iMac15,1 and then upgraded to Big Sur. Everything works, except video playback in iTunes.
 

Attachments

  • bigsur.png
    bigsur.png
    136.4 KB · Views: 27
Status
Not open for further replies.
Top