Contribute
Register

[Update] Sierra 12.1 - Skylake GA-H170N-WIFI / HD530

Joined
May 30, 2016
Messages
571
Mac
iMac, MacBook Air, MacBook Pro, Mac Pro
Classic Mac
iMac, SE/30
Mobile Phone
iOS
theres an audio fix file somewhere for this issue. I use a Cinema Display which has USB audio to work around this.
 
Joined
Nov 28, 2016
Messages
5
Motherboard
GA-H170N-WIFI
CPU
i7
Graphics
HD530
I've gone through these guides (all three of them, since the El Cap one) and still have three blocking issues with this motherboard in Sierra

* Sleep/wake doesn't work (no matter what I do)
* No audio after "light" sleep (I've tried Multibeast's LCA1150 support and other approaches)
* No secondary display (ever, of any kind) after booting (booting with the primary on HDMI and the secondary on DVI gives me mirrored displays until macOS loads, and then only the primary stays on. Unplugging/plugging back in does nothing)

The HD530 works great for me (no glitches), but the lack of a second monitor kills the build for me.
 
Joined
Aug 5, 2012
Messages
314
Motherboard
GIGABYTE H270N-WIFI
CPU
i7-7700
Graphics
Vega 56
Mac
iMac, MacBook Air
Mobile Phone
iOS
I've gone through these guides (all three of them, since the El Cap one) and still have three blocking issues with this motherboard in Sierra

* Sleep/wake doesn't work (no matter what I do)
* No audio after "light" sleep (I've tried Multibeast's LCA1150 support and other approaches)
* No secondary display (ever, of any kind) after booting (booting with the primary on HDMI and the secondary on DVI gives me mirrored displays until macOS loads, and then only the primary stays on. Unplugging/plugging back in does nothing)

The HD530 works great for me (no glitches), but the lack of a second monitor kills the build for me.
Sleep/wake work for me, however, I loose sound and sometimes external HDDs don't get mounted, I have to manually reconnect them.

Audio = the same with me, in addition to my ports on the back not working at all.
 
Joined
Nov 28, 2016
Messages
5
Motherboard
GA-H170N-WIFI
CPU
i7
Graphics
HD530
AAPL,Gfx324
I don't think these are necessary anymore with Sierra. I managed to fix my glitches with the GfxYTile alone.

Also, applying this allowed me to plug in a secondary display over DVI after boot (but only after boot). I suspect messing with video port patching is required for it to work properly, but would appreciate some pointers on how that is likely to work.

HTML:
<key>KextsToPatch</key>       
<array>
    <dict>
        <key>Comment</key>
        <string>AppleGraphicsDevicePolicy (board-id) Patch (c) Pike R. Alpha</string>
        <key>Find</key>
        <data>
        Ym9hcmQtaWQ=
        </data>
        <key>Name</key>
        <string>AppleGraphicsDevicePolicy</string>
        <key>Replace</key>
        <data>
        Ym9hcmQtaXg=
        </data>
</dict>
</array>
 
Joined
Nov 4, 2016
Messages
5
Sleep/wake work for me, however, I loose sound and sometimes external HDDs don't get mounted, I have to manually reconnect them.

Audio = the same with me, in addition to my ports on the back not working at all.
Using CodecCommander.kext will get the sound working again after sleep, if you're still having trouble later I'll post up the version I used. I also have DarkWake=8 enabled.
Have tested it with manually putting it to sleep and letting it sleep naturally.

Only issue I have currently is external HDD's not working. USB Flash Drive's and everything else works fine, just not external HDD's.
 
Joined
Aug 5, 2012
Messages
314
Motherboard
GIGABYTE H270N-WIFI
CPU
i7-7700
Graphics
Vega 56
Mac
iMac, MacBook Air
Mobile Phone
iOS
Using CodecCommander.kext will get the sound working again after sleep, if you're still having trouble later I'll post up the version I used. I also have DarkWake=8 enabled.
Have tested it with manually putting it to sleep and letting it sleep naturally.

Only issue I have currently is external HDD's not working. USB Flash Drive's and everything else works fine, just not external HDD's.
Thanks, tried CodecCommander.kext and I seem to have sleep working, also, darkwake=0 with me...Never tried power nap on hack, is it worth it? About the USB thing, it's strange...The other thing I can't get working is AirPlay Mirroring. If I disable IGPU in BIOS, I don't even get the option to mirror, if I enable it (even if I use my GTX680 as primary display), I see the option, I can with it on, the AppleTv registers it, however, no picture gets transferred. Curiously, I use Beamer App to airplay movies to my AppleTV, also, Airplay from photos app works, but not mirroring.
 
Joined
Mar 29, 2012
Messages
12
Motherboard
GA-H170N-WIFI
CPU
Intel Core i5 6600K
Graphics
Nvidia GTX 1060 6GB FE
Mac
MacBook Pro
Mobile Phone
iOS
Oh, I'd love to see a step by step install guide for Sierra on this motherboard! Since the only other one I found is massively outdated and the official guide from the top menu bar never seems to do it for me :(..
 
Joined
May 30, 2016
Messages
571
Mac
iMac, MacBook Air, MacBook Pro, Mac Pro
Classic Mac
iMac, SE/30
Mobile Phone
iOS
The original guide still applies, mostly. follow it then follow the updated ones to get wifi working.

PowerNap I found to be annoying, the computer wakes up all the time to do whatever it wants, I shut it off.
 
Joined
Feb 15, 2013
Messages
11
Motherboard
GA-H170N-WIFI
CPU
i3-6100
Graphics
HD530
Mac
MacBook Air
Mobile Phone
iOS
Has anybody upgraded to 12.2 with this build?
Considering doing so but wondering if anything breaks.
Hi, I have just updated guide, nothing breaks.
Noticing improvements in Bluetooth reliability from my side
Also I have fixed my DVI port by removing old DVI fix from previous build and adding boarID fix from user @rcarmo
 
Top