Contribute
Register

Update from 10.14.3 10.14.5 Failed - Hung During Installation

Joined
Jul 28, 2010
Messages
50
Motherboard
ASUS Prime Z270-A
CPU
G4400
Graphics
RX 570
Mac
MacBook Pro
Classic Mac
iMac, Performa, PowerBook
Mobile Phone
Android, iOS
Updated clover, and attempted to update from 10.14.3 to 10.14.5 using system preferences. installer rebooted once and fails to pass the apple logo without any indication of progress, or blinking from the hdd light. I let it go over lunch (30min or so) to see if it would pass that point but it did not. I've since rebooted back into 10.14.3 without any issues and have to look closer later.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
20,543
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
10.14.4 and above requires a drive formatted as APFS. If your drive is not APFS then boot from the recovery partition and use Disk Utility to convert it.

Make sure that you have apfs.efi or ApfsDriverLoader-64.efi (not both) in /EFI/CLOVER/drivers64UEFI/.
 
Joined
Jul 28, 2010
Messages
50
Motherboard
ASUS Prime Z270-A
CPU
G4400
Graphics
RX 570
Mac
MacBook Pro
Classic Mac
iMac, Performa, PowerBook
Mobile Phone
Android, iOS
10.14.4 and above requires a drive formatted as APFS. If your drive is not APFS then boot from the recovery partition and use Disk Utility to convert it.

Make sure that you have apfs.efi or ApfsDriverLoader-64.efi (not both) in /EFI/CLOVER/drivers64UEFI/.
Hi P1LGRIM,

I do have ApfsDriverLoader-64.efi in /EFI/CLOVER/drivers64UEFI/. And my system disk ('EVE' in the screen shot) is formatted APFS. Have you got any other suggestions?
 

Attachments

Joined
Jan 16, 2011
Messages
531
Motherboard
Asus ROG MAXIMUS X HERO
CPU
i7-9700K
Graphics
RX 580
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
A screenshot of the verbose boot could help. Or is it the apple logo and loading bar after the verbose boot?

Another thought: Do you have fakeSMC.kext (additionally) in EFI>CLOVER>kexts>Other? If not: Try.

Clover, lilu, whatevergreen and other supplementary kexts you might have installed for 10.14.3 are up to date?

Also consider disconnecting all other harddisks except your system drive during the update.
I used to have upgrade issues with clover when there were other bootable drives present during the install process.
 
Joined
Jul 28, 2010
Messages
50
Motherboard
ASUS Prime Z270-A
CPU
G4400
Graphics
RX 570
Mac
MacBook Pro
Classic Mac
iMac, Performa, PowerBook
Mobile Phone
Android, iOS
I'm gathering more information in case anyone else can help.

Here is my current system definition.

406372


I've verified the combo update I installed
406368


I'm using clover 4920

406370


I will add a screen shot of the kernel panic in a moment.
 

Attachments

Joined
Jul 28, 2010
Messages
50
Motherboard
ASUS Prime Z270-A
CPU
G4400
Graphics
RX 570
Mac
MacBook Pro
Classic Mac
iMac, Performa, PowerBook
Mobile Phone
Android, iOS
A screenshot of the verbose boot could help. Or is it the apple logo and loading bar after the verbose boot?

Another thought: Do you have fakeSMC.kext (additionally) in EFI>CLOVER>kexts>Other? If not: Try.

Clover, lilu, whatevergreen and other supplementary kexts you might have installed for 10.14.3 are up to date?

Also consider disconnecting all other harddisks except your system drive during the update.
I used to have upgrade issues with clover when there were other bootable drives present during the install process.

Hi Heading,

I do have fakeSMC in /EFI/CLOVER/kexts/Other

I've recently installed an update to Clover and then installed up-to-date versions of Lilu, and WhateverGreen in /EFI/CLOVER/kexts/10.14/

Sorry the screen shots are such poor quality, I've tried a few times to get better ones without any success. Perhaps something can be made of them?




406394



406395


406396

406397
 
Joined
Jan 16, 2011
Messages
531
Motherboard
Asus ROG MAXIMUS X HERO
CPU
i7-9700K
Graphics
RX 580
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Okay, I´m not a hackintosh specialist, so I´m not in the position to help from the info seen in your screenshots, but maybe now others are able to chime in and take over.

What comes to my mind is that the location of lilu and WEG is recommended to be in ∼Library/Extensions (properly installed with e.g.kextbeast, but there are users preferring them in /EFI/CLOVER/kexts/Others. Don´t know if it would really make a difference.
It will probably help others to judge your situation if you could give a precise description on what kind of hardware combination you are trying to upgrade, because your signature and hardware description differ.
Good luck!
 
Joined
Jul 28, 2010
Messages
50
Motherboard
ASUS Prime Z270-A
CPU
G4400
Graphics
RX 570
Mac
MacBook Pro
Classic Mac
iMac, Performa, PowerBook
Mobile Phone
Android, iOS
Good point about the sig. I've removed it since that is not the hackintosh in question. The one I'm working on now is the hardware in my hardware description. Thanks for the tips.
 
Joined
Apr 1, 2012
Messages
386
Motherboard
ASUS Maximus VIII
CPU
i7 6600k
Graphics
Gigabyte Radeon RX580
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
I had a similar issue where the update froze on the first installation screen always with 27 minutes remaining. I got around it by applying the 10.14.5 combo update to a 10.14.4 clone which then booted into 10.4.5 and everything worked including the USB patch.
 
Top