Contribute
Register

Update Directly to macOS High Sierra

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,731
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
need help! i can update appearently ok my sierra hackintosh to high sierra but when the direct update finish my computer reboot and there not seem to be a install of high sierra on my ssd. Clover only show me another HDDs but no SSD disk or any install of High Sierra. Any help please?
Maybe you had the installer convert to APFS (it is the default unless you take action to avoid it), but you forgot to add apfs.efi to EFI/Clover/drivers64UEFI.
 
Joined
Apr 21, 2017
Messages
2
Maybe you had the installer convert to APFS (it is the default unless you take action to avoid it), but you forgot to add apfs.efi to EFI/Clover/drivers64UEFI.
thanks for the answer dude! unfortunately yes, i've copy the apfs.efi to the path or i believe that i do. Can i verify if that is done? how?
 
Joined
May 31, 2017
Messages
53
Motherboard
GIGABYTE GA-Z170-HD3P
CPU
i7-6700K
Graphics
RX 580
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
Just as an FYI for GA-Z170-HD3P with Nvidia EVGA GeForce GTX 1060.

I followed the Alternative Guide: Update Directly to macOS High Sierra (HFS+)

A thing to note would be that I did not use the initially released installer. I use the newest where build 17A405. That is the one you get from the App Store when downloading it "today".

Worked perfectly. After the update I only had to update the Nvidia driver which I did via the top bar Nvidia icon.

For sound I ran toledas audio_cloverALC-130_v0.3.

(although everything seemeed, looked and sounded fine, the boot time was more than 2 minutes - I removed lily.kext - and now boot time is normal)
 
Last edited:

ec3

Joined
Jun 12, 2015
Messages
3
Motherboard
Z97X-UD7 TH
CPU
i7-4790K
Graphics
PNY GeForce GTX 780 Ti
Just finished going through the install process and when I reach the clover boot manager i have no options to boot from. No install OS X, no Boot Mac OS and no boot recovery. Any clues as to why or what to do?
 
Joined
Mar 4, 2010
Messages
4,719
Motherboard
ASUS ROG Strix Z270E-Gaming
CPU
i5-7600K
Graphics
GTX 1050 TI
Mac
MacBook Pro
Classic Mac
Power Mac
Mobile Phone
Android, iOS
Joined
Mar 4, 2010
Messages
4,719
Motherboard
ASUS ROG Strix Z270E-Gaming
CPU
i5-7600K
Graphics
GTX 1050 TI
Mac
MacBook Pro
Classic Mac
Power Mac
Mobile Phone
Android, iOS
Just finished going through the install process and when I reach the clover boot manager i have no options to boot from. No install OS X, no Boot Mac OS and no boot recovery. Any clues as to why or what to do?
APFS formatted? If yes, APFS.efi in your clover driver Folder?
 

ec3

Joined
Jun 12, 2015
Messages
3
Motherboard
Z97X-UD7 TH
CPU
i7-4790K
Graphics
PNY GeForce GTX 780 Ti
APFS formatted? If yes, APFS.efi in your clover driver Folder?
I thought I did but just looked through boot maintenance manager and it wasn't there. :facepalm:

Don't know how to add now that i can't get into any boots
 

ec3

Joined
Jun 12, 2015
Messages
3
Motherboard
Z97X-UD7 TH
CPU
i7-4790K
Graphics
PNY GeForce GTX 780 Ti
I thought I did but just looked through boot maintenance manager and it wasn't there. :facepalm:

Don't know how to add now that i can't get into any boots
All good. Used a bootable linux usb drive in test mode to add the files after the fact. Ran into some issues with the boot sequence but got the first boot up and running.
 
Joined
Dec 28, 2012
Messages
31
Motherboard
X99 Deluxe
CPU
i7 5820k
Graphics
GTX 1070
Mobile Phone
Android, iOS
I have tried to update from Sierra. But, every time i try to boot from an in place upgrade with required changes, it reboots from the install partition. Followed all the guides and even done a fresh drive and it still reboots. At least I have Sierra running; that was a challenge.
 
Top