Contribute
Register

Update Directly to macOS High Sierra

Status
Not open for further replies.
Joined
Aug 18, 2011
Messages
8
Motherboard
ASUS PRIME B365M-A
CPU
i5-9400F
Graphics
Radeon RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I am triying to perform direct upgrade and the installation get stuck here
A7E2A749-7CE2-4DF2-B183-4062AF08E826.jpeg

Any comments are welcome
 
Joined
Jan 17, 2016
Messages
43
Motherboard
MSI Z270A-Pro
CPU
7700K
Graphics
1080Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Installation went smooth, after updating Nvidia Web Drivers the resolution returned to normal and second display came on.

MultiBeast fails to install audio drivers, any ideas for Realtek ALC892? Tried https://www.tonymacx86.com/threads/high-sierra-desktop-realtek-applehda-audio.226433/ and no go.

Also how can I clean up this garbage?

crap.jpg


And although Cuda was updated to 9.0.197, it still pops up on every start saying "Update Required" although no update is available.
 
Last edited:
Joined
Nov 28, 2011
Messages
40
Motherboard
Gigabyte Z370 Aorus Gaming 5 (ver. f11)
CPU
i7-8700K
Graphics
RX 580
Mobile Phone
  1. Android
Anybody know a fix for this stall in upgrading to high Sierra?

Also, Apple removed Sierra from the app store now that high Sierra is out, how can I make a unibeast drive of If can't download the os? I lost my old USb...
 

Attachments

  • IMG_20171012_213833.jpg
    IMG_20171012_213833.jpg
    1 MB · Views: 137
Joined
Nov 12, 2013
Messages
26
Motherboard
GA Z87MX-D3H
CPU
Intel i7-4770k
Graphics
Nvidia GTX 780 3GB
Mobile Phone
  1. iOS
Hi to all,
Well this has been an ordeal to accomplish ...
My first , 2nd, 3rd, 4, 5, 6 ..., attempts where a total disaster , and it rendered my system useless, TimeMachine in the works.

I managed to find an macOS SIERRA Installation (10.12.4) on my Macbook, and recreated the USB.

I had to manually delete APFS disk in order to reinstall de macOS.
After the new setup, and appropriate configs from my old SMBIOS settings, I tried the upgrade. System was free of everything, fresh install and no APPS whatsoever on it.

The upgrade was initiated without moving to APFS. I didn't want to deal again with the process of removing it if things gone wrong again.

Got the same crash from my previous post, but I found a post somewhere, can't recall where, sorry, and changed the setting on clover configurator for the 'Drop Tables' setting. see image. I only changed that setting.

Restarted and tried again the upgrade, executing the upgrade without the APFS, although I do have a EVO 750 SSD.

After some initial error, that I couldn't see well, was to quick on displaying it, the system restarted and I let it to retry a second time. I've put the '-v' switch in order to see all messages, and setup the Gopro to record the video,

After 30 mins or so, the setup finished, and displayed an error message regarding the existence of some 'incompatible' extension, that were disabled. I restarted the system, and all seams to be ok.

Then I migrated my data from TimeMachine, and here I'm, hoping that this sticks.
Thanks to all, for the support and Tonymacx86 for its existence.

Stay well and sharp.
 

Attachments

  • Screen Shot 2017-10-13 at 08.10.17.png
    Screen Shot 2017-10-13 at 08.10.17.png
    225.3 KB · Views: 265
Joined
Oct 10, 2015
Messages
890
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
Anybody know a fix for this stall in upgrading to high Sierra?

Also, Apple removed Sierra from the app store now that high Sierra is out, how can I make a unibeast drive of If can't download the os? I lost my old USb...
Did it show a forbidden icon when not using -v? There’s also a method about downloading macOS Sierra via a command in Terminal.
 
Joined
Mar 15, 2013
Messages
24
Motherboard
GA-Z370M-D3H
CPU
i5-8400
Graphics
UHD 630
Mac
  1. iMac
My Specs

M0B0: GA B250M-D3H
7th Gen: Intel Core i5 7500
GPU: Intel HD 630
RAM: Cursair 8GB 2133mhz
LED: BenQ G2400 Resolution 1920x1200

BIG Thanks to TonyMacX86:clap:

I successful install High Sierra 10.13 on my PC with full IGPU acceleration HDMI OutPut Display.
 

Attachments

  • 1.png
    1.png
    4.2 MB · Views: 157
  • 11.png
    11.png
    3.5 MB · Views: 179
  • 111.png
    111.png
    3.5 MB · Views: 167
  • 11111.png
    11111.png
    4.2 MB · Views: 272
  • 111111.png
    111111.png
    4.1 MB · Views: 158
  • 1111.png
    1111.png
    4.2 MB · Views: 190
Last edited:
Joined
Sep 14, 2013
Messages
29
Motherboard
ASRock Z270 SuperCarrier
CPU
i7 7700
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. Android
I updated from 10.12.6 and downloaded the 10.13 app from Apple Store,
updated clover, put files like mentioned on page 1 and started the update.

I had to change smbios from macpro 5.1 to imac, because 10.13 installer wanted to make firmware update before installing.
Rebooted, installer worked for 1 sek, asked to restart to install, did so.
Had not all USB 2.0 ports but it did install and all seemed fine. Then put back my mac po 5.1 def. and restarted, USB ports are all working fine now.
Sleep + audio not working same as with 10.12./0-6. But I have an USB audio stick.

I use on this build my old hardware:
mobo X58
cpu 6core Xeon
6x4GB DDR3
3GB Ati 7950 with 27" 2560x1440


@ naveedahmad: Why did you install BETA version ?

Bildschirmfoto 2017-10-13 um 17.15.05.png
 
Last edited:
Joined
Nov 8, 2016
Messages
14
Motherboard
Gigabyte z170x-ultra gaming
CPU
core i7
Graphics
Nvida 980
Mac
  1. Mac mini
Mobile Phone
  1. Android
Anyone have any luck installing the supplemental update? It just keeps rebooting on me.
 
Joined
Jan 17, 2016
Messages
43
Motherboard
MSI Z270A-Pro
CPU
7700K
Graphics
1080Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Not sure what supplemental update you’re referring to. No updates available in the AppStore since the upgrade to High Sierra, unless Apple bundled it for all new upgrades/installations.
 
Status
Not open for further replies.
Top