Contribute
Register

Update Directly to macOS High Sierra

Joined
Dec 8, 2014
Messages
26
Motherboard
ZOTAC EI750
CPU
I7 - 4770R (HM87)
Graphics
HD 5200
Hello,

3 Questions with your permission:
  • What's the difference between putting the files on /EFI/CLOVER/kexts/Other/ to /EFI/CLOVER/kexts/10.13?
    The guide on the OP states /EFI/CLOVER/kexts/Other/ yet others put it in /EFI/CLOVER/kexts/10.13.
    Any idea what's the difference?
  • Can I go directly form 10.11.6 to 10.13?
  • I have a system based on Intel i7 4770R (Iris Pro) - See [Success] - ZOTAC ZBOX EI750.
    Currently it is defined as Mac Pro (Early 2008).
    Should I change it into something else?
    How can I do that?
Thank You.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
11,178
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Hello,

3 Questions with your permission:
  • What's the difference between putting the files on /EFI/CLOVER/kexts/Other/ to /EFI/CLOVER/kexts/10.13?
    The guide on the OP states /EFI/CLOVER/kexts/Other/ yet others put it in /EFI/CLOVER/kexts/10.13.
    Any idea what's the difference?
  • Can I go directly form 10.11.6 to 10.13?
  • I have a system based on Intel i7 4770R (Iris Pro) - See [Success] - ZOTAC ZBOX EI750.
    Currently it is defined as Mac Pro (Early 2008).
    Should I change it into something else?
    How can I do that?
Thank You.
Kexts placed in /EFI/CLOVER/kexts/Other/ will be accessible by all versions of macOS.
Kexts placed in /EFI/CLOVER/kexts/10.13/ will only be accessible by macOS 10.13 High Sierra.

It should be possible to upgrade from 10.11.6 straight to 10.13.

With your CPU, using iMac14,1 or iMac14,2 is probably a better choice than MacPro3,1. You can change it by editing your config.plist.
 
Joined
Oct 8, 2015
Messages
57
Motherboard
Gigabyte Z97x-UDH5
CPU
i5 4690K
Graphics
Gigabyte GTX 980Ti Windforce
Mac
MacBook Pro
Mobile Phone
iOS
Thanks for the guide! Success with my build using Samsung 950 PRO as a start-up disk.
Additional to the APFS guide steps 1 & 2, I removed the changes done to enable NVME for Sierra (Thank you Rehabman!).
After installation I had to use the audio_CloverALC script to fix audio (Thanks Toleda!).
Everything seems to be working: USB 3.0, iMessage, Facetime, Hand-Off, CPU PM...
 
Joined
Aug 9, 2016
Messages
21
Motherboard
Gigabyte x99 UD4
CPU
i7 5820k
Graphics
GTX 780Ti
Mac
iMac
Mobile Phone
iOS
hello
i have problem in install macOS High sierra
my hdd is not ssd
on this post 2 ways for install high sierra
i try 2 ways
but not working for me
when install macOS high sierra ( after a few seconds ) my system has been restarted
what the problem ?

my specs :

intel core i7 6700k
16 gig ddr4 2400
seagate baracuda 1tr ( not solid slate ssd )

tnx helps
Update your clover version to 4200 at least .. it is crucial step....and follow instructions explained by tonymacx86 ... I had same problem than it fixed
 
Joined
Jun 2, 2016
Messages
15
Motherboard
gigabyte z170x gaming 7
CPU
intel corei7 6700
Graphics
intel hd 530, Sapphire pulse RX 580
Mac
iMac
Hello, after several attempts, the only way I did it was:

(This works with iMac 17.1 upgrade from Sierra or clean install)
- did everything on post 1.
- after update check that I can reboot normal (without graphics acceleration)
- sip disable 0x67
- run AGDPfix and reboot
- enable sip 0x00 and nv_disable=1 and reboot
- after reboot install Nvidia drivers and reboot
- in boot options allow (check) kext from unsigned (something like that) and remove nv_disable=1

That did it for me. Hope it helps, and sorry for my English.

I also use my Sierra config.plist just check that you can boot OK before installing Nvidia drivers.
 
Last edited:
Joined
May 26, 2015
Messages
2
Motherboard
asus z97-a
CPU
i7
Graphics
gtx980
Hi Nexus66 i have a big bad luck, i cant' boot on my setup after install the update following this guide
just stay freezing on apple logo and not go on.
my setup is similar at yours, can you help me please?

my setup is:
Motherboard: ASUS SABERTOOTH Z97 MARK 2
GPU: EVGA GEFORCE GTX 970 SSC
CPU: i7 4790K
RAM: 16 Gb
System before update: 10.12.6
System definition: iMac 27 14,2


I appreciate any help or any ideas from you

thanks
Alfns, did your upgrade complete without problems? your boot problems only started after you put your GTX back or earlier? If you run with verbose (-v) what is your last console printout?
 
Top