Contribute
Register

Update Directly to macOS High Sierra

Status
Not open for further replies.
Joined
Jun 27, 2017
Messages
5
Motherboard
B85M-E/BR
CPU
i7-4790K
Graphics
R9 290X
Hey guys, let me share my experience with you all.
I just decided to upgrade to High Sierra before Multibeast and Unibeast release, I always wait, cause I'm a completely noob.
So, I installed on my HDD using APFS, and it is everything working perfectly, even HDMI audio, that I didn't had it on Sierra.
Something I need to tell is that I forgot to erase my EFI partition from Sierra, because now you have to select the option to show all the stuff in Hard Disks, right? But I just saw that in Disk Utility after the OS was installed, but it is everything working perfectly, so whatever, right? I saw some people saying that you can't install APFS on HDD, maybe mine it is working, because I forgot to erase EFI partition from Sierra?

Thanks for all the help, tonymac and the people who support this, will always be amazing.

PS: for audio and video to work properly I downloaded AppleALC, Lilu, and WhateverGreen from vit9696.
 

Attachments

  • Screen Shot 2017-09-27 at 4.38.55 PM.png
    Screen Shot 2017-09-27 at 4.38.55 PM.png
    2 MB · Views: 229
  • Screen Shot 2017-09-27 at 4.39.05 PM.png
    Screen Shot 2017-09-27 at 4.39.05 PM.png
    1.7 MB · Views: 242
  • Screen Shot 2017-09-27 at 4.40.15 PM.png
    Screen Shot 2017-09-27 at 4.40.15 PM.png
    110.4 KB · Views: 200
Joined
Feb 19, 2011
Messages
93
Motherboard
Gigabyte Z97-UD5H
CPU
i7 4790k
Graphics
GTX 1070
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Just a thanks too tonymac and the boys, all working here, simple upgrade no problems as per instructions and tips in here thank you.
 
Joined
Mar 10, 2011
Messages
1
Motherboard
foxconn hm77
CPU
intel i5 3317U
Graphics
intel hd4000
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
After hours of lag and freeze, when I can back this morning, everything works like a charm! Amazing.

Intel i5-2400
Gigabyte Z77-DS3H
Nvidia GTX960 2GB with new web driver
Samsung 840evo
 
Joined
May 3, 2012
Messages
10
Motherboard
GIGABYTE GA-Z68XP-UD3
CPU
Intel Core i5-2500K Sandy Bridge 3.3GHz
Graphics
XFX Radeon HD 6870
Mac
Classic Mac
  1. Performa
  2. PowerBook
Mobile Phone
  1. iOS
@Mingjoy I've had some luck!

This fixed my issue of the installer sticking at the apple sign

I followed the advice in this post... (ignore the kexts to patch part)

High Sierra is now installing :)

This worked for me - to a point. I was able to begin the installation, however the installation fails and the installer gives me a message that the operation could not be completed (com.apple.DiskManagement error 0.)

So, I guess I have a new problem?
 
Joined
Jun 10, 2016
Messages
31
Motherboard
Gigabyte H370-D3H
CPU
i5 9600KF
Graphics
ASUS RX 570
Mac
  1. Mac mini
Classic Mac
  1. iBook
  2. Plus
Mobile Phone
  1. iOS
Went and did the upgrade today on Handles - did the install on top of my Sierra SSD drive (after doing a backup with SuperDuper). Followed the instructions with the EFI partition and Clover. Took about 40 minutes to install, then it told me the NVIDIA web drivers were available. Installed those and rebooted - everything is fine and it seems to be running OK. Didn't even have to fix audio.
Screen Shot 2017-09-27 at 7.59.25 PM.png
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,222
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
EDIT: never mind, right after I posted this I found it under another disk identifier.

I have High Sierra installed and running but forgot to copy the apfs.efi to my EFI folder on my Sierra boot SSD where Clover is installed in the EFI partition. I able to boot using a USB stick with Clover installed but now that I am in High Sierra I do not see where clover is installed any more since there doesn't appear to be an EFI partition on my now AFPS drive. However, if I remove the USB stick and try to boot normally, Clover still pops up so it is there somewhere on the drive.

Any ideas?

Here is a screenshot of the AFPS volumes:
Screen Shot 2017-09-27 at 9.02.24 PM.png
 
Joined
Jul 23, 2012
Messages
802
Motherboard
GA-Z77N-WIFI-F3-Clover
CPU
E3-1225 v2
Graphics
GT 640 | P4000
Mac
  1. Mac mini
EDIT: never mind, right after I posted this I found it under another disk identifier.

I have High Sierra installed and running but forgot to copy the apfs.efi to my EFI folder on my Sierra boot SSD where Clover is installed in the EFI partition. I able to boot using a USB stick with Clover installed but now that I am in High Sierra I do not see where clover is installed any more since there doesn't appear to be an EFI partition on my now AFPS drive. However, if I remove the USB stick and try to boot normally, Clover still pops up so it is there somewhere on the drive.

Any ideas?

Here is a screenshot of the AFPS volumes:
View attachment 281323

try boot from USB linux, can you see the FAT32 EFI partition
 
Status
Not open for further replies.
Top