Contribute
Register

Update Directly to macOS High Sierra

Status
Not open for further replies.
Joined
May 7, 2014
Messages
22
Motherboard
GA-H97N-WIFI
CPU
i7-4790K
Graphics
MSI GTX1080
Mobile Phone
  1. iOS
  2. Other
i have OSX system installed on SSD, so after update this disk will be convertet to APFS, but i have classic HDD for "DATA" which is formated with HFS, my question is: will be this "DATA" disk work after update? or can i acces this HDD formated with HFS after update?
 
Last edited:
Joined
Aug 25, 2012
Messages
5
Motherboard
Mac
CPU
i7
Graphics
nVidia
Mac
Classic Mac
Mobile Phone
after starting macos high sierra installer in clover, this is happening...
IMG_20170927_113239.jpg
 
Last edited:
Joined
Nov 1, 2012
Messages
44
Motherboard
GA-Q77M-D2H
CPU
i7-3770
Graphics
HD 4000
Mobile Phone
  1. iOS
Same issue here. In verbose mode I get a message that says localhost com.apple.xpc.launchd[1] (com.apple.bsd.dirhelper.532) <warning> : Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in() : com.apple.bsd.dirhelper

Then some other lines too fast to read, then black screen, then finally a simple line at the top of the screen with the date and "
iMac.local com.apple.XPC. Launchd[1] (com.apple.windowserver) <notice>: service only ran for 0 sec. Pushing respawn out by 10 seconds". And it seems to enter in an infinite loop (left it over 30 min running, nothing, nor any sign of activity from the HD). I'll run it again to check exactly what it's saying at the end.

I've followed all the steps in the guide, and when I force a reboot I can still boot on Sierra, so I guess the installation process gets stuck before making any definite action.

Any update? Having the same, started a thread here.
 
Joined
May 18, 2011
Messages
4
Motherboard
MSI H61m-p31
CPU
i5 3470
Graphics
ASUS GTX 650
Mobile Phone
  1. iOS
Joined
Jul 28, 2012
Messages
200
Motherboard
Asus RoG Strix Gaming z370e
CPU
i5-8600K
Graphics
RX 580
On the one hand - upgrade to HS from Sierra now that NVidia Drivers are available... Sweet as a Nut! Everything working.... USB3, Sound, Video,,,, AFPS on a HyperX SSD...

HOWEVER!!!

I have tried several times to create an installer USB Stick,,,, and install to a Sata Partition... every time I get OSInstall.mpkg appears to be missing!!! What gives???? I'm using the same procedure for creating the stick as I did with the GM a week ago... which did install to this partition on one occasion

Is there an issue or have apple pulled a fast one like they did on Mavericks I believe it was... where you had to copy over the intall packages,,,

USB Stick (Verified) Install info please guys!!!
 

Attachments

  • Untitled.png
    Untitled.png
    1.8 MB · Views: 283
Joined
Jul 9, 2017
Messages
17
Motherboard
asus N551VW
CPU
corei7
Graphics
nvidia
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
I removed the discrete graphics card (a Nvidia GT 1030) and upgraded my hackintosh to High Sierra with only the internal graphics (an Intel HD P4600). The upgrade went fine and was successful.
Can you set the efi / clover section for download?
 
Joined
Jul 21, 2011
Messages
44
Motherboard
Asus ROG Maximus XI Hero
CPU
i9-9900k
Graphics
GTX1080 & AMD Radeon Pro 5100
Guys is possible to boot high sierra APFS from external SSD (sata-USB) ?
As Hfs+ it works , after conversion it won't bot anymore :(
 
Joined
Oct 15, 2013
Messages
17
Motherboard
Z170X-UD5 TH
CPU
I7-6700K
Graphics
Vega 64
Mobile Phone
  1. iOS
Downloaded today's official High Sierra Update. Performed a direct update from 10.12.6. First updated Clover to v2.4k r4220, and then followed APFS guide above. Everything seems to be working with the exception of audio. I then downloaded and ran audio_cloverALC-130_v0.3.command, rebooted and my audio devices were now there. :) Thanks Toleda!
Later on I discovered my USB 3.0 ports weren't working. Downloaded USBinjectAll.kext and modified config.plist with the new raise port edits for High Sierra. Working now. Thanks tonymacx86! :)

View attachment 280452

View attachment 280453

View attachment 280456

hi, in-n-out
my system is same yours.
but I'm failed to update high Sierra.
install process not show up, my monitor black out when install high Sierra.
so Can you upload your using config.plist file?

Best Regard.
 
Joined
Jul 27, 2017
Messages
5
Motherboard
ASUS B150I
CPU
I5-7500
Graphics
HD 630
Mac
  1. iMac
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Downloaded today's official High Sierra Update. Performed a direct update from 10.12.6. First updated Clover to v2.4k r4220, and then followed APFS guide above. Everything seems to be working with the exception of audio. I then downloaded and ran audio_cloverALC-130_v0.3.command, rebooted and my audio devices were now there. :) Thanks Toleda!
Later on I discovered my USB 3.0 ports weren't working. Downloaded USBinjectAll.kext and modified config.plist with the new raise port edits for High Sierra. Working now. Thanks tonymacx86! :)

View attachment 280452

View attachment 280453

View attachment 280456


hi, when i upgrade the High Sierra, my usb device can't work, such as usb keyboard mouse?

i copy the USBinjectAll.kext to the EFI/CLOVER/kext/Other, and is it right? and what's your monfied config.plist?
 
Status
Not open for further replies.
Top