Update Directly to macOS Catalina

What are my options here? I guess I would need to get a new WiFi adapter. Can someone please suggest one that would work with my setup?
I have just purchased and installed a Fenvi FV-HB1200 PCI-E Wireless Card that has Bluetooth 4 and 2.4/5GHz Wi-Fi in my setup and it just works without any mods.
Update available :)


  • Screenshot 2019-10-12 at 11.02.01.png
    Screenshot 2019-10-12 at 11.02.01.png
    61.4 KB · Views: 164
I'm definitely doing something wrong and need help. Trying to install from a boot USB and no matter what I try I just get Error loading kernel cache 0xe when trying to boot. I've tried following the instructions exactly as they are on the boot USB thread, using the vanilla clover installer, the UEFI custom clover 4961 available from tonymacx86 and even just copied the EFI folder from my main system EFI (currently working fine with Mojave) to the USB EFI partition and then dropping in the latest kexts. I've also tried using the -disablegfxfirmware flag as some have suggested to no avail. I just always get the same error.

Anyone know what I am doing wrong and can suggest help would be greatly appreciated. My motherboard is the ASUS 270-A, i7-7700k CPU and RX 580 GPU. The system is working perfectly with Mojave, I wanted to install a fresh copy of Catalina but I may have to try and just do an update from Mojave, although I'm nervous to do that with the problems I'm having trying to get the USB to boot. If you need any additional info to help me let me know. Thanks!

(Sorry just realised I've posted this in the update directly instead of USB thread where it's relative. Too many tabs open trying to get this to work)
Last edited: