Contribute
Register

Update Directly to macOS Catalina

Joined
Jan 13, 2019
Messages
15
Motherboard
Gigabyte AORUS Z390 PRO
CPU
i9 9900K
Graphics
Vega 64
Updated to Catalina today without any issues till now. Just did the simple upgrade without any changes.
 
Joined
Apr 1, 2019
Messages
2
Motherboard
z370-f
CPU
i7 8700k
Graphics
GTX 1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Updated to Catalina today without any issues till now. Just did the simple upgrade without any changes.
Is normal that is taking forever?
 

Attachments

  • A97E1C26-A074-4D8A-AF8D-140ED703059B.jpeg
    A97E1C26-A074-4D8A-AF8D-140ED703059B.jpeg
    2.2 MB · Views: 554
Joined
Sep 29, 2012
Messages
26
Motherboard
ASRock Z77 Pro4-M
CPU
i5-3450
Graphics
GTX 550 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Anyone else getting this "You must be running macOS Catalina 10.15 or later..." ? Trying to update from Mojave 10.14.5 to Catalina. Clover is ver. 5070, restarted but still can't update.

Thanks.

View attachment 429158

I have this issue as well. When booting from Clover, I can see Installer from the APFS drive. I can boot, and it installs then reboots, and it just keeps going into that loop.
 
Joined
Mar 10, 2011
Messages
348
Motherboard
Gigabyte Designare TRX40
CPU
Ryzen 3970x
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Foster I downloaded Catalina from the AppStore final version 10/7 8.09gb but I can’t find the install macOS Catalina app to be able to copy as backup before updating where it is located on the hackintosh, I can’t find it in applications? Thanks

If you let the installer run, and do the update it deletes the Install App at some point.
That is why I always copy it to another location before doing the install

if you need to download the Install App again search for how to install catalina on unsupported mac on youtube
 
Last edited:
Joined
Apr 10, 2019
Messages
12
Motherboard
Dell Optiplex 7010
CPU
i7-3770
Graphics
HD4000
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Color Classic
  2. iBook
  3. iMac
  4. LC
  5. Plus
  6. Power Mac
  7. PowerBook
  8. SE/30
Mobile Phone
  1. iOS
I just upgraded from 10.14.4 to 10.15. It took about an hour and went smoothly as described. The audio broke but I re-added the Lilu KEXT and rebooted and that fixed it. All is well.
 
Joined
Jul 15, 2017
Messages
133
Motherboard
Gigabyte GA-Z270XP-SLI
CPU
i7-7700K
Graphics
RX 570
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Dumb question, but ... if I already have these kexts installed to /L/E:

AppleALC.kext
FakeSMC.kext
IntelMausi.kext
Lilu.kext
USBInjectAll.kext
WhateverGreen.kext
XHCI-unsupported.kext

Do I also need to copy them to Clover/kexts/Other for this upgrade?

And do I need to set config.plist/SystemParameters/InjectKexts=Detect so that Clover will inject all applicable (depending on version) kexts in EFI/Clover/kexts/Other only if FakeSMC.kext is NOT in kernel cache.
 
Joined
Jan 25, 2019
Messages
9
Motherboard
Z370G
CPU
i7 8700
Graphics
RX580
Every step went smoothly excep when I boot macOS from my target disk. Finally, screen showed only a white corner and cursor.When I clicked mouse, the cursor disappeared. What on earth is the problem? Does anyone know this? Please help me.
67DA0449-F988-4E2F-8C29-D6A97D53D0C8.png15A55A9B-9458-4669-8323-C4C22975C2E1.jpeg0C331712-6011-4EE3-9D7A-B1CF32F8325E.png4CE1C896-C9A1-4F64-AB0C-401711FBE385.jpeg
 
Joined
Feb 24, 2019
Messages
13
Motherboard
Dell 04YVDP
CPU
i5 - 7200U
Graphics
HD 620
After the first restart, chose Boot macOS Install option and stuck at this.
Please help me out here, not able to find any solution.
 

Attachments

  • IMG_20191009_115954.jpg
    IMG_20191009_115954.jpg
    1.4 MB · Views: 1,406
Top