Contribute
Register

Update Directly to macOS Big Sur

Joined
May 6, 2014
Messages
13
Motherboard
Gigabyte GA-Z270X-Ultra Gaming
CPU
3.6 GHz Intel Core i7
Graphics
Radeon RX 580 8192 MB
Mac
  1. iMac
Mobile Phone
  1. iOS
Can any one advice me if my system info is sufficient enough for Big Sur ?
To be honest I have Been toying with buying a older iMac 27/2017 ish, but feel my current hackinosh will probably be better and way cheaper.. it just the mission of updating it!
 
Joined
Aug 5, 2016
Messages
15
Motherboard
ASUS ROG STRIX Z490-I GAMING
CPU
Core i7-10700
Graphics
Intel UHD 630
Updated from Catalina 10.15.7 with OC 0.6.3 without any issues. The only thing that needed to replace is the Airporttltwm wifi kext for Catalina. Replaced it with Airporttltwm.kext for Big Sur. All applications, wifi/bluetooth, MS Office, Zoom, MS Teams, VPN, stock trading streaming tools, etc. are working properly after the update. A simple update like before.
Rig: Asus Z490i-Gaming, i7-10700, Samsung Evo 970 NVMe M.2 500G, 16X2 32GB Corsair Vengeance RGB Pro RAM.
 
Joined
Sep 1, 2020
Messages
2
Motherboard
asus p68p67
CPU
i5 3.1
Graphics
geforce 1060
Mac
  1. iMac
  2. MacBook Pro

nevermind me..... i was misreading it or something. idk.

Thanks for the guides!
 
Last edited:

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
5,351
Motherboard
Gigabyte Z390M Gaming - Clover 5102
CPU
i5-9600K
Graphics
RX 570 1920x1080
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
Can anyone please explain this to me? In step 4, he says to install to your system drive (Which is called Macintosh HD). Then here in step 5, he says that once clover is loaded to chose to Boot install from Macintosh HD, but says choosing the system drive sends you back without updating. Is "Macintosh HD" not the same drive as system drive?

Please help this poor confused man... me.

Hi there.

No, he is correct. What happens is, once the main drive - Macintosh HD - is prepared, system files are copied across to it. On reboot an extra new Clover Boot entry appears with "Boot install from Macintosh HD" as well as the others. Basically you now have three Clover icons until the install is complete and then this reduces to two - Macintosh HD and Recovery. The trick is to select the Boot Install... option throughout all the reboots until it is no longer there.

(P.S in the above I've ignored the "Preboot" options which can be hidden using a setting in config.plist.)

:)
 
Joined
Sep 1, 2020
Messages
2
Motherboard
asus p68p67
CPU
i5 3.1
Graphics
geforce 1060
Mac
  1. iMac
  2. MacBook Pro
Hi there.

No, he is correct. What happens is, once the main drive - Macintosh HD - is prepared, system files are copied across to it. On reboot an extra new Clover Boot entry appears with "Boot install from Macintosh HD" as well as the others. Basically you now have three Clover icons until the install is complete and then this reduces to two - Macintosh HD and Recovery. The trick is to select the Boot Install... option throughout all the reboots until it is no longer there.

(P.S in the above I've ignored the "Preboot" options which can be hidden using a setting in config.plist.)

:)

Thank you. I read through it a few more times and then realized I was confusing the two icons or something. thanks again!
 
Joined
Aug 2, 2013
Messages
871
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
HD 4600 / RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
I have successfully updated my Mojave NVME drive to Big Sur. I have Catalina on another NVME drive, which I still use as my main OS.

I use OpenCore (currently 0.6.3), had both OS's booting from the same OC folder.

Downloaded Big Sur on the Catalina drive as an update via the System Preferences > Software Update pane. I did this on the Catalina drive, as that is my main drive but could have just as easily downloaded it to my Mojave drive.

I made sure I selected the Mojave drive for Big Sur installation location.

System ran through the boot process with no issues and updated my Mojave 10.14.6 to Big Sur 11.0.1. As I had the OC folder set to run Mojave and Catalina, with the latest kexts etc. there were absolutely no boot or installation issues during the update process, well not from the installer.

Only thing I forgot to do was to remove the obsolete (32-bit) Adobe CS6 Master Collection applications before the update. Took me longer to remove the Adobe applications and the associated preferences, files and folders than it did to install Big Sur.
 
Joined
Nov 22, 2011
Messages
43
Motherboard
GA-Z270-HD3
CPU
i7-7700K
Graphics
RX 570
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Upgraded my MacPro 7,1 build to Big Sur today - seamless, and unattended upgrade :headbang:

Updated to OpenCore 0.64, introduced the use of "CpuTscSync.kext", replacing "TSCAdjustReset.kext", as well as following "Fixing MacPro7,1 Memory Errors", and removing "MacProMemoryNotificationDisabler.kext" which is not supported under Big Sur.
 
Last edited:
Joined
Jan 13, 2013
Messages
8
Motherboard
ASUS B85M-G
CPU
i5 4440
Graphics
HD 4600
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Had Catalina running on a NVMe in a Asus B85M-g, i5-4440, 16GB RAM. I didn't want to ruin a functioning system yet,
so just through in a SSD and loaded fresh calcine with MultiBeast applied. I spent hours messing around with numerous combos trying to update clover. OMG! I threw in the towel and went with OC, success! Easy peasy! Read the guide, and you'll be up in no time.
Now just loading up Big Sur on the NVMe drive.
 
Joined
Jul 30, 2012
Messages
53
Motherboard
Gigabyte H97-D3H
CPU
i7-4970
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
Upgraded from Cataline to Big Sur using Clover bootloader. Audio, BT and wifi working perfectly. Had to update the Clover config.plist to MacBbook Pro 2017. That was it .... having a working Big Sur iMac... Thanks TonyMacx86!!!
 
Joined
Jun 29, 2013
Messages
3
Motherboard
GA-X79-UP4
CPU
Xeon E5 8-Core 2.4Ghz
Graphics
Radeon RX 580
Mac
  1. Mac Pro
Upgraded from Catalina to Big Sur too using Latest Clover R5129. Biggest hurdle for me was upgrading Clover from R5107 to latest supporting BigSur. I did try to migrate from Clover to OC but couldn't find a good dual boot options so went back to Clover. Followed guide at top and worked seemless. Everything working here.

*Edit - spoke to soon. App store not working for installs/updates. Reinstalled via preboot as discussed here and now working appstore.
 
Last edited:
Top