Contribute
Register

Unlock With Apple Watch Not Working In Catalina

Joined
Apr 14, 2012
Messages
11
Mac
Classic Mac
Mobile Phone
I'm having exactly the same issue on 10.14.6. "Unlocking with Apple Watch" appears for a split second then disappears. I've tried everything I can think of, everything suggested on this thread. It was working before the 10.14 upgrade.
 
Joined
Mar 6, 2017
Messages
119
Motherboard
ASUS ROG Maximus IX Hero
CPU
i7-7700K
Graphics
RX 580
So today I updated my OS to 15.3 and opencore it broke the watch. So I updated the watch my phone still not luck. Then I did a reinstall of the os Downloaded from the App Store. Once it was done I was able to unlock the system with the watch again. Even with my 2018 Mac mini my watch is finicky.
@scottkendall just to clarify your answer, after updating to 10.15.3 you reinstalled macOS 10.15.3 on top of the existing installation and that caused unlock with apple watch to start working again? Can you also confirm you had the same exact symptoms where all other handoff/continuity features work including approve with Apple Watch (approve admin dialogs by double tapping the watch button) but unlock with Apple Watch shows a spinner at the login prompt and them times out and asks for the password?

I haven't had it working in my Catalina system since upgrading from Mojave. It seems weird that an in-place install of macOS would fix this issue, but I'm willing to try if you can confirm you had the same symptoms.
 
Joined
Jul 13, 2016
Messages
1,672
Motherboard
Gigabyte Z370 Gaming 5
CPU
I7 8700K
Graphics
Vega 64
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
@scottkendall just to clarify your answer, after updating to 10.15.3 you reinstalled macOS 10.15.3 on top of the existing installation and that caused unlock with apple watch to start working again? Can you also confirm you had the same exact symptoms where all other handoff/continuity features work including approve with Apple Watch (approve admin dialogs by double tapping the watch button) but unlock with Apple Watch shows a spinner at the login prompt and them times out and asks for the password?

I haven't had it working in my Catalina system since upgrading from Mojave. It seems weird that an in-place install of macOS would fix this issue, but I'm willing to try if you can confirm you had the same symptoms.
I do not wear the watch often enough to know if it unlocks everything it should. However, yes handoff/continuity features were working, I never tried the tapping of watch buttons. But it showed a spinner at the login prompt and then timed out. Before I updated to 10.15.3 it worked and after I updated it did not. My steps were to make sure the Watch had the most up to date software version, also my phone just in case. Then I reinstalled 15.3 over the top of 15.3 set the watch up again and it worked. I am not sure about Native Nvram is the issues as @ricker59 says but I can tell you I do have working native Nvram.

No I do not use EmuVariableUefi or RC scripts... However, I would imagine your board supports Native Nvram and does not require them either.
 
Joined
Mar 6, 2017
Messages
119
Motherboard
ASUS ROG Maximus IX Hero
CPU
i7-7700K
Graphics
RX 580
No I do not use EmuVariableUefi or RC scripts... However, I would imagine your board supports Native Nvram and does not require them either.
I don't believe that's the case for my board. I cannot set nvram variables and have them persisted after boot without using EmuVariableUefi.

Another question about your configuration. Does anyone else here have FileVault2 enabled? I'm wondering if this is related to using FileVault2 disk encryption.
 
Joined
Jul 13, 2016
Messages
1,672
Motherboard
Gigabyte Z370 Gaming 5
CPU
I7 8700K
Graphics
Vega 64
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
I don't believe that's the case for my board. I cannot set nvram variables and have them persisted after boot without using EmuVariableUefi.

Another question about your configuration. Does anyone else here have FileVault2 enabled? I'm wondering if this is related to using FileVault2 disk encryption.
Maybe that is because you do not use a memory fix that has native Nvram support.
 
Joined
Jul 13, 2016
Messages
1,672
Motherboard
Gigabyte Z370 Gaming 5
CPU
I7 8700K
Graphics
Vega 64
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
Joined
Jul 13, 2016
Messages
1,672
Motherboard
Gigabyte Z370 Gaming 5
CPU
I7 8700K
Graphics
Vega 64
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
Top