Contribute
Register

Unibeat 9.2.0 fails always creating Legacy boot mode drives (error copying apfs.efi)

Joined
Jun 19, 2019
Messages
1
Hi guys,

Ive seen a lot of reports of this problem, but none of them include the needed details. I hope this would help to debug this problem.

Following the report steps:
  1. UniBeast version: 9.2.0 (latest)
  2. UniBeast choices: Legacy Boot mode (as I have an intel P67 motherboard), Mojave, my 32 GB USB drive. I didnt selected ATI or NVIDIA injection (as I've never needed them in any previous hackintosh installations for this HW)
  3. USB partition scheme, GPT or MBR and size of the destination partition: GPT, but I'd tried with MBR, and I'd got same error.
  4. System specifics where UniBeast was run including hardware configuration and macOS version. Asus P8P67 rev 3.1, Core i5-2400, ATI radeon HD 6570, 16GB RAM, SSD disk and macOS 10.12.6. Old hardware, but, it is still rocking.
  5. Error message: Copy of apfs.efi failed. (screenshot attached)
  6. Contents of UniBeast.log (attached)
  7. Contents of install.log (attached)
Additional information:
* Ive tried this command cited in other posts:
sudo diskutil partitionDisk /dev/disk3 GPT JHFS+ USB R
And Ive managed to format the drive properly (no other process were using the USB drive), but still UniBeast throws the apfs.efi error.
* Ive created a UniBeast drive with the exactly the same configuration but setting the UEFI boot mode, and It worked! But, sadly, as I have a P67 motherboard, I can't boot from the USB drive. But, this will give some information: in my case, the apfs.efi error happens only while configuring the Legacy boot mode, no matters how I format the USB drive (GPT, MBR, or using the provided command), but is working using UEFI boot mode config.

413073
 

Attachments

MacMan

Administrator
Staff member
Joined
Feb 2, 2010
Messages
8,261
Motherboard
ASUS ROG STRIX Z370-E GAMING - 1601 - UEFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook Pro, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
I just ran UniBeast on my CoffeeLake hack running 10.13.5 with no issues:

06/26/19 13:20:33 - Starting UniBeast 9.2.0-6
06/26/19 13:20:51 - Copying Files...
06/26/19 13:33:20 - Installing Clover Bootloader...
06/26/19 13:33:51 - Copying apfs.efi for Legacy Boot Mode...
06/26/19 13:33:57 - UniBeast USB Creation Successful

I ran it 2 times, the first time the USB2 stick was formatted as MBR and the second time it was formatted as GPT.
 
Joined
May 20, 2011
Messages
87
Motherboard
P8Z68-V PRO
CPU
i5-2500k
Graphics
GTX 1080
Mobile Phone
Android, iOS
I am also having the exact same problem..
I need to create a mojave legacy usb installer but it fails with the same error each time on unibeast 9.0.2
Any solutions to this?

It seems like when the EFI partition gets auto mounted
that is when it fails cos it can't copy the apfs file to that EFI partition.
That is what Obvious Answer Man said in another thread about the same error message.
 
Last edited:
Top