Contribute
Register

UniBeast problems, please help! "Couldn't create USB installer"

Joined
Jun 14, 2013
Messages
10
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
GTX 1070 Ti
Mac
  1. MacBook Pro
Hey Hackintosh friends!

I am having some trouble... I've tried searching through the threads using "Couldn't create USB installer"
I've read through the Unibeast troubleshoot notes: https://www.tonymacx86.com/threads/unibeast-8-troubleshooting-notes.235489/
And still, I can't find a solution that works.

I've tried running the Unibeast install on two different MacBooks.
I've tried re-downloading the Catalina file from iTunes.
I've bought two new USB sticks. I've formatted, and re-formatted, and reformatted, and reformatted, etc etc etc.
and nothing. I'm at a loss and I'm itching to get this Hackintosh up and running. So alas here we are, shamelessly asking for you to help a n00b get this thing up and running.

About my build:
I've basically followed this build; https://www.tonymacx86.com/threads/...390-thunderbolt-3-i7-9700k-amd-rx-580.267551/
with a few alts, all verified to work for a Hackintosh build (Ex. i9 9900k, 64gb ram, Samsung ssd etc)
and given that we haven't even made it to the bootable USB that the components aren't the issue right now.

Here is the UniBeast LOG:
03/22/20 14:51:48 - Starting UniBeast 10.0.0-8
03/22/20 14:52:43 - Copying Files...
03/22/20 14:54:22 - Couldn't create USB installer
03/22/20 15:30:49 - Starting UniBeast 10.0.0-8
03/22/20 15:31:11 - Copying Files...
03/22/20 15:31:11 - Couldn't create USB installer
03/22/20 15:31:37 - Starting UniBeast 10.0.0-8
03/22/20 15:32:03 - Copying Files...
03/22/20 15:32:03 - Couldn't create USB installer
03/22/20 15:32:09 - Starting UniBeast 10.0.0-8
03/22/20 15:32:32 - Copying Files...
03/22/20 15:32:32 - Couldn't create USB installer
03/22/20 15:36:40 - Starting UniBeast 10.0.0-8
03/22/20 15:37:00 - Copying Files...
03/22/20 15:37:00 - Couldn't create USB installer
03/22/20 15:37:29 - Starting UniBeast 10.0.0-8
03/22/20 15:37:47 - Copying Files...
03/22/20 15:37:47 - Couldn't create USB installer
03/23/20 20:29:37 - Starting UniBeast 10.0.0-8
03/23/20 20:29:53 - Copying Files...
03/23/20 20:29:53 - Couldn't create USB installer
03/23/20 20:29:57 - Starting UniBeast 10.0.0-8
03/23/20 20:30:11 - Copying Files...
03/23/20 20:30:11 - File system user/group ownership enabled
msg --- Copying Files...
03/23/20 20:30:12 - Couldn't create USB installer
03/23/20 20:33:27 - Starting UniBeast 10.0.0-8
03/23/20 20:33:46 - Copying Files...
03/23/20 20:33:46 - Couldn't create USB installer

Unibeast version: 10.0.0 Catalina found here: https://www.tonymacx86.com/resources/unibeast-10-0-0-catalina.448/
Unibeast Choices:
Destination: USB Flash Drive (Tried a partitioned 64gb into a 32gb, a 16gb, all journaled & GUID Partition Map, Named; Install macOS Catalina)
OS: Catalina
Bootloader: UEFI Boot Mode (but I tried legacy once just to see if it made a difference, nope)


Let me know if you have any ideas, thoughts, questions, etc. Thanks for the help!! I appreciate it
 

MacMan

Administrator
Staff member
Joined
Feb 2, 2010
Messages
8,628
Motherboard
ASUS TUF Z390-PRO GAMING - 2606 - UEFI
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Typically this is due to a USB write error. Try a different USB stick and/or system or USB port.
 
Joined
Jun 14, 2013
Messages
10
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
GTX 1070 Ti
Mac
  1. MacBook Pro
Typically this is due to a USB write error. Try a different USB stick and/or system or USB port.
Hey thanks for the reply! I've tried all of these... (found this advice on previous threads)
I've tried 3 different USB sticks, all different brands.
Two different Macs.
Different USB ports

and NOTHING :'(
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
18,896
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
I've tried 3 different USB sticks, all different brands.
Two different Macs.
Different USB ports
Have you disabled SIP before trying to make the USB ? If the Mac you're using to create the USB is on Catalina this is required for the USB creation to succeed.
 
Joined
Jun 14, 2013
Messages
10
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
GTX 1070 Ti
Mac
  1. MacBook Pro
Have you disabled SIP before trying to make the USB ? If the Mac you're using to create the USB is on Catalina this is required for the USB creation to succeed.

Didn't seem to change anything. Same problem.
With SIP disabled,
I tried re-formatting the USB stick, and running UniBeast using two different ports. Neither worked. Exactly same issue.
Thanks for the suggestion though.
 
Joined
Mar 25, 2020
Messages
1
Motherboard
Dell XPS 8000
CPU
i5
Graphics
GTX 760
I'm having the exact same issue. Log is the same, just three entries per attempt.

03/23/20 20:29:37 - Starting UniBeast 10.0.0-8
03/23/20 20:29:53 - Copying Files...
03/23/20 20:29:53 - Couldn't create USB installer

MacBook Pro Early 2013.
Running Catalina 10.15.4
18GB free on Macbook drive
Tried two USB sticks:
  1. 8 GB USB
  2. 16 GB USB
SIP is disabled.
I've deleted and re-downloaded the Catalina from the app store. Catalina download is around 8GB

I've noticed the 'Install MacOS Catalina' file on the USB stick never grows above 528.7MB

UPDATE: I spoke to soon. It worked on the 16GB USB drive. Looks like Catalina needs more than 8GB for the install USB.
 
Last edited:
Joined
Jun 14, 2013
Messages
10
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
GTX 1070 Ti
Mac
  1. MacBook Pro
I'm having the exact same issue. Log is the same, just three entries per attempt.

03/23/20 20:29:37 - Starting UniBeast 10.0.0-8
03/23/20 20:29:53 - Copying Files...
03/23/20 20:29:53 - Couldn't create USB installer

MacBook Pro Early 2013.
Running Catalina 10.15.4
18GB free on Macbook drive
Tried two USB sticks:
  1. 8 GB USB
  2. 16 GB USB
SIP is disabled.
I've deleted and re-downloaded the Catalina from the app store. Catalina download is around 8GB

I've noticed the 'Install MacOS Catalina' file on the USB stick never grows above 528.7MB

UPDATE: I spoke to soon. It worked on the 16GB USB drive. Looks like Catalina needs more than 8GB for the install USB.

Glad it worked for you. I tried all methods above and nothing. I don't know what the deal is but I'm working on a Mojave install instead atm and it's proceeding well so far. Will attempt an update to Catalina after the install. Posting this in case someone else gets stuck like so they know there's an alternate route if the newest install doesn't work.
 
Top