Contribute
Register

Unibeast Mojave Install Hanging

Joined
Feb 15, 2019
Messages
19
Motherboard
Asrock Z390 Phantom Gaming-ITX/ac
CPU
i5-9600K
Graphics
UHD 630
Hi there. This is my first Hackintosh build ever, which of course means I have no idea what I'm doing wrong and why I can't get to the installer anymore.

The very first pass through, I got to the Install screen, but the machine was in a boot loop where the install page would say "31 minutes remaining" for about 2 minutes, then restart, only to bring up the same page when it restarted.

I've tried numerous install paths and processes, and none of them are getting me past this point in the picture below.

Here are my current Hardware bits:

Mobo: ASRock Z390 Phantom Gaming-ITX/ac on P1.50 (latest UEFI BIOS vers.)
CPU: Intel Core i5-9600K at Stock Settings
RAM: 8 GB G.Skill Aegis DDR4 3000 (1 stick, XMP initialized)
Install HDD: Seagate 120 GB (I have a 1TB backup from the iMac I want to transfer files from which I'll migrate in later, hopefully)

I've set all the BIOS options to what I could find, but there is no "Set to Optimized" option on this board, and the only Super UI Config Option is for "PS2 Y-Cable," which only has Auto and Enabled in their sections, so nothing I could change on that front.

In case it's not clear, the line it's stalling on reads:
"apfs_module_start:1340: load: com.apple.filesystems.apfs, v945.241.4, 945.231.4, 2019/01/01"

Any help would be greatly appreciated.
 

Attachments

Joined
Jul 25, 2012
Messages
6,399
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Hi there. This is my first Hackintosh build ever, which of course means I have no idea what I'm doing wrong and why I can't get to the installer anymore.

The very first pass through, I got to the Install screen, but the machine was in a boot loop where the install page would say "31 minutes remaining" for about 2 minutes, then restart, only to bring up the same page when it restarted.

I've tried numerous install paths and processes, and none of them are getting me past this point in the picture below.

Here are my current Hardware bits:

Mobo: ASRock Z390 Phantom Gaming-ITX/ac on P1.50 (latest UEFI BIOS vers.)
CPU: Intel Core i5-9600K at Stock Settings
RAM: 8 GB G.Skill Aegis DDR4 3000 (1 stick, XMP initialized)
Install HDD: Seagate 120 GB (I have a 1TB backup from the iMac I want to transfer files from which I'll migrate in later, hopefully)

I've set all the BIOS options to what I could find, but there is no "Set to Optimized" option on this board, and the only Super UI Config Option is for "PS2 Y-Cable," which only has Auto and Enabled in their sections, so nothing I could change on that front.

In case it's not clear, the line it's stalling on reads:
"apfs_module_start:1340: load: com.apple.filesystems.apfs, v945.241.4, 945.231.4, 2019/01/01"

Any help would be greatly appreciated.
  • To diagnose boot problems, in addition to the Hardware SPECS of the system where MacOS is being installed, we also need to know:
    • the validity of the MacOS Installer file in the macOSUSB Installer,
    • the entire CLOVER FileTree including the config.plist SECTIONS,
    • the BIOS options chosen for that Boot Disk.
  • If boot problem occurs despite following "ALL the steps to the T", then the fault can be in any or combination of the following areas.
    • maCOS Installer,
    • CLOVER or
    • the BIOS Options
  • If users indicate in their posts, that they have followed Unibeast Method , we will assume that they have downloaded and used a full maCOS file from App Store to create the USB Installer in an acceptable method.
  • But, if a problem occurs during boot, despite using all the suggested steps , the troubleshooters need to revisit the important components of flawless boot:
    • CLOVER
    • BIOS
To upload your BIOS Screen Captures and EFI or CLOVER from your maCOSMojave USB Installer, please check this post-> #6
 
Last edited:
Joined
Feb 15, 2019
Messages
19
Motherboard
Asrock Z390 Phantom Gaming-ITX/ac
CPU
i5-9600K
Graphics
UHD 630
  • To diagnose boot problems, in addition to the Hardware SPECS of the system where MacOS is being installed, we also need to know:
    • the validity of the MacOS Installer file in the macOSUSB Installer,
    • the entire CLOVER FileTree including the config.plist SECTIONS,
    • the BIOS options chosen for that Boot Disk.
  • If boot problem occurs despite following "ALL the steps to the T", then the fault can be in any or combination of the following areas.
    • maCOS Installer,
    • CLOVER or
    • the BIOS Options
  • If a users indicate in their posts, that they have followed Unibeast Method , we will assume that they have downloaded and used a full maCOS file from App Store to create the USB Installer in an acceptable method.
  • But, if a problem occurs during boot, despite using all the suggested steps , the troubleshooters need to revisit the important components of flawless boot:
    • CLOVER
    • BIOS
To upload your BIOS Screen Captures and EFI or CLOVER from your maCOSMojave USB Installer, please check this post-> #6
My MacOS installer is not in FAT32, but GUID. Will that process still work?
 
Joined
Jul 25, 2012
Messages
6,399
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
My MacOS installer is not in FAT32, but GUID. Will that process still work?
Your macOS Mojave USB Installer (8-16GB) has 2 partitions created in GUID
200+MB EFI in FAT32
and remaining of 16GB in MacOS Extended (Journaled) AKA HFS+J Format.

It will work OK.
Edited to add:
I will check the uploaded files (BIOS+EFI) in detail and post later.
 
Joined
Feb 15, 2019
Messages
19
Motherboard
Asrock Z390 Phantom Gaming-ITX/ac
CPU
i5-9600K
Graphics
UHD 630
Your macOS Mojave USB Installer (8-16GB) has 2 partitions created in GUID
200+MB EFI in FAT32
and remaining of 16GB in MacOS Extended (Journaled) AKA HFS+J Format.

It will work OK.
Edited to add:
I will check the uploaded files (BIOS+EFI) in detail and post later.
Appreciate the support and look forward to what you can find. :D
 
Joined
Jul 25, 2012
Messages
6,399
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Appreciate the support and look forward to what you can find. :D
  • I have reviewed your BIOS screen shots.
  • Some of them I am unfamiliar ( Never owned AsRock MoBo)
  • The Graphics related, SATA Controllers, and USB controllers seem to be OK.
  • I am uploading your CloverFileTree viewed in CCG as an edited Screen Capture.

  • Its CLOVER /drivers64 Folder and /CLOVER/ drivers64UEFI folder look OK now.
    • Depending upon future boot events, it is possible , you might need to add EmuVariableUefi-64.efi to /CLOVER/ drivers64UEFI; no need to add that now as it can cause issues if not needed.
  • CLOVER/kexts have empty Numbered subfolders folders that serve no useful purpose and can be safely deleted.
    • I have enclosed them in Red with an outward Red arrow to "Send them to Trash"
  • CLOVER/kexts/Other have some missing kexts .
    • They are essential.
    • I have listed them in Green
  • You need to add the ESSENTIAL kexts to "Other" by copy & Paste method.
  • Search the Tonymac Downloads and else where like Rehabman Bucket for these needed kexts.
  • The Kext Installer on the LEFT panel of CCG might be able to download them for you.
    • I have not tried that method.
  • I have edited config.plist and uploading that for you to use .
  • Rename the current config.plist as config.plist-ORIG before pasting this one inside EFI/CLOVER of your USB Installer disk
  • Upload problem Verbose boot screen(s) or other screens of concern/questions/
 

Attachments

Joined
Feb 15, 2019
Messages
19
Motherboard
Asrock Z390 Phantom Gaming-ITX/ac
CPU
i5-9600K
Graphics
UHD 630
  • I have reviewed your BIOS screen shots.
  • Some of them I am unfamiliar ( Never owned AsRock MoBo)
  • The Graphics related, SATA Controllers, and USB controllers seem to be OK.
  • I am uploading your CloverFileTree viewed in CCG as an edited Screen Capture.

  • Its CLOVER /drivers64 Folder and /CLOVER/ drivers64UEFI folder look OK now.
    • Depending upon future boot events, it is possible , you might need to add EmuVariableUefi-64.efi to /CLOVER/ drivers64UEFI; no need to add that now as it can cause issues if not needed.
  • CLOVER/kexts have empty Numbered subfolders folders that serve no useful purpose and can be safely deleted.
    • I have enclosed them in Red with an outward Red arrow to "Send them to Trash"
  • CLOVER/kexts/Other have some missing kexts .
    • They are essential.
    • I have listed them in Green
  • You need to add the ESSENTIAL kexts to "Other" by copy & Paste method.
  • Search the Tonymac Downloads and else where like Rehabman Bucket for these needed kexts.
  • The Kext Installer on the LEFT panel of CCG might be able to download them for you.
    • I have not tried that method.
  • I have edited config.plist and uploading that for you to use .
  • Rename the current config.plist as config.plist-ORIG before pasting this one inside EFI/CLOVER of your USB Installer disk
  • Upload problem Verbose boot screen(s) or other screens of concern/questions/
I was able to add the majority of those kexts using CCG, but I cannot find XHCI-unsupported.kext anywhere. Tons of links end up saying I need it without actually providing a download link or anything of that sort. One page I found seems to imply that it's included with USBInjectAll.kext? Is there something I missing?
 
Joined
Jul 25, 2012
Messages
6,399
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I was able to add the majority of those kexts using CCG, but I cannot find XHCI-unsupported.kext anywhere. Tons of links end up saying I need it without actually providing a download link or anything of that sort. One page I found seems to imply that it's included with USBInjectAll.kext? Is there something I missing?
  • Uploaded XHCIunsupported as a zipped file. unzip , extract and copy&paste to /CLOVER/kexts/Other.
  • Please upload edited CLOVER BEFORE use for a second look if you like.
 

Attachments

Top