Contribute
Register

Unibeast Lion 10.7.5 USB "Still Waiting For Root Device" Error

Joined
Mar 7, 2011
Messages
33
Motherboard
ASRock X79 Extreme 6, 16GBs GSKILL DDR3 2400, OCZ Vertex 4 128GB SSD, 2TB Hitachi Deskstar
CPU
i7 3930k
Graphics
EVGA GTX 780 Classified
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
I have been trying to install Lion for a week now and after getting all te other errors sorted out I'm now down to my last few before I can get to the installer.

I have tried all sorts of combinations of boot flags and read several installation guides about installing. This isn't my first hackintosh but it has been the most infuriating. I have the USB plugged into the USB 2.0 ports on the left and it always stops at "Still waiting for root device".

My specs:
i5 3570k @ stock
ASRock Z77E-ITX
4GB Samsung DDR3 1600
EVGA GTX 680 2GB
OCZ Vertex 4 128GB
2TB Hitachi
 

Attachments

  • image.jpg
    image.jpg
    1.1 MB · Views: 1,152
Joined
Nov 10, 2011
Messages
4
Motherboard
Mac OS 10.7
CPU
i5-2500k
Graphics
Sapphire 6850
Mac
Classic Mac
Mobile Phone
Check your BIOS settings, and make sure the SATA control mode is set to AHCI, not IDE. I had the same issue a few days ago, and that fixed it
 
Joined
Mar 7, 2011
Messages
33
Motherboard
ASRock X79 Extreme 6, 16GBs GSKILL DDR3 2400, OCZ Vertex 4 128GB SSD, 2TB Hitachi Deskstar
CPU
i7 3930k
Graphics
EVGA GTX 780 Classified
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
Yep. I got all the BIOS settings right.
 
Joined
Mar 6, 2015
Messages
1
Motherboard
PC
CPU
INTEL CENTRINO
Mac
Classic Mac
Mobile Phone
I had this problem too until I tried the option USBBusFix=Yes and it worked out for me.
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,233
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
I have been trying to install Lion for a week now and after getting all te other errors sorted out I'm now down to my last few before I can get to the installer.

I have tried all sorts of combinations of boot flags and read several installation guides about installing. This isn't my first hackintosh but it has been the most infuriating. I have the USB plugged into the USB 2.0 ports on the left and it always stops at "Still waiting for root device".

My specs:
i5 3570k @ stock
ASRock Z77E-ITX
4GB Samsung DDR3 1600
EVGA GTX 680 2GB
OCZ Vertex 4 128GB
2TB Hitachi

Try with -v npci=0x2000 or -v npci=0x3000

You will need to patch the BIOS to unlock CPU MSR, install NullCPUPM kext OR use Clover as your boot loader, which patches AppleIntelCPUPowerManagement.kext on the fly to prevent a KP caused by AICPUPM kext.

Also not sure if Lion has Ivy Bridge support - maybe 10.7.5 has support, it was about the time IB hardware was released that Apple released 10.7.5, so maybe you will be OK.
 
Top