Contribute
Register

UniBeast: Install OS X Mavericks on Any Supported Intel-based PC

Status
Not open for further replies.
Joined
Nov 2, 2011
Messages
9
Motherboard
Z86 > Need make & full model > See Rules!
CPU
i5-2500K
Graphics
6850 HD
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Article: UniBeast: Install OS X Mavericks on Any Supported Intel-based PC

My monitor turns off after the apple screen when attempting to boot the unibeast partition in order to begin the install. I have tried with npci=0x300, PCIRootUID=1(gives me a kernel panic), and GraphicsEnabler=no/yes yet nothing has worked. The monitor itself is the one that turns off; the computer, and I assume the installation screen, continues running in the background.

Try use different monitor connection, VGA, HDMI or DVI. This happened to me, the system didn't recognize the DVI but it the HDMI is working fine. So after multibeast installation, I reboot and everything back to normal.
 
Joined
Jun 24, 2013
Messages
5
Motherboard
Gigabyte Z77X-UD5H F14
CPU
i7 3770K
Graphics
Gigabyte GeForce GTX 770 2GB
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Article: UniBeast: Install OS X Mavericks on Any Supported Intel-based PC

install went well but SSD trim is not enabled and usb 3.0 seems not working on ga-z77x-ud5h

+1 for USB 3.0 not working on the GA-Z77x-UD5H. Not sure about trim support, really don't even know what that does or if it's working.
 
Joined
Jun 5, 2013
Messages
23
Motherboard
GA Z77X-UP5 TH
CPU
I7-3770K
Graphics
GTX 650 TI
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. Android
  2. iOS
My config is below:

I am not able to install the new OS. It is book screen and resets back again. Not sure what the issue is. Please help.


System Z77X-UP5 THCPU I7 3770KGraphics GTX650TI RTOther Hardware Corsair Vengeance 32GB (4x8GB) DDR3 1600 MHz
BD COMBO LG|UH12NS29 %
SSD 240G|SANDISK SDSSDX-240G-G25 R
PSU CORSAIR| HX750 750W RT
WL ADPT TP-LINK| TL-WDN4800 R
2 TB Seagate
 
Last edited by a moderator:
Joined
Apr 13, 2013
Messages
15
Motherboard
Gigabyte GA-Z87N-WIFI
CPU
i5-4570
Graphics
HD 4600
Well done; another great guide.
Upgraded from 10.8.5 to 10.9 using this guide > no errors/issues. Had to reinstall Audio and Intel Ethernet Kext (via MultiBeast), other than that - it works!
 
Joined
Nov 2, 2011
Messages
9
Motherboard
Z86 > Need make & full model > See Rules!
CPU
i5-2500K
Graphics
6850 HD
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Article: UniBeast: Install OS X Mavericks on Any Supported Intel-based PC

install went well but SSD trim is not enabled and usb 3.0 seems not working on ga-z77x-ud5h

My SSD TRIM feature seems working fine. Make sure to check on the multibeast to have TRIM enable.
 

Attachments

  • Screen Shot 2013-10-22 at 10.42.46 PM.png
    Screen Shot 2013-10-22 at 10.42.46 PM.png
    9.3 KB · Views: 131
Joined
Apr 24, 2012
Messages
86
Motherboard
GA-Z87X-UD7 TH
CPU
i7-4770K
Graphics
EVGA GeForce GTX 760
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
Mobile Phone
  1. Android
You guys are simply GREAT!
 
Joined
Dec 15, 2012
Messages
11
Motherboard
OSX 10.8 GA-Z77X-UP5-TH
CPU
Intel i7-3770k
Graphics
EVGA GTX570HD 2056MB
Mac
Classic Mac
Mobile Phone
Article: UniBeast: Install OS X Mavericks on Any Supported Intel-based PC

The post stating that your Mountain Lion upgrade ran flawlessly. I have 10.8.5 running just fine and have tried running the Mavericks update package from the Apple Store and it downloads and then seems to run and start to install and then asks to reboot and then nothing - I Mean I am left with 10.8.5.
What am I missing please - how do I do a non destructive upgrade to Mavericks is what I am asking !
 
Joined
Sep 19, 2011
Messages
27
Motherboard
GA-Z270-HD3
CPU
i5-7500
Graphics
GT 740
Mac
  1. iMac
Mobile Phone
  1. iOS
I just bought a GA-Z87-HD3 and a i5-4750 (using internal GPU and 8GB Ram) last week after looking at the recommended CustoMac hardware. It is running 10.8.5.1 OK (albeit without QE/CI) after a lot of effort. But I cant even get the installer to launch on this one using the recommended settings and trying all combinations of the boot flags.

I updated the Bios to F6 tried installing to a fresh disk but no luck yet I had hoped that this would have been an easier build. :(

Oh well I'll keep trying
 
Joined
Sep 19, 2011
Messages
27
Motherboard
GA-Z270-HD3
CPU
i5-7500
Graphics
GT 740
Mac
  1. iMac
Mobile Phone
  1. iOS
Article: UniBeast: Install OS X Mavericks on Any Supported Intel-based PC

Just upgraded using this method with success. The Multibeast 6.0.0 went a bit slow on me after selecting the components and waiting for the install, but after a couple of mins it finally made progress, still took a while. Rebooted and now ready to surf the Mavericks.

Feels snappier.

My specs are
Z87X-D3H
i7 4770 Haswell
760 GTX (Shows up with 2048MB and full name in 10.9)

Selected DSDT-Free, ALC892 (DSDT free) and Intel network drivers.

My resize window lag in Safari is also gone, but that was also fixed in 10.8.5 with Safari 6.1 update.

iMessage still an issue. Error at login.

Can you please post your Bios settings and the boot boot flags you used. I am having a lot of difficulty with a similar motherboard. Thanks
 
Status
Not open for further replies.
Top