Contribute
Register

UniBeast: Install macOS Sierra on Any Supported Intel-based PC

Joined
Jan 13, 2013
Messages
9
Motherboard
ASUS B85M-G
CPU
i5 4440
Graphics
HD 4600
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Tried installing it couple times. As much as all my hardware seemed to work correctly, it was just buggy especially when using MS office accessing files from a NAS. Would completely lock up and had to reboot. Went back to El Capitain, things are great again.
 
Joined
Jun 15, 2015
Messages
2
Mac
Classic Mac
Mobile Phone
Working like a charme on my Customac Mini Deluxe with i7 4790K and GTX980. No kernel flags required (not even nv_disable!). It worked out of the box. The first boot required booting via the Unibeast stick, Uefi Clover via Multibeast did the trick then :)
I installed it over my El Capitan installation, everything was on its place ;)
 
Joined
Jul 11, 2014
Messages
3
CPU
i7-4700mq
Graphics
Intel HD4600, Nvidia GT740M
Whenever i try to boot into the install macOS partition it gives me a can't perform kext scan: no kext summary. I have just created the USB and I have tried heaps of boot flags combinations.
 
Joined
Oct 6, 2016
Messages
3
Motherboard
MSI
CPU
I5 8265U
Graphics
NO
Mac
  1. iMac
Mobile Phone
  1. Android
anyone knows which audio driver should i pick with asus p8z68-v? I installed the "ALC892" but it doesn't work...
also i can boot only from usb...

Have you tried VoodooHda 2.8.8?
It was the one that worked on my MSI H110-M, but only installing without Multibeast. I had to download it myself!

For the booting issue, if you followed the steps and it's not working, check some things:

- Make sure you have a EFI partition on your HDD. If you forgot to select GUID when formating your HDD, probably your EFI partition wiil be missing.
- To check that type diskutil list on the terminal and see if there is a EFI partition on your HDD.
 
Joined
Oct 9, 2016
Messages
1
It says "Make sure neither 'OS X Install ESD' or 'OS X Base System' are mounted on your drive" when I try to complete step 15, when I look at my drive I see neither of those things and have tried clearing my drive multiple times without any luck.
 
Joined
Sep 6, 2012
Messages
3
Motherboard
Intel Core i5
CPU
3,19 ghz
Graphics
mother board
Mac
Classic Mac
Mobile Phone
all works perfect following the guide with gigabyte ga-h81m-s2h and nvidia gt520 .Intel core i5 haswell.thanks.
 
Joined
Sep 18, 2016
Messages
77
Have you tried VoodooHda 2.8.8?
It was the one that worked on my MSI H110-M, but only installing without Multibeast. I had to download it myself!
No, i haven't. I'll try it.
For the booting issue, if you followed the steps and it's not working, check some things:

- Make sure you have a EFI partition on your HDD. If you forgot to select GUID when formating your HDD, probably your EFI partition wiil be missing.
- To check that type diskutil list on the terminal and see if there is a EFI partition on your HDD.
Which steps?
Yes I've formatted in GUID and I have the EFI partition.
 
Joined
Sep 29, 2013
Messages
174
Motherboard
Gigabyte Z390 Aorus Ultra
CPU
i9-9900K
Graphics
UHD 630, RTX 2080 Super
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have succesfully installed Sierra on my machine (H87N-wifi-I3 Haswell-HD4600). I did it using terminal commands, Clover and Multibeast.
Artheros enthernet is not recognized (the intel one is) and my Atheros bluetooth dongle has to be disconnected and reconnected in order to work (after each restart). Without Multibeast, I had USB problem (some not working) and reboot/shutdown problems.

They are some really good stuffs inside this version of Mac OS. Like Metal (a graphic engine which make everything looks more crispy), or the updated helping tool of Xcode (much more efficient), and finally (after years of waiting), the possibility to put all the folders of a finder window on the top of the list (it was a feature of OS9 if I'm right).
Allas, Xcode is sometimes crashing (playgrounds and projets) and Safari is crashing the all machine (freeze) if it tries to open a flash movie. I don't think it is only me, or is it?

All my wishes of success for the future. May the force be with you forever.

Yeah, I for one have gone back to El Capitan, too many issues. Maybe Sierra will mature with time, I'll try again then.. for now it feels like a version I'll be happy to skip over :)

Good luck to those keeping at it.
 
Joined
Sep 8, 2016
Messages
14
Motherboard
SAMSUNG NP550P5C-T01AE
CPU
i7-3630QM
Graphics
HD 4000 / GT 630M
please help!
anyone encountered this after booting to sierra installer on clover boot menu? is this normal and the install process is still taking place? should i wait for for some time?

sorry photo is upside down dont know why everytime i upload this happens..
image.jpg
 
Joined
Aug 29, 2013
Messages
56
Motherboard
H97N-Wifi
CPU
i5-4690K
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
Thanks for the guide. My system is up and running. Zero issues once I got passed some boot issues I ran into in clover.
 
Top