Contribute
Register

UniBeast: Install macOS Sierra on Any Supported Intel-based PC

Joined
May 15, 2016
Messages
4,852
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
First time installing OSX, Installed Sierra and multi beast and boots okay(without usb) but every time I reboot and mount my EFI I have lost all my kexts, I am also unable to get graphics working properly((flickering in top left)using IGP on i3 6100 intel 530 graphics) and have no sound(have also tried running the script command but keep error will attach photo)
Intel 530 graphics have that problem, no way around yet. Did you check bios for sound activation? Try loading 0x19120001 for fake ID in graphics settings in clover. It should get you SKL CRB graphics which is apples native version of Intel 530.
Check your 64efi drivers folder in clover. Osiaptiofix2 has been causing some problems, switch it for Osioaptiofix if possible.
 
Joined
Sep 29, 2016
Messages
1
CPU
Skylake i5 - 6402P
Graphics
EVGA GTX 950 SSC
@tonymacx86 Thanks for the update post on installation of macOS Sierra.:) I have installed the OS successfully, internet just works fine but I'm facing issues with the audio, there is no sound at all my motherboard is msi b150m pro-vdh so I have installed the alc887 driver from the latest version of multibeast but it doesn't seems to be working, also my graphics card (evga GTX 950 SSC) doesn't seems to be working at all i tried installing the nvidia web driver followed by editing the config.plist using textedit and also some boot args like nvda_drv=1 but nothing seems to work the screen always show the loading Apple logo then when it's almost in the middle part the screen glitches out and restarts. :cry:

Do you know if there is any alternate ways to get those two things to work.:|
 
Joined
Sep 29, 2016
Messages
2
Motherboard
HP ProBook 450 G1
Hello Guys - this was my first attempt at Hackentosh. Booting from the USB is functioning. Unfortunately, the installation process can not be started, because the the screen is not displayed correctly (see pictures). I have a HP ProBook 450 G1 with Intel graphics chip. The BIOS settings are made according to instructions. How do I get the display corrected? I hope you can help me here.

Best regards
MarkusView attachment 213096 View attachment 213097
I have fixed it with enable UEFI Hybrid (with CSM)
 
Joined
Sep 29, 2016
Messages
10
Motherboard
Z170MX
CPU
i7 6700K
Graphics
GTX 1080
Mac
MacBook Pro
Mobile Phone
iOS
Can't disable SIP on Sierra, I need this to fix problem with GTX 960. I'm making csr 0x67 in config.plst but anyway it is not disabling, checking status of SIP via terminal shows me that
 

Attachments

Joined
Oct 29, 2013
Messages
2
Motherboard
mav
CPU
nvidia
Graphics
core i5
Mac
Classic Mac
Mobile Phone
how do install osx10.12 on pc (MBR)
 
Joined
Sep 30, 2016
Messages
1
Hello, I was wondering if someone could help me out. This process turned out to be a million times more complicated than expected.

Parts:

MSI Gaming 7 Carbon motherboard
i7 6700k
32gb Ram
Gtx 1070 SuperClocked GPU

So fat I have been able to install Sierra but have no audio, graphics cant be turned up or down ( using a 4k monitor ) and no internet at all.

I run unibeast 9 and have watched about 64 videos on how to install divers but none are working.

I am completely lost and frustrated and not sure where to go next.

Please help me out and thanks.
 
Joined
Aug 15, 2012
Messages
13
Motherboard
10.12.5
CPU
i5 2450M
Graphics
Intel HD3000
Mac
MacBook Pro
Mobile Phone
iOS
UniBeast-7.0.1 does'nt work on non English system :(
 
Top