Contribute
Register

UniBeast: Install macOS High Sierra on Any Supported Intel-based PC

Joined
Nov 4, 2010
Messages
23
Motherboard
GA-Z97M-D3H
CPU
i5 4460
Graphics
HD 4600
Mac
  1. MacBook Pro
Classic Mac
  1. SE
Mobile Phone
  1. Android
  2. iOS
clean intall with 10.13.2 reboot problem on GA-H97M-HD3

i recreated usb stick with mac os 10.3.2 and formatted disq

after installation when i choose the main system it reboots. i've read somewhere that there was problem with lulu ktext something after update, but how do you fix it on clean instal ? you can't ? ;)

i did a clean instal with 10.13.1 i didn't have this problem.all went fine.
 
Joined
Nov 9, 2017
Messages
1
I am able to get my High Sierra system stable by using NVDAStartup.kext from EL Capitan. I have a NVIDIA GTX 285. I use the "disabledfgfirmware" boot flag. I was never able to get stock unibeast to work without putting in the NVDA kext. Is there a better way? Could I run the web drivers? I want to make sure I get the full power of my GPU. I have a ASUS z270i and i7 7700K.
 
Joined
Jun 13, 2015
Messages
16
Motherboard
Gigabyte X99 UD4
CPU
Intel 5820K
Graphics
Gigabyte GTX970
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
Hello, everyone.

[SOLVED: Got it downloading the official installer on another mac. Don't use alternative methods if you're getting the 19mb version. Find another mac and get the 5.19gb version from the App Store]

I'm following this guide thoroughly to create a thumb drive with 10.13.2 to make a clean install on a new HFS+J formatted SSD.

I've formatted a usb HFS+J with GUID, ran the latest version of "Unibeast" (UEFI, High Sierra, No Graphics), copied the "MultiBeast High Sierra Edition" in the new "Install MacOS Hight Sierra" partition. When I boot from the UEFi partition on the USB, I reach the clover boot page, but I can't any "install MacOS High Sierra" partition to boot. Notice that when I keep my old Yosemite SSD or my Windows SSD plugged in it thise lists properly. But no "High Sierra Install" partition whatsoever. [see attached pic]

I've tried pretty much every solution I could think of: multiple thumb drives, updating clover, installing and/or updating apfs.efi/hfsplus.efi and other drivers, unplugging every internal drive on my pc...

The only thing I can't do is to use the official installer download fully from the app store. I've already tried to download from 3 real macs. Wonder if Apple changed the installer for some reason... I used this method to download the full app: (http://osxdaily.com/2017/09/27/download-complete-macos-high-sierra-installer/)

Thanks in advance!
 

Attachments

  • image.jpg
    image.jpg
    1.1 MB · Views: 124
Last edited:

MacMan

Administrator
Staff member
Joined
Feb 2, 2010
Messages
8,462
Motherboard
ASUS TUF Z390-PRO GAMING - 2606 - UEFI
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
The only time I ever downloaded the stub installer was the day High Sierra was released and it was within the first couple of hours of it release. I deleted the installer and when I downloaded it again it was the full installer. Since then it has always been the full installer on multiple Macs and Hacks.
 
Joined
Jun 13, 2015
Messages
16
Motherboard
Gigabyte X99 UD4
CPU
Intel 5820K
Graphics
Gigabyte GTX970
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
The only time I ever downloaded the stub installer was the day High Sierra was released and it was within the first couple of hours of it release. I deleted the installer and when I downloaded it again it was the full installer. Since then it has always been the full installer on multiple Macs and Hacks.

True MacMan, i made it with the official installer downloaded from another real mac. Don't use the alternative method posted before! Thanks everyone!
 
Last edited:
Joined
Dec 14, 2017
Messages
1
Motherboard
MSI Z270 Gaming M3
CPU
Intel i7 7700k
Graphics
MSI GTX 1070
My PC specs are-
Motherboard- MSI Z270 Gaming M3
Graphics Card- MSI GTX 1070 Gaming X 8G
Processor- Intel i7 7700k
RAM- 2x8GB Corsair Vengeance LPX
Cooler Master Hyper 212
Corsair VS650
WD 2TB HDD

Will I able to run macOS High Sierra smoothly or at all.

Any guide I should follow to make my PC run Fully supportly.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,717
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I am still having trouble getting to the instal screen after clover any help?
not a help thread, please post in the desktop support section
 
Joined
Mar 15, 2013
Messages
24
Motherboard
GA-Z370M-D3H
CPU
i5-8400
Graphics
UHD 630
Mac
  1. iMac
Install

“macOS High Sierra”



MoBo: GIGABYTE: Z370M-D3H

CPU: 8th Gen Coffee Lake i5 8400 (9MB) Cache

GPU: Intel UHD 630 1536MB

Memory Ram: 8GB Corsair 2133mhz

I Install with support TonyMac and RehabMan with Maciasl and

Patchmatic Extract DSDT and SSDTs with Big Help on RehabMan

Tutorials Pages, Big Thanks to TonyMac and RehabMan.




My Ready EFI.Zip and Installed OS Pics Attached
 

Attachments

  • Screen Shot 2017-12-20 at 10.19.20 PM.png
    Screen Shot 2017-12-20 at 10.19.20 PM.png
    4.2 MB · Views: 301
  • Screen Shot 2017-12-20 at 10.19.37 PM.png
    Screen Shot 2017-12-20 at 10.19.37 PM.png
    3.5 MB · Views: 328
  • Screen Shot 2017-12-20 at 10.20.06 PM.png
    Screen Shot 2017-12-20 at 10.20.06 PM.png
    3.3 MB · Views: 284
  • Screen Shot 2017-12-20 at 10.20.35 PM.png
    Screen Shot 2017-12-20 at 10.20.35 PM.png
    4 MB · Views: 243
  • EFI.zip
    4.1 MB · Views: 88
Last edited:
Top