Contribute
Register

Unibeast 8.2.0 Issues

Joined
Mar 3, 2014
Messages
605
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Air
Classic Mac
Power Mac
I tried creating a Unibeast 8.2.0-generated High Sierra installer USB just for grins. I found the following issues with it:

1. Although the "Copying Files" process completed, the next "Installing bootloader" process stalled, i.e. the clock kept ticking, but the progress bar never changed. I quit Unibeast and saw in the "Clover Install Log" on the USB the following information:

ERROR: can't mount ESP partition (disk2s1) !
Check that the partition is well formated in HFS or Fat32.
To format as HFS use command like:
sudo newfs_hfs -v EFI /dev/rdisk2s1
For format as Fat32 use command like:
sudo newfs_msdos -v EFI -F 32 /dev/rdisk2s1

In my ignorance, I chose the "hfs" format in Terminal, which resulted in the same message upon repeating the Unibeast app. So then I tried the "msdos" version in Terminal, and lo and behold, the Unibeast app completed, and there was an "EFI" icon on the desktop, which was just like all the previous Unibeast versions I have used. So now I thought I had a useable High Sierra installer, but there was another issue.

2. The Tonymac "standalone" Clover installer version 4411, published on this forum, had replaced the "OsxAptioFix2Drv-64.efi" with "OsxAptioFix3Drv-64," but in this Unibeast app, the older one is still present. And the "EmuVariableUEFI" driver is not there either, which means that no emulated NVRAM is available from this installer. So I replaced it with my OsxAptioFix3Drv-64 driver from my 10.12.6 installation.

There are quite a few Apple-supplied drivers in this EFI partition's Clover folder. I had deleted some of them in my 10.12.6 installation... not sure if they are needed by High Sierra. That's a question, not an issue with the installer.

I have yet to try upgrading from Sierra to High Sierra, but I will hold on to this USB for future use.
 
Last edited:
Joined
Jul 13, 2015
Messages
28
Motherboard
Gigabyte Z370 Gaming 7
CPU
i7 8700K
Graphics
Gigabyte RX570 4G
Mac
iMac
I tried using Unibeast 8.2.0 with the latest OS X High Sierra 10.13.4 installation file and the net result was that Clover did not work from the USB's EFI partition (I was returned back to the boot order menu in the BIOS). However, I was able to start the OS X installer from the existing Clover installation on my computer. However, after finishing the installation, the new volume would not finish booting up and I just got a black screen. I used the same 10.13.4 install file with Unibeast 8.1.0 and I was able to start Clover from the USB, and for the first time I was actually able to boot up my existing OS X installation from the Unibeast OS X USB (had previously relied on a non-approved USB install drive as an emergency back up).
 
Top