Contribute
Register

Underperforming GeForce GTX1060 in 10.12.4

Status
Not open for further replies.
Joined
Oct 12, 2011
Messages
119
Motherboard
Asus Maximus V Gene
CPU
i7-3770K
Graphics
GTX 1060
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Hi guys

Not really been using my Hacky, as I've been playing a lot of games (mostly my children, not me). However, after hearing that Nvidia released drivers for Pascal support, I went out and bought an Asus Strix 1060 OC 6GB GPU.

Obviously, in Windows, it is flawless. A decent upgrade from my Gigabyte GTX780 OC Windforce.

In order to get it running on macOS, I had to do the following:

1. Update Clover
2. Update from 10.12.1 to 10.12.4 (used combo update)
3. Download and install Nvidia web driver
4. Amend config.plist to use new nvidiaweb activation

Strangely, whilst doing all this, it actually went smooth, with no issues.

The problem I have is that my benches (Cinebench, Luxmark, Unigine Heaven, etc) are all bad results. Especially compared to the GTX780 install.

I am currently on iMac13,2 due to my other hardware (3770K, Z77 Asus Maximus V Gene). In Windows, this build is super quick, and it's quick in macOS.

However, I have just tried playing around with different models (MacPro6,1, MacPro5,1) and not much different happens. My GPU is underperforming a great deal.

I know that I am probably stuck here, as my hardware is going back a few years, but I should be able to get more out of the GPU.

Any ideas? I can drop whatever info you need to assist. Thanks in advance for looking.
 
Joined
Jul 30, 2012
Messages
9
Motherboard
asrock fatal1ty Z87 killer
CPU
i5-4670K
Graphics
EVGA GTX 1070 FTW
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
i have a gtx 1070 which performs great in windows paired with an i5-4670k and 16GB but underperforms in macOS. keep in mind that this is the first beta driver release for pascal cards on OSX and it will take a while to optimise. i'm grateful that i'm able to run the OS without any graphical errors and even watch 1080p / 4k video's on it.
 
Joined
Oct 12, 2011
Messages
119
Motherboard
Asus Maximus V Gene
CPU
i7-3770K
Graphics
GTX 1060
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Thanks for replying bro. I get that, I've been using OSX from 10.8 (in hackintosh) with different hardware.

I've seen people with the same cards, and getting really good benchmarks.

I'm just running OpenGL, and it renders fine. There are no glitches, tears, just bad bench numbers?
 
Joined
Jul 30, 2012
Messages
9
Motherboard
asrock fatal1ty Z87 killer
CPU
i5-4670K
Graphics
EVGA GTX 1070 FTW
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
i've been using this system in the past with OSX el capitan and macOS sierra but with a gtx 770 instead of the 1070 and it was performing great. when the 10 series landed i got a 1070 and removed my hackintosh installation and reverted back to my 2012 macbook pro as primary apple system. i just installed this system fresh again 2 days ago. here's a link to my novabench:

https://novabench.com/view/1231250

as you can see the 1070 is performing terrible atm but good enough for normal use and video's. i tried to run some games and while they ran they didn't run well. still playable tho. i'm thinking we'll just have to wait for better drivers :)
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,322
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
keep in mind that this is the first beta driver release for pascal cards on OSX and it will take a while to optimise.

It is not a Beta driver.
The f in 378.05.05.05f01 signifies Final release, if it was a Beta it would be 378.05.05.05b01.
Post your config.plist.
 
Joined
Jul 30, 2012
Messages
9
Motherboard
asrock fatal1ty Z87 killer
CPU
i5-4670K
Graphics
EVGA GTX 1070 FTW
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
It is not a Beta driver.
The f in 378.05.05.05f01 signifies Final release, if it was a Beta it would be 378.05.05.05b01.
Post your config.plist.

ah i did not know. all other sources on the internet where talking beta so i assumed they really where beta...

anyway here's my plist:
 

Attachments

  • config.plist
    4.7 KB · Views: 192
Joined
Jul 30, 2012
Messages
9
Motherboard
asrock fatal1ty Z87 killer
CPU
i5-4670K
Graphics
EVGA GTX 1070 FTW
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Your config.plist is injecting Intel - Don't do that.

fixed it but didn't change anything. also installed that latest cuda driver. but i don't really care for gaming performance. i have windows for that. for the rest it's running like a dream
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,322
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
fixed it but didn't change anything. also installed that latest cuda driver. but i don't really care for gaming performance. i have windows for that. for the rest it's running like a dream
Check that integrated graphics are disabled in your BIOS settings - PEG as primary.
 
Status
Not open for further replies.
Top