Unable to load installer - Asus Z370i, I7-9700, RX570, 1TB NVME

Not open for further replies.
Feb 26, 2011
Asus Z170i
Hi all,

I’ve built a few hacks over the years and this is the first I’ve run into where I’m having a heck of a time getting the installer to load.

Specs are as follows:
  • Asus Z370i (Bios 1406)
  • i7-9700
  • Sapphire RX570 4gb
  • 1TB Inland Premium NVMe
  • 16gb GSkill Trident RGB 3000mhz RAM
I pulled the RX570, 1TB and 16GB RAM from my working Z170i Mojave rig to use in this new build.

Initially I tried to go vanilla - built the USB installer via terminal, installed Clover and used pretty much the default vanilla config.plist; with changes made for the graphics and SMBIOS serial (18,3). i found BIOS settings for other Asus Z370 boards and used it for mine (optimized defaults, disabled virtualization, disabled fast boot, disabled keyboard and mouse virtualization)

I was able to reach Clover fine, but when booting in verbose it would hang after VM Swap Subsystem is ON. I recorded the boot and found quite a large number (I would guess 10-15 or more) of ACPI Exception: AE Not Found and ACPI Errors above. Tried to adjust various BIOS settings, tried different boot flags (including acpi=off), tried taking the RX570 out and using iGPU, tried using the default config from Clover, tried all the different USB ports on the mobo, no luck. Always hangs in the same place.

I then put my old Z170 system back together and built a new installer using UniBeast on a separate USB stick, (as I always did in the past), but I’m still running into the same problem as above and it hangs at the same place, with the same ACPI errors.

Any ideas on what to do to proceed? I recognize there are newer BIOS revisions (mine is from Sept 2018), but I know more recent BIOS revisions can sometimes cause their own issues.

Thanks in advance!!
Last edited:
Screencap from Video during verbose boot showing the ACPI exception and ACPI errors.
Not open for further replies.