Contribute
Register

unable to do direct update

Status
Not open for further replies.
Joined
Jan 16, 2011
Messages
35
Motherboard
ASUS P5QC
CPU
E8500
Graphics
RX 560
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi,

I am unable to directly update my system. I receive a message that tells me my system does not meet the requirements for mojave.

It has the specs of an iMac 27 late 2009 and I tried to change that through multicast, however it didn't work. I know my graphic card is very old but I would like to ask if there is a way around it. Thank you in advance.
 
Joined
Oct 23, 2011
Messages
235
Motherboard
Asus ROG Strix Z390-I
CPU
i9-9900K OC 5GHz
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
With an iMac 2009 as SMBIOS, of course you can't upgrade since the oldest iMac supported is from 2012.
Even if you change it I don't think that your GPU will support Metal 2.
 
Joined
Jan 16, 2011
Messages
35
Motherboard
ASUS P5QC
CPU
E8500
Graphics
RX 560
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thank you for your quick reply. I guessed that was the problem, but do you think that changing the gpu ad the SMBIOS will solve my issue, or the CPU is also a problem?
 
Joined
Jan 16, 2011
Messages
35
Motherboard
ASUS P5QC
CPU
E8500
Graphics
RX 560
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Intel Core 2 Duo E8500 with only SSE4.1, without SSE4.2
Replace com.apple.telemetry.plugin with one from 10.13.x
/System/Library/UserEventPlugins/com.apple.telemetry.plugin

Thank you Brebo,

I am managing to replace my GPU with an AMD Radeon HD 7xxx in order to get full compatibility. Then I will try to install mojave.
 
Status
Not open for further replies.
Top