Contribute
Register

Solved > Unable to detect other internal sata drives

Joined
Jan 30, 2020
Messages
3
Motherboard
HP Z240
CPU
E3-1240 V5
Graphics
RX 580
Hello

I'm attempting to install Catalina on my HP Z240 workstation. (https://h20195.www2.hp.com/v2/getpdf.aspx/c04760707.pdf)

So far I have been fairly successful, installed on NVMe drive, with Clover 5103. Boots fine, got sound, running an RX580 with dual displays. Happy as.

But, I connected a samsung EVO 850 to one of the sata ports on the motherboard and I don't see this drive in finder or disk utility. The clover bootloader can see it however.

I've tried ApplePCIIDE.kext, SATA-100-series-unsupported.kext, SATA-200-series-unsupported.kext and SATA-unsupported.kext. The last one caused some kernel panic and I was unable to boot at all. Managed to remove it by going into recovery, and removing the kext from /Library/Extensions.

I'm all new to this. Am I missing something to get sata drives showing up?

I have Clover Configurator and Hackintool on standby. Just tell me what to do!

Would appreciate your help.


---------
UPDATE
---------

AppleAHCIPort.kext was the answer, but not without system reboots due to conflicting extensions. I had to remove the other SATA-* kexts before this would work. So don't give up if your system keeps rebooting, look at your extensions and remove the ones that could cause conflict.
 
Last edited:
Joined
Jan 30, 2020
Messages
3
Motherboard
HP Z240
CPU
E3-1240 V5
Graphics
RX 580
Wish I could delete this.. (it was a correction for above)
 
Last edited:
Top