Contribute
Register

UHD 630 on H310M-HDV/M.2 ISSUE

Joined
Jan 26, 2013
Messages
94
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
UHD 630
For me works this Kext to Patch (Intel UHD 630/i5-8400)


AppleIntelKBLGraphicsFramebuffer

02040A000004000087010000

02020A000008000087010000

KBL-5912000-Port_0x7_HDMI


On my motherboard 2x HDMI and 1 x DP .
One of this HDMI works after patched.

System Definition iMac18,1 .
 
Joined
Jun 1, 2016
Messages
7
Motherboard
HP Folio 9470m (Clover)
CPU
i7-3687U
Graphics
HD4000, 1600x900
For me works this Kext to Patch (Intel UHD 630/i5-8400)


AppleIntelKBLGraphicsFramebuffer

02040A000004000087010000

02020A000008000087010000

KBL-5912000-Port_0x7_HDMI


On my motherboard 2x HDMI and 1 x DP .
One of this HDMI works after patched.

System Definition iMac18,1 .
Thank you for your information. One more thing: Could you please share your config.plist?
I want to see your configuration of IntelGFX FakeID and ig-platform-id.
I can only boot with 0x59120002, the others 0x59120000 or 0x59120003 throw KP related to IOPCIFamily
 
Joined
Jan 26, 2013
Messages
94
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
UHD 630
My tested motherboard has H370 intel chipset so maybe slightly different.
I run without Intel GFX Fake ID and without ig-platform.

Try too IntelGFX Fake ID 0x59128086 and gi-platform 0x5912000.

No difference in both cases.

For me only framebuffer patch give me one HDMI port working.
DP port always works.

Two LCD config (HDMI & DP) is possible but DP LCD must be power off before computer start and power on after Mac OS start .

Install kexts : IntelGraphicsFixup.kext , Lilu.Kext .

I dont have extra knowledge about UHD 630 connector ports for more.
 
Top