Contribute
Register

Trying to patch framebuffer for XFX RX 580 8GB in Mojave

Joined
Aug 31, 2018
Messages
1,435
Motherboard
Asus ROG Strix Z390 I-Gaming
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook
Classic Mac
  1. 512K
  2. iMac
Mobile Phone
  1. iOS
And how do you flash a Radeon card on a MAC?

2 options:
  1. Install WINDOWS? It's a free download and you can use it to flash the VBIOS or
  2. Download a ROM from TechPowerUP and use Clover to inject it. Match it as closely as you can and rename it to the GPU ID of your XFX which you can also look up at the same site. Using an XFX RX-580 that would be something like 1002_67DF.rom Put the file in Clovers rom folder and set it up to inject.
Sounds like I offended you, that was not my intention, I was genuinely curious as to why you hadn't tried the above options.
 
Last edited:
Joined
Oct 3, 2012
Messages
182
Motherboard
Gigabyte X99-SLI
CPU
Xeon E5
Graphics
GT 640
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
You did not offend me at all. On the contrary, I am glad you replied to my interrogations. Yes, I do have Windows 10 on one of my hard drives. Are you saying that I could flash my Sapphire HD 7850 with a rom from a different card?

Thanks
 
Joined
Aug 31, 2018
Messages
1,435
Motherboard
Asus ROG Strix Z390 I-Gaming
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook
Classic Mac
  1. 512K
  2. iMac
Mobile Phone
  1. iOS
You did not offend me at all. On the contrary, I am glad you replied to my interrogations. Yes, I do have Windows 10 on one of my hard drives. Are you saying that I could flash my Sapphire HD 7850 with a rom from a different card?

Thanks

Yes but not sure that would help! The title of the thread was for XFX 580, sorry If I misunderstood and wasted your time.
 
Joined
Aug 2, 2012
Messages
12
Motherboard
Supermicro X8DA6
CPU
X5690 x 2
Graphics
RX 580
Mobile Phone
  1. iOS
I am just curious, why haven’t you guys just flashed PowerColor or Sapphire firmware to your XFX cards?

Does it not work?
I have actually tried injecting Sapphire, Power Color and Asus ROM but without success. It is not that XFX is not working (it is working quite good actually with 15100 on LuxMark test for example), and multi display setup problems are not uncommon for above mentioned cards too. This is just issue with non-referent layout and port priority, probably with motherboard added to the mix :)
 
Joined
Jan 16, 2019
Messages
10
Motherboard
Asus IPIBL LB
CPU
Q8200
Graphics
GT 520
Mac
  1. iMac
Hello guys...

Did you manage to make your "RX 580 GTS XXX Edition 8GB" GPU to make it work with Mojave or Catalina? I did it for a few days with 10.15.17 with the same card but I reinstalled the system trying to repeat every step and it doesn't work hahaha. :(
 
Last edited:
Joined
Jan 16, 2019
Messages
10
Motherboard
Asus IPIBL LB
CPU
Q8200
Graphics
GT 520
Mac
  1. iMac
After a month of testing I made it work with DVI & HDMI. My Hack is running the latest update of Catalina 10.15.17 and only works with the latest Lilu and Whatevergreen kexts + @foxbox Orinoco Patch + @mattystonnie enhanced SSDT

For anyone having trouble or black screen with "XFX RX 580 GTS XXX Edition 8GB" Cards on HDMI and DVI. It runs with the following settings (For me at least).

With OS X 10.15.17 (19H2)
- Download and apply latest Lilu.kext / Whatevergreen.kext to your EFI Kexts folder
- Add Foxbox Orinoco patch to your Kernel Patches on Clover Configurator (With disabled "Inject ATi" because its not needed by Whatevergreen)
- Add "SSDT-RX580- Version 1.0.aml" from This Thread to your "EFI/Clover/ACPI/Patched" folder

Note: my motherboard has Intel 4000 IGPU, even if I disable it on bios I had to put the correct ig-platform-id on Graphics to make it work.

I hope this info helps. Cheers
 
Top