Troubleshooting iMessage Login Issues

Not open for further replies.


Staff member
Nov 17, 2009
i7 8700K
HD 630
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
With the launch of 10.8 Mountain Lion, Apple replaced iChat with the redesigned Messages app. This has the added feature of letting you login to send and receive text messages to and from any iOS device from your Mac. As long as one had configured OS X to boot from the hard drive, most logins such as Mac App Store, FaceTime, iMessage, and iCloud worked as they did on a standard Mac. However, in late December users started reporting issues logging into iMessage portion of Messages app. The error message reads: Could not sign in to iMessage. The server encountered an error processing registration. Please try again later.


If you have this error on a CustoMac, update to the latest Chimera 2.0, reboot, and try again. iMessage login should work. So what happens if this doesn't fix the issue? What happens if you're using a standard Mac? There are a few things you can try.

Option 1: Set Network Device Priority

  1. Open System Preferences > Network
  2. In lower right corner, choose the gear icon dropdown as shown below and choose Set Service Order...
  3. Drag your current network device to the top of the list. This sets your priority as en0. This is 1st priority. For multiple network device connections, make sure Ethernet is en0 (1st priority) and Wifi as en1 (2nd priority).
  4. Reboot
  5. Try iMessage login again
Option 2: Erase all Network Settings then Re-Add Devices

  1. Open Finder and navigate to /Library/Preferences/SystemConfiguration/
  2. Delete the files inside the SystemConfiguration folder
  3. Reboot
  4. Open System Preferences > Network
  5. Re-add Ethernet and/or Wifi by using the +
  6. Try iMessage login again
Option 3: Change Your Apple ID Password
Added July 2013:

You can check to see what en0 and en1 are inside /Applications/Utilities/System Information under the Network area. If none of these solutions help you, you can try a reinstall or an alternate network device. Hope this helps!

If you have any solutions that aren't listed here, feel free to add them in the comments.

If you still can't log into iMessage or FaceTime, try xzenue's FileNVRAM solution version 1.1.2 from here This module is no longer packaged with Chimera by default. To use, put FileNVRAM.dyib in /Extra/modules and reboot.

Chimera 2.0 with iMessage Login Fix


  • Screen Shot 2013-01-02 at 11.49.51 AM.png
    Screen Shot 2013-01-02 at 11.49.51 AM.png
    126.3 KB · Views: 876
Last edited by a moderator:
#1 Biggest issue I've seen on hackintoshes is a non-unique serial number, for a machine that actually matches what your SMBIOS is. Without that you will have trouble with iMessages, App Store, iCloud, etc. Yet so many people DO not have this done.
as per comment 1, thanks for telling us that, but how about telling us how to know when it matches, i have no way of knowing this.

Anyway, from what i've seen the main article here is not my issue, i even tried a clean rebuild, used the latest chameloeon wizard to generate a unique serial, and imessage still wont login "Cannot be used at this time......" errors, it seems to me so far for many people this chimera fix is only partial, ie i can login if i get my iPad/iphone etc to login using the macs credentials then login again on the hack, and although this works every time it is NOT a full fix when the hack depends on having another idevice do the validating first. Basically i beleive although progress has been made it is not yet complete (we are missing something that apple is using to validate which hacks do not have yet).

I wish i knew more than i do having only been a hackintosher for about 6 months, i'd love to be able to fix this for everyone.
What fixed it for me is by using the systemId flag and the UUID of my Hard drive..
Have tried all above, could you please tell me how though from the last comment i would no if my serial does mach my smbios (is this the selection in chameleon wizard for preconfigured SMBioses), if so i have done it.

Anyway it appears that we still only have half a solution to this problem, i've tried clean rebuilds too but still get "cannot be used at this time...." errors.

I say half solution as i can get it to work every time if i use an idevice to login then relogin on the hack, however even though this does work it means the hack is dependant on the user having another idevice to do the verification, so we ARE missing something for sure, If i knew how to sort this for everyone i gladly would but i have limited experience here only having been hackintoshing for 6 months or so.
Thanks for the comments- and your solutions- keep em coming.

Unfortunately, it's impossible to identify every possible situation where this issue could pop up. There are many variables such as initial system install setup, alternate ethernet, wifi, motherboard, peripherals, cards, that could get in the way of successful login. These solutions with recommended hardware should work as described.
Article: Troubleshooting iMessage Login Issues

Does this also fix the Messages beta expiration on mac os x Lion?
Not open for further replies.