Contribute
Register

Solved > Trouble while booting Mojave from USB

Joined
Feb 12, 2019
Messages
8
Motherboard
MSI H310M PRO VH
CPU
i3 8100
Graphics
UHD 630
Mobile Phone
Android
Hi everyone! I’m new in hackintosh, but I’m currently trying to get my first working customac with MacOS Mojave, but I’m facing some awkward issues.
I’ve made my usb stick using unibeast and I haven’t made any further customisation (except for USBInjectAll kext). After this, I’ve changed only XHCI hand-off (from disable to enable, while all the other parameters in tonymac installation guide are missing in my bios) and Clover boots correctly from the usb stick. The first error I faced was the “still waiting for root device” but I don’t know exactly if I solved it simply changing the USB port (I’ve tried all 2.0 ports) and injecting USBInjectAll kext. Anyway, I’ve kept booting, and booting, and booting, but now another error appears, both with USBInjectAll kext injected or disabled (boot args: dart=0 nv_disable=1 -V): clover stucks at “end randomseed +++++++”. I’ve been reading threads here and on reddit, but nothing has been working. What could I do?

P.S.: the usb stick I used is a 16gb sandisk usb 3
P.P.S.: the kext is located on another usb stick (8gb Kingston usb 3) created with unibeast, since I wasn’t able to reach the efi partition of the sandisk drive; when I boot from the 16gb drive clover recognises the 8gb drive but bios can’t boot directly from Kingston. Anyway, I keep connected both the drives at the same time.
 

Attachments

Last edited:
Joined
Jul 25, 2012
Messages
6,599
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Hi everyone! I’m new in hackintosh, but I’m currently trying to get my first working customac with MacOS Mojave, but I’m facing some awkward issues.
I’ve made my usb stick using unibeast and I haven’t made any further customisation (except for USBInjectAll kext). After this, I’ve changed only XHCI hand-off (from disable to enable, while all the other parameters in tonymac installation guide are missing in my bios) and Clover boots correctly from the usb stick. The first error I faced was the “still waiting for root device” but I don’t know exactly if I solved it simply changing the USB port (I’ve tried all 2.0 ports) and injecting USBInjectAll kext. Anyway, I’ve kept booting, and booting, and booting, but now another error appears, both with USBInjectAll kext injected or disabled (boot args: dart=0 nv_disable=1 -V): clover stucks at “end randomseed +++++++”. I’ve been reading threads here and on reddit, but nothing has been working. What could I do?

P.S.: the usb stick I used is a 16gb sandisk usb 3
P.P.S.: the kext is located on another usb stick (8gb Kingston usb 3) created with unibeast, since I wasn’t able to reach the efi partition of the sandisk drive; when I boot from the 16gb drive clover recognises the 8gb drive but bios can’t boot directly from Kingston. Anyway, I keep connected both the drives at the same time.
  • The verbose boot shows possible Memory Mapping issues related to missing needed AptioFix ...efi file(s) in EFI/CLOVER/drivers64UEFI folder or Actual RAM modules or Sockets on the MoBo.
  • Upload your CLOVER from the macOS Mojave USB Installer disk as a zipped file .
  • To upload CLOVER.zip, you may use the bulleted steps from #4
 
Joined
Feb 12, 2019
Messages
8
Motherboard
MSI H310M PRO VH
CPU
i3 8100
Graphics
UHD 630
Mobile Phone
Android
  • The verbose boot shows possible Memory Mapping issues related to missing needed AptioFix ...efi file(s) in EFI/CLOVER/drivers64UEFI folder or Actual RAM modules or Sockets on the MoBo.
  • Upload your CLOVER from the macOS Mojave USB Installer disk as a zipped file .
  • To upload CLOVER.zip, you may use the bulleted steps from #4
I just got back... here it is.
I took the opportunity to put USBInjectAll on sandisk, too.
Thanks for helping!
 

Attachments

Joined
Jul 25, 2012
Messages
6,599
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I just got back... here it is.
I took the opportunity to put USBInjectAll on sandisk, too.
Thanks for helping!
In your earlier post I noted now
P.S.: the usb stick I used is a 16gb sandisk usb 3
P.P.S.: the kext is located on another usb stick (8gb Kingston usb 3) created with unibeast, since I wasn’t able to reach the efi partition of the sandisk drive; when I boot from the 16gb drive clover recognises the 8gb drive but bios can’t boot directly from Kingston. Anyway, I keep connected both the drives at the same time.
  • I am a little confused that you are trying to boot with 2 USB Installer disks.
  • Whichever disk you have uploaded the CLOVER from must have Mojave Installer files and must be the ONLY macOSMojave USB Installer disk you should be connecting to the USB port for the initial installation of Mojave on the Target SSD.
  • Any and all other USB devices from other USB ports must be disconnected to reduce any conflicts/problems during installation.
  • Connect Target SSD /HDD to SATA Port-0 and DISCONNECT all other devices from SATA ports.
  • I have uploaded CLOVER zip.
  • Unzip and extract CLOVER.
  • Mount the EFI Partition of the macOSMojave USB Installer disk
  • Delete its CLOVER ( if you prefer to make a copy and save somewhere else, it is OK and then Delete the CLOVER from the EFI folder of USB )
  • Copy the extracted CLOVER and paste in place of the deleted CLOVER from USB Installer.
  • Try booting with that.
  • I have edited this CLOVER similar to a GA-Z370P-D3 motherboard's Mojave System I have, hoping it will help.
  • Please take photos of any Problem verbose boot screens or any other screens you find problems to find the next best option.
 

Attachments

Joined
Feb 12, 2019
Messages
8
Motherboard
MSI H310M PRO VH
CPU
i3 8100
Graphics
UHD 630
Mobile Phone
Android
In your earlier post I noted now
  • I am a little confused that you are trying to boot with 2 USB Installer disks.
  • Whichever disk you have uploaded the CLOVER from must have Mojave Installer files and must be the ONLY macOSMojave USB Installer disk you should be connecting to the USB port for the initial installation of Mojave on the Target SSD.
  • Any and all other USB devices from other USB ports must be disconnected to reduce any conflicts/problems during installation.
  • Connect Target SSD /HDD to SATA Port-0 and DISCONNECT all other devices from SATA ports.
  • I have uploaded CLOVER zip.
  • Unzip and extract CLOVER.
  • Mount the EFI Partition of the macOSMojave USB Installer disk
  • Delete its CLOVER ( if you prefer to make a copy and save somewhere else, it is OK and then Delete the CLOVER from the EFI folder of USB )
  • Copy the extracted CLOVER and paste in place of the deleted CLOVER from USB Installer.
  • Try booting with that.
  • I have edited this CLOVER similar to a GA-Z370P-D3 motherboard's Mojave System I have, hoping it will help.
  • Please take photos of any Problem verbose boot screens or any other screens you find problems to find the next best option.
GONNA LOVE YOU FROM THE MOON AND BACK!!!
:clap:

Your clover folder is working... I faced a couple of kernel panics but, at the end, I correctly booted MacOS!! So I need to wait forthe ssd (I should order it in a while) and, if everything goes right, I'll sign the thread as solved. Thank you very much!!
 
Joined
Jul 25, 2012
Messages
6,599
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
GONNA LOVE YOU FROM THE MOON AND BACK!!!
:clap:

Your clover folder is working... I faced a couple of kernel panics but, at the end, I correctly booted MacOS!! So I need to wait forthe ssd (I should order it in a while) and, if everything goes right, I'll sign the thread as solved. Thank you very much!!
I had to make a lot of assumptions when making that CLOVER hoping it can help you boot to macOS Utilities>DU>Erase and install on the target Disk .

Glad it worked out OK for you.:):clap:

If the CLOVER was good enough to install, you may copy and paste that CLOVER to the EFI Partition/EFI folder of the Mojave System Disk to boot it also without the need for the USB Installer.

The same steps through CCG to mount both disks's EFI Partitions to access and copy EFI Folder from USB and Delete existing EFI Folder (if any) of System Disk and paste the copied USB's EFI Folder in that place.

You need to install the kexts inside CLOVER/kexts/Other on to Library/Extensions folder of the Mojave System Disk using KextBeast and perform Repair Permission and Rebuild Cache with that Utility.

You will need to edit config.plist_Devices and Graphics SECTIONS from CLOVER of Pasted EFI to enable your Intel HD Graphics 630 to get full Resolution in your Mojave System Disk
That you can do later, once the System disk can boot on its own without the need for the USB Installer disk.
 
Joined
Feb 12, 2019
Messages
8
Motherboard
MSI H310M PRO VH
CPU
i3 8100
Graphics
UHD 630
Mobile Phone
Android
The same steps through CCG to mount both disks's EFI Partitions to access and copy EFI Folder from USB and Delete existing EFI Folder (if any) of System Disk and paste the copied USB's EFI Folder in that place.
...and for any major update/clean install I should use that with all its files, shouldn’t I?



You will need to edit config.plist_Devices and Graphics SECTIONS from CLOVER of Pasted EFI to enable your Intel HD Graphics 630 to get full Resolution in your Mojave System Disk
That you can do later, once the System disk can boot on its own without the need for the USB Installer disk.
Can I edit it with a file editor? What should I write to enable the integrated gpu?
 
Joined
Jul 25, 2012
Messages
6,599
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
...and for any major update/clean install I should use that with all its files, shouldn’t I?





Can I edit it with a file editor? What should I write to enable the integrated gpu?
  • CLOVER is unaffected by Mojave updates.
  • Instead of trying Multibeast (A tool to install CLOVER and needed kexts) I was suggesting to use a CLOVER from the USB Installer that is proven to work [CLOVER's job is to take the Disk to its destination USB to Disk Utility and System Disk to Login and the same CLOVER does both] for the System Disk and use needed kexts to be installed to System Disk's /Library/Extensions.
  • The same kexts in "CLOVER/Other" are the ones you need for your Ethernet+Video+Audio +USB controllers to work in Hard disk's Operating System too.
  • config.plist editing is to 'fine tune' the " Video" and "Audio".
  • You can use plist editor if you area familiar with it.
  • You can also try the easier Gui tool :CCG which is used to "Mount EFI" >Mount Partition > to access CLOVER>config.plist
  • CCG's Top left Panel has SECTIONS menu: "ACPI" to "System Parameters" of config.plist can be opened , viewed and edited.
  • The Edited config.plist can be saved by clicking the 2nd Arrow at bottom Left Panel to get a "Save As.. " dialog box [See image]
 

Attachments

Joined
Feb 12, 2019
Messages
8
Motherboard
MSI H310M PRO VH
CPU
i3 8100
Graphics
UHD 630
Mobile Phone
Android
  • CLOVER is unaffected by Mojave updates.
  • Instead of trying Multibeast (A tool to install CLOVER and needed kexts) I was suggesting to use a CLOVER from the USB Installer that is proven to work [CLOVER's job is to take the Disk to its destination USB to Disk Utility and System Disk to Login and the same CLOVER does both] for the System Disk and use needed kexts to be installed to System Disk's /Library/Extensions.
  • The same kexts in "CLOVER/Other" are the ones you need for your Ethernet+Video+Audio +USB controllers to work in Hard disk's Operating System too.
  • config.plist editing is to 'fine tune' the " Video" and "Audio".
  • You can use plist editor if you area familiar with it.
  • You can also try the easier Gui tool :CCG which is used to "Mount EFI" >Mount Partition > to access CLOVER>config.plist
  • CCG's Top left Panel has SECTIONS menu: "ACPI" to "System Parameters" of config.plist can be opened , viewed and edited.
  • The Edited config.plist can be saved by clicking the 2nd Arrow at bottom Left Panel to get a "Save As.. " dialog box [See image]
Can I use this tool to install clover bootloader on the ssd (and then replace the clover folder that this app creates with my (or, it’s better to say “your” lol) clover folder that I have on the USB?
I’m waiting for the ssd and imagine myself using macOS every day is freaking me out...
 
Joined
Jul 25, 2012
Messages
6,599
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Can I use this tool to install clover bootloader on the ssd (and then replace the clover folder that this app creates with my (or, it’s better to say “your” lol) clover folder that I have on the USB?
I’m waiting for the ssd and imagine myself using macOS every day is freaking me out...
Can I use this tool to install clover bootloader on the ssd (and then replace the clover folder that this app creates with my (or, it’s better to say “your” lol) clover folder that I have on the USB?
  • You can use your circuitous method of first installing a latest Clover EFI from Sourceforge.net on to the hidden EFI Partition of System SSD as a temporary space holder with its CLOVERFileTree and then just remove that CLOVERFileTree and REPLACE it with the CLOVER folder from the USB installer as second step. :)
    • It will work just the same way as I had described by direct copy & paste on mounted EFI Partitions.:)
I’m waiting for the ssd and imagine myself using macOS every day is freaking me out...
  • Using Hackintosh is like Macintosh.
    • Making Hackintosh is the Herculean Task. We are trying to use hardware made for Windows to function as Real Mac! Its like converting Graphite into Dimond!
 
Top