Contribute
Register

Trouble in Mavericks with no -v -x params | Z97N-WiFi

Status
Not open for further replies.
Joined
Feb 21, 2014
Messages
28
Motherboard
GA-Z97X-UD5H
CPU
i7-4770K
Graphics
ASUS GTX 650 1GB
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. Android
Hello guys, i'm having some trouble with my new mavericks install.

Today I have finally finished building my new PC, these are my specs:
i7 4770k
Z97N-WiFi
2x4GB Vengeance Red 1600MHz CL9
Samsung 840 120GB (for Windows only)
WD Green 1.5TB 64MB Cache (for data Windows + Hackintosh)
OCZ Agility 3 60GB (for Hackintosh only)

The problem is that I can't boot the setup without params. I can reach it only with -v -x params, and then continue the setup. Without these params i got errors like deadbeef. I noticed that after a clean setup, it get stuck while the Apple logo is loading something. The only way I can boot is using -v -x params, even after installing kext.

I also can't reboot, if i choose to reboot inside my hackintosh (which is still running in -v -x mode, so in compatibility mode), the session got closed but I understood that something is going wrong with the ACPI.. the system is completely frozen, everything is powered up, but the CPU isn't working. So I have to reset the system or shutdown it manually.

What do you suggest to do? Sometimes after reaching the disk utility (with no params) to prepare my SSD, the setup freezes and I'm forced to reboot manually, avoiding me to complete setup.

I was reading that could be a bluetooth-related problem, launching the system using -v mode I can notice that the system wait a long long time for a response (from a bluetooth kext maybe?)

Any help would be appreciated
 
Joined
Jun 14, 2014
Messages
4
Motherboard
Ga H97N WIFI
CPU
Core i5-4690
Graphics
Gigabyte GTX760 Windforce 2x
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
Hello, can you borrow a graphic card? My system boots since i disabled the IGPU in bios.
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,935
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Feb 21, 2014
Messages
28
Motherboard
GA-Z97X-UD5H
CPU
i7-4770K
Graphics
ASUS GTX 650 1GB
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. Android
After a clear setup and no kext installed, i've installed the http://www.tonymacx86.com/graphics/...phics-acceleration-9-series-motherboards.html patch but I still can't boot pretty well. Kernel panic (cpu 0 caller) if I don't boot using -x -v

Reboot and shutdown doesn't work properly, seems that something with the ACPI is wrong. (It seems like old Windows PCs when you had to remove the power after a shutdown)
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,935
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Feb 21, 2014
Messages
28
Motherboard
GA-Z97X-UD5H
CPU
i7-4770K
Graphics
ASUS GTX 650 1GB
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. Android
OS X: no support 9 Series.
Are you using IGPEnabler=Yes?
Chimera HD Graphics Bootflags: IGPEnabler, IGPlatformID, and IGPDeviceID

Still not working..

IMG_20140621_002216.jpg
 
Joined
Feb 21, 2014
Messages
28
Motherboard
GA-Z97X-UD5H
CPU
i7-4770K
Graphics
ASUS GTX 650 1GB
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. Android
Discrete graphics card.

I was looking at some GPUs like GT640, but I found only the 1GB version, which is not suggested in the CustoMac list, should it be compatible too?

Are AMDs discrete cards compatible? I don't want to spend a lot of money (HD4600 is enough to play FIFA14 on Windows and that's the maximum power that I need from a graphic card)
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,180
Motherboard
Gigabyte Z690 Aero G
CPU
i5-12600K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
I had a AMD/ATI 6450 on the shelf and used it in a H97N-WIFI system. Works great to get the system running. I'm now using dual monitors with HD4600 (on-board graphics) after using toleda's modified Azul's kext and his graphics_intel_hd5k-azul-d-90_patch.command.
 
Status
Not open for further replies.
Top