Contribute
Register

TP-Link TL-WN851ND 300 Mbps PCI Wi-Fi adapter with OS X El Capitan ?

Status
Not open for further replies.
Joined
May 19, 2014
Messages
9
Motherboard
Asus PRIME Z270-A
CPU
Intel Core i7-7700K @ 4,20 GHz
Graphics
Intel HD Graphics 630 / EVGA GeForce GTX 1070 FTW2
Mac
  1. iMac
Mobile Phone
  1. Android
[SOLVED] TP-Link TL-WN851ND 300 Mbps PCI Wi-Fi adapter with OS X El Capitan ?

Hello guys I've a new TP-Link PCI Wi-Fi adapter it's the famous TL-WN851ND model I've installed an ar9227 kext (IO80211Family.kext) with Kext Wizard and Wi-Fi is now recognized in Wi-Fi settings but it not founds any Wi-Fi access point :(

Ideas ? Or new kext ? Running OS X El Capitan

Sorry for my bad english

Best regards
 
Joined
Nov 21, 2015
Messages
3
Motherboard
Gigabyte Z97X-UD3H-
CPU
Intel Core i7-4790K
Graphics
EVGA GTX 750 Ti
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi Guys,

I installed this kext and now my TP-Link TL-WN851ND 300Mbps works, but after a couple of secs the whole system freezes.

Any ideas?

Thanks!
 
Joined
Jun 4, 2015
Messages
2
Mac
Classic Mac
Mobile Phone
In my case it works but in a few minutes the wifi stop working (it losts the signal and it doesn't find any wifi).
 
Joined
May 19, 2014
Messages
9
Motherboard
Asus PRIME Z270-A
CPU
Intel Core i7-7700K @ 4,20 GHz
Graphics
Intel HD Graphics 630 / EVGA GeForce GTX 1070 FTW2
Mac
  1. iMac
Mobile Phone
  1. Android
Impossible to enable Wi-Fi after update El Capitan 10.11.2...

If I delete Wi-Fi from the list of connections I can't re add it... ****ing bull****
 
Joined
Dec 29, 2015
Messages
29
Motherboard
GA-Z97P-D3
CPU
i7-4970K
Graphics
GT 740
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I did it some test


On my hackintosh with El Capitan 10.11.2 and a PCI card (not pci-e) WN881ND ( 13$ on amazon).
I downloaded DPCIManager | Free System Administration software downloads at SourceForge.net

Note the Vendor, device of the Atheros chipset PCI card ,OK I'll have only one info to change .
Edit the PLIST , put my "device" ID in place of another.
Put back the modified KEXT in /System/Library/Extension, witch KextBeast
Reboot the hackintosh..
Tadaaaaam the Airport logo appears now, and it's usable.
5 minutes to have Wifi on the hackintosh :headbang:

EDIT : FREEZE after install , FREEZE after reboot & login ...
Some google search here... And : modification in my Z97 motherboard (Gigabyte) BIOS : MIT/Memory Settings/Memory enhancement settings => Enhanced stability.

EDIT2 : FREEZE again but after 2 or 10 minutes : removing the card :-X :-X , no more Freeze.

Well maybe it's a Gigabyte Z97 new problem: nothing appears in the syslog/messages via Console before freezing. Freeze are not Kernel Panic and so very difficult to analyze.
 
Joined
Jan 18, 2016
Messages
1
Motherboard
Z97 Asus sabertooth mark 2
CPU
Intel i7 4790k
Graphics
Intel hd 4600
Mac
Classic Mac
Mobile Phone
Have you guys had any luck with this on El Capitan 10.11.2? I am running into problems with the WN881ND, I installed the IO80211Family kext with kextbeast. It shows the wifi sign in the upper right corner but it does not find any networks.
Any help maybe?
 
Joined
Nov 13, 2012
Messages
17
Motherboard
Gigabyte Z97-HD3 v2.1
CPU
i5-4690k
Graphics
HD4600/GTX 960 2GB
Mac
Classic Mac
Mobile Phone
I think this card is a very bad idea to use with a Hack.
I just finished building and I get a false sense of security when I boot the system after patching the kext with my device ID, installing with Kext tool, repairing permissions and booting.
I can connect to WiFi fine, I browse, download, have fun.
And then I restart my computer... Crash, crash.. Log in... Three seconds pass, crash. Restart, crash before login screen. Crash again, crash.
I get maybe 10-15 crashes, if I boot in airplane mode, no problem.
As soon as I turn on Wifi, clock is ticking to a crash.
Remove the card, 100% stable.
Stay away from the WN881ND.
ONLY use the 4800 or even a USB stick. This card is BAD news.
 
Joined
Jan 27, 2013
Messages
37
Motherboard
GA-B85-HD3 by Gigabyte
CPU
i3 4330
Graphics
GTX 770
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
So none has any luck with it?
I faced most of these problems too with the modified kext..
It is such a pitty it doesn't work in El Capitan... It was such a straightforward card back in the day.:confused::confused:
 
Joined
Jul 24, 2011
Messages
68
Motherboard
Gigabyte GA-Z97-HD3
CPU
i5 4670K
Graphics
Intel HD 4600
Mac
  1. Mac mini
Mobile Phone
  1. Android
The following works for my TP-Link TL-WN881ND PCIe x1.

Open the file /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros40.kext/Contents/Info.plist as sudo with a decent text editor (nano, vi, ...) and add <string>pci168c,2e</string> so it looks like

Code:
...
<string>pci168c,30</string>
<string>pci168c,2a</string>
<string>pci106b,0086</string>
<string>pci168c,1c</string>
<string>pci168c,23</string>
<string>pci168c,24</string>
<string>pci168c,2e</string>
...

You may have to rebuild caches and repair permissions before rebooting.
 
Status
Not open for further replies.
Top