Contribute
Register

[TOOL] Virtual Bios Mod without flashing

Joined
Oct 19, 2019
Messages
688
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
  2. iOS
  3. Other
Could you please make a VirtualBiosMod for Asus ROG GL502VSK? To disable the Gtx 1070 in particular. Thx in advance!
Sure, i will adapt a vbm to your bios, i will let you know when done.
 
Joined
Oct 19, 2019
Messages
688
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
  2. iOS
  3. Other
Could you please make a VirtualBiosMod for Asus ROG GL502VSK? To disable the Gtx 1070 in particular. Thx in advance!
Please test the attached efi file built for your GL502V
 

Attachments

  • VirtualBiosMod.GL502V.zip
    22.5 KB · Views: 16
Joined
Jun 7, 2021
Messages
4
Motherboard
ASRock2
CPU
i7 7700hq
Graphics
gtx 1070
Okay so I chose V to switch graphics card. VBM says switched to intel. But Windows 10 and macOS Catalina still defect the Gtx 1070. Could this be because I have NVIDIA boot args in OpenCore config?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,269
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Okay so I chose V to switch graphics card. VBM says switched to intel. But Windows 10 and macOS Catalina still defect the Gtx 1070. Could this be because I have NVIDIA boot args in OpenCore config?
please read the faq for proper hardware profile setup:
 
Joined
Oct 19, 2019
Messages
688
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
  2. iOS
  3. Other
Okay so I chose V to switch graphics card. VBM says switched to intel. But Windows 10 and macOS Catalina still defect the Gtx 1070. Could this be because I have NVIDIA boot args in OpenCore config?
Please update your hardware profile to match your computer.
You may need to remove all Nvidia related settings from your opencore config and check again.
The VBM does save the new settings right (green ok)? After reboot are still with new changes those variables?
 
Joined
Jun 7, 2021
Messages
4
Motherboard
ASRock2
CPU
i7 7700hq
Graphics
gtx 1070
Please update your hardware profile to match your computer.
You may need to remove all Nvidia related settings from your opencore config and check again.
The VBM does save the new settings right (green ok)? After reboot are still with new changes those variables?
Yes the new settings display the green okay. Removed all Nvidia settings from the opencore config too. Gtx 1070 still shows in both windows and Mac
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,269
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Yes the new settings display the green okay. Removed all Nvidia settings from the opencore config too. Gtx 1070 still shows in both windows and Mac
As per rules, please update your hardware profile to allow others to help you easier

please read the faq for proper hardware profile setup:
 
Joined
Aug 22, 2018
Messages
367
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
So I had a BIOS update like an hour ago. It was at 0% when the laptop suddenly shut down, was connected to charger and all, just out of nowhere. Now it won't start anymore. Black screen and turning off after some time. Removed CMOS battery, battery, all. Nothing.
 
Joined
Oct 19, 2019
Messages
688
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
  2. iOS
  3. Other
So I had a BIOS update like an hour ago. It was at 0% when the laptop suddenly shut down, was connected to charger and all, just out of nowhere. Now it won't start anymore. Black screen and turning off after some time. Removed CMOS battery, battery, all. Nothing.
Pfff, this is very unfortunate, i had issues sometimes not powering up, i found that if i power down with power cable connected then remove the power cable and then press power again it starts, you can try this too, but if the flash was damaged only a hardware flash can help.
 
Joined
Aug 22, 2018
Messages
367
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
Nothing... I don't have a flasher. Of course I have backups, but they're useless now. The thing is, it happened during an official update. I did nothing. (literally, I was just watching) I'll try to contact Asus, but they're asleep now (timezones).
 
Top