Contribute
Register

[TOOL] VGTab: Control your Vega in macOS without flashing the vBios

pastrychef

Moderator
Joined
May 29, 2013
Messages
9,006
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Thank you. Just tried inject table into CLOVER config.plist . And its very very very bad(( When start OS its normal - about 800rpm. Then after 1 minute of Unigine Heaven benchmark temp 77 and 3800 rpm. Then After stop benchmark temp about 50 and 4000rpm even after 5 minutes!! its very very loud still , when i am writing this message its about 3000 rpm. And i spotted one common issue after many many tries vgtab. After stoping benchmark when temp is down, fan spinnig more faster exactly after stop benchmark.
With the settings in my kext and my card, my temps never reach 75C, usually around 72C, when running Heaven.

Why is your utilization at 23% after the benchmark is done? Even with your fan at 4000+RPM, the temp is 39C. That's very high.

Also, why use config.plist to inject? Why not just use the kext?
 
Joined
May 13, 2012
Messages
22
Motherboard
GA-Z97M-D3H
CPU
i7-4790K
Graphics
RX 580
Mac
iMac
Mobile Phone
Android, iOS
With the settings in my kext and my card, my temps never reach 75C, usually around 72C, when running Heaven.

Why is your utilization at 23% after the benchmark is done? Even with your fan at 4000+RPM, the temp is 39C. That's very high.

Also, why use config.plist to inject? Why not just use the kext?
Now utilization is 0%. Maybe its not immediately throw down to zero i dont know. Thats what i am talking about: after gpu job is done fan rpms start RISING. its so stupid.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
9,006
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Ok i will try your kext now. but none of my kexts did not work and did not affect - only plist.
I have all my hackintosh kexts in /EFI/CLOVER/kexts/Other/ and it works fine.
 
Joined
May 13, 2012
Messages
22
Motherboard
GA-Z97M-D3H
CPU
i7-4790K
Graphics
RX 580
Mac
iMac
Mobile Phone
Android, iOS
I have all my hackintosh kexts in /EFI/CLOVER/kexts/Other/ and it works fine.
Yes just rebooted and fan starts rising without benchmark or anything - kext did not affect on fan at all when i put it into /EFI/CLOVER/kexts/Other/ (
 

Attachments

pastrychef

Moderator
Joined
May 29, 2013
Messages
9,006
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Yes just rebooted and fan starts rising without benchmark or anything - kext did not affect on fan at all when i put it into /EFI/CLOVER/kexts/Other/ (
Did you set Inject to yes?
Screen Shot 2019-05-07 at 9.46.59 PM.png
 
Joined
May 13, 2012
Messages
22
Motherboard
GA-Z97M-D3H
CPU
i7-4790K
Graphics
RX 580
Mac
iMac
Mobile Phone
Android, iOS

pastrychef

Moderator
Joined
May 29, 2013
Messages
9,006
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Thank you. I had 'detect' option instead of 'yes'. Now vgtab kexts are working. But nothing changed with this super speed fan rpm rising after gpu load is gone. ((
Yeah, I think all the people who keep their kexts in /Library/Extensions/ and/or use "Detect" have problems with the VGTab. VGTab works best in /EFI/CLOVER/kexts/Other/ and Clover kext inject set to "Yes".

At least now, you don't have to keep making changes to your config.plist every time you modify your power tables...

I don't know why your fans are not ramping down. I suggest changing settings to make your card run cooler. I spent a lot of time to make sure that my card never exceeds 75C.
 
Joined
May 13, 2012
Messages
22
Motherboard
GA-Z97M-D3H
CPU
i7-4790K
Graphics
RX 580
Mac
iMac
Mobile Phone
Android, iOS
Yeah, I think all the people who keep their kexts in /Library/Extensions/ and/or use "Detect" have problems with the VGTab. VGTab works best in /EFI/CLOVER/kexts/Other/ and Clover kext inject set to "Yes".

At least now, you don't have to keep making changes to your config.plist every time you modify your power tables...

I don't know why your fans are not ramping down. I suggest changing settings to make your card run cooler. I spent a lot of time to make sure that my card never exceeds 75C.
Thank you. But seems i am not alone with this problem. I do not need super performance and already experimented whole day with low voltage and frequences. But problem with big cooldown and rising rpm still remains. In windows this vega works like a charm. Low temps and low rpms even in turbo mode(
 
Top