Contribute
Register

TL-WN851ND/Atheros AR9227 Yosemite Problem.

Status
Not open for further replies.
Joined
May 1, 2013
Messages
6
Motherboard
Teras
CPU
Intel Core i5 3570K
Graphics
Nvidia GTX 550Ti
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Hey guys, i just got Yosemite Working and booting flawlessly on my Asrock Z77 Extreme Pro 3.
But i cannot get my PCI Wi-Fi Card (TL-WN851ND/Atheros AR9227) working...I tried many Kexts and solutions but i can't get it working.

It was working perfectly under Mavericks, I tried to install the old kext but it doesn't boot afterwards.

What should i do?

My Specs:
-Intel Core i5 3570K Ivy Bridge
-8GB of RAM (2x4 DDR3)
-GTX 550 Ti
-WD Blue Caviar 640GB
-Asrock Z77 Extreme Pro 3
-TL-WN851ND/Atheros AR9227 (The one i can't get working)
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,016
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hey guys, i just got Yosemite Working and booting flawlessly on my Asrock Z77 Extreme Pro 3.
But i cannot get my PCI Wi-Fi Card (TL-WN851ND/Atheros AR9227) working...I tried many Kexts and solutions but i can't get it working.

It was working perfectly under Mavericks, I tried to install the old kext but it doesn't boot afterwards.

What should i do?

My Specs:
-Intel Core i5 3570K Ivy Bridge
-8GB of RAM (2x4 DDR3)
-GTX 550 Ti
-WD Blue Caviar 640GB
-Asrock Z77 Extreme Pro 3
-TL-WN851ND/Atheros AR9227 (The one i can't get working)

I don't see AR9227 listed in the guide as supported: http://www.tonymacx86.com/network/104850-guide-airport-pcie-half-mini-v2.html
 
Joined
May 1, 2013
Messages
6
Motherboard
Teras
CPU
Intel Core i5 3570K
Graphics
Nvidia GTX 550Ti
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
That's the thing, in mavericks i found a Kext that worked flawlessly. but now it doesn't work. Is it a Yosemite Problem?
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,016
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
That's the thing, in mavericks i found a Kext that worked flawlessly. but now it doesn't work. Is it a Yosemite Problem?

You should find out more about what was done to that kext. You cannot use Mavericks native (or patched) WiFi kexts on Yosemite.
 
Joined
Jul 22, 2015
Messages
1
Motherboard
ASRock Z77 Extreme4
CPU
i5-3570K
Graphics
GTX 560 Ti SLI
Mac
Classic Mac
Mobile Phone
  1. iOS
Hey man I was just wondering if you ever got this issue fixed. We have nearly identical builds and I've looked all around the internet for a couple days and still haven't found anything. I got as far as getting the Wifi icon to at least show up after adding <string>pci168c,2d</string> to the IO80211Family kext. But still no Wifi.
 
Status
Not open for further replies.
Top