Contribute
Register

TL-WDN4800 not recognized in Mt.Lion

Joined
Apr 7, 2011
Messages
42
Motherboard
Asrock x299 Taichi w/Thunderbolt 3
CPU
Intel i7 7820X
Graphics
Sapphire Nitro Radeon RX 580 8GB
Mac
iMac, MacBook Pro
Mobile Phone
Android
TP LINKS TL-WDN4800 not recognized in Mt.Lion

TP LINKS TL-WDN4800 not recognized in Mt.Lion

You read it here....

All the talk about this card being natively supported is no longer the case.

This card isn't recognized at all in my Network connections.

Any ideas?

Thanks

-Scott
 
Joined
Aug 5, 2012
Messages
58
Motherboard
GA-Z77M-D3H-MVP
CPU
Core i5 3570K
Graphics
Zotac Geforce 560
Mac
Mac mini
Classic Mac
Mobile Phone
Android
Which wifi cards DO work in Mountain Lion these days? :crazy:
 
Joined
Dec 21, 2011
Messages
6
Motherboard
Gigabyte Z68MA-D2H-B3 UEFI
CPU
Intel Core i5-2500K
Graphics
Gigabyte Radeon HD 6850 1GB
Mac
Classic Mac
Mobile Phone
I've tested two PCIe 802.11n cards that work out of the box in Lion and Mountain Lion.

D-Link DWA-556, Ver. A1
http://www.newegg.com/Product/Product.aspx?Item=N82E16833127218

TP-LINK WDN4800 Ver. 1.0
http://www.newegg.com/Product/Product.aspx?Item=N82E16833704133

I switched to the TP-LINK to use the 5GHz band on my Apple Airport Extreme 5th Gen. However, it only connects on 2.4GHz.

Then I saw that the TP-LINK only supported up to channel 64, while the Airport uses channel 149 by default. Manually setting the Airport to use channel 36 on 5GHz got it working.

Code:
en1:
  Card Type:		AirPort Extreme  (0x168C, 0x3112)
  Firmware Version:	Atheros 9380: 4.0.70.23-P2P
  MAC Address:		[I]xx:xx:xx:xx:xx:xx[/I]
  Locale:		Unknown
  Country Code:	
  Supported Channels:	1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64
  Wake On Wireless:	Supported
  AirDrop:		Supported
  Status:		Connected
  Current Network Information:
	...
	PHY Mode:	802.11n
	BSSID:		[I]yy:yy:yy:yy:yy:yy[/I]
	Channel:	36,-1
	Country Code:	
	Network Type:	Infrastructure
	Security:	WPA2 Personal
	Signal / Noise:	-34 dBm / -92 dBm
	Transmit Rate:	450
	MCS Index:	23
 
Joined
Jul 26, 2012
Messages
6
Mac
Mac Pro
SOLVED!!! TL-WDN4800 not recognized in Mt.Lion

hi

this card work perfect in mountain lion just attached you device id to info.plist of AirportAtheros40.kext update your system cache with kext utility Restart that 's all ...
 
Joined
Apr 7, 2011
Messages
42
Motherboard
Asrock x299 Taichi w/Thunderbolt 3
CPU
Intel i7 7820X
Graphics
Sapphire Nitro Radeon RX 580 8GB
Mac
iMac, MacBook Pro
Mobile Phone
Android
That's the one I have.
I got it to be recognized once, but never again.
Can't even see the device ID.... :(

Update: Managed to get it recognized and working. Still trying to figure out how to assign device ID


I've tested two PCIe 802.11n cards that work out of the box in Lion and Mountain Lion.


TP-LINK WDN4800 Ver. 1.0
http://www.newegg.com/Product/Product.aspx?Item=N82E16833704133

I switched to the TP-LINK to use the 5GHz band on my Apple Airport Extreme 5th Gen. However, it only connects on 2.4GHz.

Then I saw that the TP-LINK only supported up to channel 64, while the Airport uses channel 149 by default. Manually setting the Airport to use channel 36 on 5GHz got it working.

Code:
en1:
  Card Type:		AirPort Extreme  (0x168C, 0x3112)
  Firmware Version:	Atheros 9380: 4.0.70.23-P2P
  MAC Address:		[I]xx:xx:xx:xx:xx:xx[/I]
  Locale:		Unknown
  Country Code:	
  Supported Channels:	1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64
  Wake On Wireless:	Supported
  AirDrop:		Supported
  Status:		Connected
  Current Network Information:
	...
	PHY Mode:	802.11n
	BSSID:		[I]yy:yy:yy:yy:yy:yy[/I]
	Channel:	36,-1
	Country Code:	
	Network Type:	Infrastructure
	Security:	WPA2 Personal
	Signal / Noise:	-34 dBm / -92 dBm
	Transmit Rate:	450
	MCS Index:	23
 
Joined
Aug 6, 2012
Messages
11
Motherboard
OS X Mountain Lion 10.8.2
CPU
Core i5 3570K
Graphics
Galaxy GTX 460 1GB
Mac
MacBook Pro
Classic Mac
Mobile Phone
Android, iOS
Mine works just fine!!
 
Joined
Dec 7, 2010
Messages
354
Motherboard
Gigabyte X58A UDR3-R v2.0 bios FF OC to 3.84 Ghz
CPU
Core i7 960
Graphics
Gigabyte HD6870
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Mobile Phone
iOS
yes, tplink just works. No problem here.
 
Joined
Dec 12, 2010
Messages
2
Motherboard
H55mUSB3.0
CPU
i3 2.94
Graphics
Geforce 210 1GB
Mac
iMac
Classic Mac
Mobile Phone
I have a singular problem -

My mother board is H55M USB3
and I dont have a 16x PCIe slot on my motherboard.
I have earlier used the Tp-Link wn651G pci card for all my snow leopard and lion
but on update to mountain lion my card was not recognised.

so i got the TL-WDN4800 and a PCI to PCIe converter - but the card is NEVER recognised.

ANY HELP ... I otherwise have a great build.

i3 2.94
8GB
GEforce 210 1GB


That's the one I have.
I got it to be recognized once, but never again.
Can't even see the device ID.... :(

Update: Managed to get it recognized and working. Still trying to figure out how to assign device ID
 
Joined
Jan 3, 2012
Messages
33
Motherboard
GA-Z77X-UD5H [rev 1.0]
CPU
Intel Core i7 3770 3.4GHz Socket 1155 8MB Cache
Graphics
Gigabyte GTX 560Ti OC 1GB GDDR5 Dual DVI Mini HDMI Out PCI-E
Mac
Classic Mac
Mobile Phone
Same here, I've plugged it in, re-booted, unplugged, plugged in after booting, and even though all other hardware is working 100% fine with no hassle the TL-WDN4800 has never once been recognized in Mt.Lion. Starting to get highly annoying.
 
Joined
Jan 3, 2012
Messages
33
Motherboard
GA-Z77X-UD5H [rev 1.0]
CPU
Intel Core i7 3770 3.4GHz Socket 1155 8MB Cache
Graphics
Gigabyte GTX 560Ti OC 1GB GDDR5 Dual DVI Mini HDMI Out PCI-E
Mac
Classic Mac
Mobile Phone
yes, tplink just works. No problem here.
*facepalm*

Ignore my above comment, I accidentally brought the "TP-Link 300mbps Wireless N Pci Express Adapter" (TL-WN881ND) which I presume will not work ...
Just ordered a TL-WDN4800 and will report back soon.
 
Top